2

I added a new user to a fresh Raspbian Lite install (4.14 2019-04-08, Raspbian Stretch Lite). On a pi zero, I had direct access and had signed in as the pi user. Via Wifi I had authenticated as the new user.

As the pi user I did:

pi@rpizero:~ $ touch hello

As the newuser I did:

newuser@rpizero:~ $ ll ../pi/
.ansible/      .bash_history  .bash_logout   .bashrc        hello          .profile       
newuser@rpizero:~ $ rm ../pi/hello 
rm: remove write-protected regular empty file '../pi/hello'? 
newuser@rpizero:~ $ ll ../pi
-bash: ll: command not found

Restarting the device does not help as the ll command is still not found.

Why did the ll command "get destroyed" when trying to remove the hello file? Very confused.

6

There is no standard ll command. Often there is an alias that defines ll as ls -l.

The output in your question is not from ls -l.

It seems that you have typed ll ../pi/ at the shell prompt and then pressed the Tab Key. This resulted in the display of the available completions. This is a function of the shell and doesn't check whether a command ll is available.

After you removed ../pi/hello, you didn't use tab completion, you tried to execute the ll command/alias.

The most likely explanation is that you never had an alias ll defined, and the removal of the file ../pi/hello had no effect on that.

  • I think I must have hit the tab key subconsciously. Thanks. I feel like I should delete my question due to serious * facepalm *... what do you think? – AJP May 31 at 11:22
  • 1
    It is a valid question, and others may have the same problem. – RalfFriedl May 31 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.