I want to use tor browser on my rasberry pi3b+ and I've used terminal by typing: sudo apt-get tor, it worked. But when I run tor in terminal it failed.

it says that :

Could not bind to already in use. Is Tor already running?
Failed to parse/validate config: Failed to bind one of the listener ports.
Reading config failed--see warings above

Sorry, I'm a beginner of such things, could anyone teach me about that?

  • 1
    Did you verify whether it is already running? Or is something else using that port?
    – RalfFriedl
    May 31, 2019 at 12:41
  • sorry i don't know how to check whether it is already running.can you give me some guides? May 31, 2019 at 13:02
  • Check lsof -i TCP:9050 (you may have to apt install lsof first) and sudo ps -A | grep -i tor (this is a catchall for any process name with "tor", case insensitive, in it; you may know something more specific if this turns up too much junk but I don't think it will).
    – goldilocks
    May 31, 2019 at 13:36
  • Are you running tor using the word “sudo” before your command? May 31, 2019 at 17:02

1 Answer 1


You installed the tor service that can only be used by applications directly. At the tor project you will find at Configure your applications to use Tor:

If you want to use Tor for anonymous web browsing, please use Tor Browser. It comes with readily configured Tor and a browser patched for better anonymity. To use SOCKS directly (for instant messaging, Jabber, IRC, etc), you can point your application directly at Tor (localhost port 9050, or port 9150 for Tor Browser), but see this FAQ entry for why this may be dangerous.

Unfortunately the Tor Browser isn't available directly for Raspbian/Debian from the default repository. You have to install it from the Debian backports site. How to do it you can look at Install from official repository.

  • I tried but it shows that active(exited) Jun 1, 2019 at 0:29
  • @WayneSun Sorry, given the wrong service name. Please look at the status of [email protected]. I have corrected the answer.
    – Ingo
    Jun 1, 2019 at 16:58
  • Hi, thank you for correction.I did see it said active(running) but when I was going to test whether Tor works by using the link you give, the website shows that "Sorry. You are not using Tor." Maybe there is something wrong with my configuration? since I didn't set anything after typing the command sudo apt-get tor. Jun 2, 2019 at 7:12
  • @WayneSun Ah OK, I understand your problem now. I have rewritten my answer how to use the Tor Browser instead of tor directly.
    – Ingo
    Jun 2, 2019 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.