0

I want to use with OpenCV the library dlib, I installed in my virtual environment. I'm sure because with pip list appears:

(Thesis_env) pi@raspberrypi:~/Environments $ pip list Package Version


Babel 2.6.0
certifi 2019.3.9 chardet 3.0.4
debtcollector 1.21.0

dlib 19.17.0

dnspython 1.16.0
eventlet 0.24.1
fasteners 0.14.1
greenlet 0.4.15
idna 2.8
iso8601 0.1.12
monotonic 1.5
msgpack 0.6.1
netaddr 0.7.19
netifaces 0.10.9
numpy 1.16.3
opencv-python 3.4.4.19 os-win 4.2.0
oslo.concurrency 3.29.1
oslo.config 6.9.0
oslo.context 2.22.1
oslo.i18n 3.23.1
oslo.log 3.43.0
oslo.serialization 2.29.1
oslo.utils 3.41.0
pbr 5.2.0
pip 19.1.1
pyinotify 0.9.6
pyparsing 2.4.0
python-dateutil 2.8.0
pytz 2019.1
PyYAML 5.1
requests 2.22.0
rfc3986 1.3.2
setuptools 41.0.1
six 1.12.0
stevedore 1.30.1
urllib3 1.25.2
wheel 0.33.4
wrapt 1.11.1
(Thesis_env) pi@raspberrypi:~/Environments $

But now, when I run my code, appears the error:

ImportError: No module named 'dlib'

What is wrong? This just happens with dlib.

Thank you

  • What is your command for running your code please ? the code is in a file script ? maybe try to use another version of python for calling your file (if it is a file) – Ephemeral Jun 4 at 11:20
  • Yes it's a file, I'm using python3 – NEA Jun 4 at 11:32
  • and you run your file with python version ? – Ephemeral Jun 4 at 11:52
  • version 3 too :( – NEA Jun 4 at 11:53
  • Have you take a look here ? Step #4: Test out your dlib install . Try to open your virtualenv and then do : import dlib for seeing if all work. – Ephemeral Jun 4 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.