0

I'm having some trouble to re-setup my raspberryPi. I had this running before and am trying to retrace my steps after I reinstalled the whole thing. I'm struggling with pilight:

$ pilight-send -p raw --code="<CODE_WHICH_WORKED_BEFORE>"
$ cat /var/log/pilight.err
[Jun 05 17:41:43:499287] pilight-send: ERROR: invalid option -- '--code'
$ pilight-send -p raw --help
Usage: pilight-send -p raw [options]
 -H  --help         display this message
 -V  --version          display version
 -p  --protocol=protocol    the protocol that you want to control
 -S  --server=x.x.x.x       connect to server address
 -P  --port=xxxx        connect to server port
 -C  --config           config file
 -U  --uuid=xxx-xx-xx-xx-xxxxxx UUID

[raw]
 -c --code="raw"        raw code devided by spaces
                (just like the output of debug)

$ pilight-send -p raw -c "<CODE_WHICH_WORKED_BEFORE>"
$ cat /var/log/pilight.err
[Jun 05 17:45:51:779289] pilight-send: ERROR: invalid option -- '-c'

Sooo. What am I doing wrong here? I merely copied this from my old bash script so I'm not sure what happened here. Simply installed via apt packages.

1

Solved by myself. I had an error in wiring (power of 433MHz transmitter was not connected) so I connected and rebooted the Pi. The command is now working. Not sure if actually caused by wiring error or if reboot (yes, shame on me, I didn't reboot before asking) solved it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.