0

I installed Squid on my RPi-3 for use behind a DHCP router. However, the pi will not route traffic back and forth between my computer because my router's DHCP settings. I don't want to give my router a static IP, because then it will be a target, making the network unsafe. I also want to have as few hops as possible. Could someone help me?My Ideal Setup

  • 1
    Why do you think a static IP is unsafe? People are just scanning all IP address constantly, static or not. – Brick Jun 7 at 20:10
  • What do you mean by the problem being "because [of your] router's DHCP settings"? Do you mean that you don't know the WAN-side IP address of your router? (That has nothing to do with its DHCP settings.) – Mark Smith Jun 7 at 20:10
  • Static ip is dangerous because if someone gets access, they can repetitively get access instead of tracking the ip all over again. – greatdu0 Jun 7 at 20:16
  • I tried WAN IP and it didn't work. I also tried different ports (80, 443) – greatdu0 Jun 7 at 20:25
  • 1
    I think you need to explain what you're trying to achieve, what you've done, how you're testing it and how you know it isn't working. The question as it stands is unanswerable, I think. I could guess at several things which might not be right. More detail please. – Mark Smith Jun 7 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.