0

I am experiencing an issue related to wifi network sleeping or disconnecting, that has been persisting despite trying this methods:

  • Changing the power management setting to off using iwconfig wlan0 power off
  • Editing the /etc/network/interfaces file to include:

source-directory /etc/network/interfaces.d wireless-power off

but these don't seem to work. When I connect my raspberry pi to my monitor and login, thats when the wifi connects again and everything is fine.

Is there a work-around to this - such as having a script run to reboot the server and so it can activate the network or something?

Also, I'm using a raspberry A+ model.

  • What Raspbian version do you use? Is it stretch? With stretch /etc/network/interfaces isn't used by default. Also power management isn't an issue anymore since years, no need to fiddle with it. It is disabled in the driver. What server you are talking about? – Ingo Jun 12 at 11:22
  • @Ingo I’m using noobs. I’m using a raspberry pi A+ model – wpnewbie Jun 24 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.