0

Sim800l is not responding anymore after a few days of continuously working and requires restart/reset. It won’t recover by itself or respond to any commands unless a restart or power off is made. If I restart the sim800l it will work for another few days.

Same behavior on two different sim800l modules.

The module is powered by a 5v 2.5 A power supply in parallel to the raspberry pi. 115200 baud rate is set.

I have tried a DC to DC (2.5) step down buck converter to power the module with 4V 2.5A separate power supply with common GND for SIMcard, raspberry pi, and module.

I don't think poor network or Transmission burst is the problem for now. It works for 12 days in the same network conditions and then stops working for a long time.

Is someone else experiencing the same behavior? Any suggestion or information would be helpful.

8
  • "I restart the sim800l it will work for another few days." - A quick and dirty get around around is use a real time clock module such as DS3231 to hardware trigger the 5V PSU (through the LM2596 switch on/off pin) to power off/on every 3am in the morning say. There are many reasons that Rpi crashes every couple of days - (1) software buffer/file over flows or leaking, (2) 110/220VAC main power line fluctuates (3) Rpi circuit related back EMF/EMI from home appliances such as TV set, or near by huge motor/pump starts/stops (my 28 story building has huge water tank motor and elevator, eg).
    – tlfong01
    Commented Jun 11, 2019 at 8:35
  • I hope, I understood you correctly. My raspberry pi is working efficiently without any problem. I restart my Raspberry Pi once in a day. Since Sim800l is powered by another power supply it stays ON all the time. Although I perform an SW Reset i.e. Kill the PPP0 script and restarting it when there is no internet. It seems ineffective. 1 solution can be using GPIO with Mosfet to reset powersupply or Something else. Commented Jun 11, 2019 at 8:46
  • Before this, I am trying to understand what is the reason behind this problem. I will consider point (2) and (3). I think also that Point (3) can cause that in my case also. I am using some other electronic devices nearby including TV. Commented Jun 11, 2019 at 8:51
  • Ah, if you "restart Raspberry Pi once a day." , then my suggestion of restarting Rpi is not applicable. So let us focus on points (2) and (3). Let me think harder and come back later, perhaps tomorrow.
    – tlfong01
    Commented Jun 11, 2019 at 9:37
  • Just for troubleshooting, you might like to make the power supply to Rpi very stable, eg, using lipo power bank just to find where the noise/spike/back EMF, EMI comes, eg. raspberrypi.stackexchange.com/questions/99408/…
    – tlfong01
    Commented Jun 11, 2019 at 9:43

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.