0

I've been trying to debug an issue where all my homebridge devices get stuck in a "Updating" status (according to the Home app) for 15 to 30 seconds occasionally. Initially, I tried starting homebridge with pm2 start homebridge -- -D, but it didn't really tell me what was happening when the problem occurred.

I discovered that if I manually run homebridge (without pm2) using DEBUG='*' homebridge -D, I get much more detailed debug output that I think has the potential to tell me what's going on if it could have that mode active when the problem occurs.

But I tried pm2 start DEBUG='*' homebridge -- -D and as I suspected, that didn't work. I also tried:

export DEBUG='*'
pm2 start homebridge -- -D

but the log output from doing that isn't detailed the level of detail I get from running it manually. (It did make pm2's output way more verbose however.)

So how do I get pm2 to start up homebridge using DEBUG='*' homebridge -D? I've tried searching the documentation for pm2, but could not find something that said how to change the way a command is issued...

  • What Raspberry Pi model do you use? What operating system? What is pm2? I cannot find anything about homebridge in the default repository. Where do you get it? How do you install it? – Ingo Jun 13 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.