0

I need to use libssl-dev 1.0.2g to compile some old codes.

I followed the guides in stackoverflow but it does not work in my case. This is my /etc/apt/sourcelist

deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
deb http://ftp.us.debian.org/debian/ stretch main contrib non-free rpi
deb-src http://ftp.us.debian.org/debian/ stretch main contrib non-free rpi

From apt-cache madison openssl1.0, I can see:

openssl1.0 | 1.0.2r-1~deb9u1 | http://ftp.us.debian.org/debian/ stretch/main Sources**

But running sudo apt-get install openssl1.0 gives:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package openssl1.0
E: Couldn't find any package by regex 'openssl1.0'

Please let me know if you have any insight or ideas. Thanks a lot!

0

Please only us openssl1.0 is you really need to. Otherwise, use the newer and more secure openssl1.1.

To tell apt to use the old version from the jessie repository (which you already have in your sources.list) , you have to add /jessie to the end. For example:

$ sudo apt install openssl/jessie
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Selected version '1.0.1t-1+deb8u11' (Raspbian:oldstable [armhf]) for 'openssl'
The following additional packages will be installed:
  libssl1.0.0

And for the libary you can just do sudo apt install libssl1.0.0.

  • Thanks for answering but the version that I need is 1.0.2g. To install version 1.0.1 is easy and straightforward. This is for compiling legacy codes. – Dave Jun 13 at 6:18
  • @Dave you might have to compile from source then. – scitronboy Jun 13 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.