-1

When I start up my Raspberry Pi it goes through the lines of code like usual but ends at "end Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2)". I have tried to get to the place you get to by holding shift when I turn on the computer to fix the problem but that's not working either, it just goes through the normal code with "end Kernel Panic" at the end!!! IT IS SO ANNOYING I HAVE TRIED EVERYTHING I CAN BUT NOTHING WORKS!!! PLEASE HELP NOW!!! I don't want the computer to go to waste! AARGH SOMEBODY HELP ME. 😢😢😢

  • 2
    If you search this site you will find hundreds of posts with that error – Milliways Jun 14 at 2:44
  • The error message means partition 2 on your SD Card is either missing, faulty or has been corrupted. Without detail of what OS, what you did or whether it ever worked it is impossible to be more precise. – Milliways Jun 14 at 6:44
  • Please don't cry so much with capital letters and multiple exclamation marks. And please take the short Tour and visit the Help Center to get an idea how things work here. You may also have a look at the The Boot Problems Sticky. – Ingo Jun 14 at 14:17
0

not syncing: VFS: Unable to mount root fs on unknown-block(179,2) means your SDCard's root filesystem is corrupt and in need of a fsck.

The automatic fsck during boot was unable to run.

So you'll need to mount that SDCard in any other Linux system and run sudo fsck -f -y /dev/sdb2 [Note: check the device name].

That other Linux system could be you laptop booted from a live Linux CD/USB stick or it could be your Raspberry booted from another SDCard or a USB stick. Don't use Windows - it doesn't know how to access EXT4 filesystems.

  • I only have Mac OS and no Linux. What do I do? – BodnarGeoFS Jun 18 at 4:58
  • You have a Raspberry. Get a new SDCard and you can have a Linux rescue system. – Dougie Jun 18 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.