1

I booted and used my Raspberry for the first time yesterday. I used USB mouse, keyboard and monitor first, enabled ssh and vnc and established connections with my Windows laptop going forward.

I did the same procedure with another Raspberry today. Both have identical SD cards in them which came directly from the seller (got everything together from work). Ultimately I need to run OPC UA server and client applications on them.

Just now I tried booting both at the same time. The one from today works just fine. The one I set up yesterday doesn't do anything. Red light is on, green light blinks 4 times with a few seconds staying on after, then repeating the cycle.

Prior answers to people encountering similar issues suggested the SD was somehow corrupted and start.elf could not be launched.

However, I tried putting the SD card from the other Raspberry in and it shows the same behavior. Also, I can put either SD card in the other Raspberry and it works just fine. Same for the power supply. I haven't found any answer so I would assume this is not a duplicate.

Any help is greatly appreciated.

Update: I managed to boot from a USB stick instead, following the instructions here: How to boot from a USB mass storage device on a Raspberry Pi And it showed the color screen and something after that for a few seconds (rearranging root or something like that, I suppose to start the installation). However, the screen went black, the green light stopped doing anything. Thereafter, whenever I have a USB drive plugged in and connect the raspberry to power, it takes around 30 seconds until the green LED starts showing the usual 4 blinks.

  • Ah, the 2 identical Rpi's, green LED blinking 4 times is a misery. No one know how to solve it. I spent much time but still no luck. – tlfong01 Jun 18 at 6:08
  • what model is the one that is working, what model is the one that is not working? – oh.dae.su Jun 18 at 19:58
  • @oh.dae.su both are Raspberry Pie 3 B+ and were bought at the same time, from the same vendor (made in the UK I guess, would need to ask the purchasing department for more details) – Lorenz Mohr Jun 20 at 16:13
  • If they are the same kind, then I am out of ideas. – oh.dae.su Jun 21 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.