0

I have a Timecapsule with some USB drives attached to it. I can access it just fine from OSX. I can also access it via smbclient on my Raspberry Pi:

smbclient -U foobar //192.168.1.1/drive                                                                             
WARNING: The "syslog" option is deprecated
Enter foobar's password:
Domain=[WORKGROUP] OS=[Apple Base Station] Server=[CIFS 4.32]
smb: \> ls
  .                                   D        0  Tue Feb 12 20:36:00 2019
  ..                                  D        0  Tue Dec 25 19:15:36 2018
  .com.apple.timemachine.supported      H        0  Tue Dec 12 19:26:41 2017
  .DS_Store                           H     6148  Mon Jun 10 11:43:11 2019

                156198988 blocks of size 4096. 129774214 blocks available

But when I try to mount it via mount.cifs, I always get a file not found:

sudo mount.cifs //192.168.1.1/drive /media/drive -o username=foobar,password=somepass,sec=ntlm,uid=pi,vers=1.0 --verbose

mount.cifs kernel mount options: ip=192.168.1.1,unc=\\192.168.1.1\drive,sec=ntlm,vers=1.0,uid=1000,user=foobar,pass=********
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

The mount point exists, I tried other mount points as well. Now I am at the end of my wits. Any ideas why I get this message?

1
  • Using smb has noting to do with Raspberry Pi. You should better ask at superuser.com
    – Ingo
    Jun 21 '19 at 17:58
1

Well, I feel slightly stupid: the Pi had some uptime and turns out the kernel had been updated, but the modules would not fit unless I reboot. After a reboot cifs would work just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.