0

I have a Raspberry Pi 3B+ running Raspbian, and a Pi-Top with another Raspberry Pi 3B+ running Pi-Top OS Polaris (which is mostly Raspbian).

My issue is that they can't see nor connect to any of the Windows computers on the network. All of my software is up to date. Another piece of information that may be helpful is that all of the Windows computers on the network are in a workgroup other than WORKGROUP or HOMEGROUP.

The Raspberry Pi (and other Linux devices on the network) can see other Linux devices but not any of the Windows devices. The Windows devices consist of a mix of Windows 7 Home Premium, Windows 7 Professional, and Windows 10 Home devices. The Windows devices communicate just fine with each other and can connect to the Linux devices as long as a path is manually entered.

Messing with the Windows PCs is out of the question.

I will answer any questions that will move this forum closer to an answer to the best of my ability as long as they don't disclose my personal information.

Answers:

In response to Jaromanda X's question, on the Ubuntu device, I set it using the Samba GUI and on the Raspi's I set it in the smb.conf file.

News:

6-23-2019: On the Raspbian device something worked and now I can connect using pcmanfm but only if I input the path. On the Ubuntu device, I can connect to the windows devices but only if I input the path. Also, on the Pi-Top OS device if I delete the smb.conf file I could see other devices on the network including ones in homegroups by clicking through the network section in pcmanfm but I couldn't connect and browse the devices themselves, but when I rebooted the Pi-Top it stopped showing the computers.

  • have you changed the samba workgroup setting? – Jaromanda X Jun 23 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.