I'm pulling my hair out with this problem. All I want to do is connect my raspberry pi to the internet via WiFi.

I have model B pi, and I have a dynamode WL-700N-RXS. I have raspbmc installed and I have inserted the dynamode.

Using rasbmc settings, I have played about with all of the possible network configuration options in an attempt to get 'Scan Networks' to at least reveal the existing wireless networks in this house but with no luck.

Where have I gone wrong? Am I expecting too much to plug it in and scan straight away? Should there be configuration steps using a different os first?

By the way, I have verified this WiFi adapter is functioning by testing in another laptop.

  • The output of lsusb would help. If you run this as root - wpa_cli scan && sleep 5 && wpa_cli scan_results, can you paste the output ? – Lawrence Oct 7 '13 at 2:13
  • now the realtek package is installed by default but you can still get a lot of problems. After doing a tiny bit of research I found this blog post that can get you set up pretty easily. This article here. I just tried it and it is still valid for this chip set in 20/02/2015. – Mrkillius24 Feb 20 '15 at 18:30
  • have you checked if that WiFi is verified to work. Also make sure you are using a good power supply. You might need a powered USB hub for the Model B. B+ and 2B have new power circuits which make USB allot easier – ppumkin Feb 21 '15 at 0:40

It looks as though that adapter has a 8188SU chipset. According to the Debian Wiki you should be able to install the drivers via ssh by (you will probably need to sudo these commands) :

Add a "non-free" component to /etc/apt/sources.list, for example:

# Debian 7.0 "Wheezy" deb http://http.debian.net/debian/ wheezy main contrib non-free

Update the list of available packages and install the firmware-realtek package:

# apt-get update && apt-get install firmware-realtek

After that, restart your pi, and configure the network settings.

(This worked for me with the 8188CUS.. so should be the same for you)

this is discussed extensively here: http://www.raspberrypi.org/forums/viewtopic.php?t=49864

the CUS version is different from the RXS version of the dynamode wifi dongle

  • Welcome to rpi stackexchange! To improve your answer, it would be good to elaborate it a bit - do include the most relevant parts of the post you link to, and keep the link for reference. It makes this site a lot better and it is good to keep at least some of it here. – Bex Oct 28 '14 at 4:27

i don't think you have done anything wrong, simply the linux world in general is not plug and play, you have to find and install the drivers for your device. Have you checked this one has linux drivers?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.