Linked Questions

3 votes
6 answers
19k views

How to prevent /etc/resolv.conf from being overwritten?

I use a static IP for my RPi: root@rpi2:/etc# cat /etc/network/interfaces auto lo iface lo inet loopback allow-hotplug wlan0 iface wlan0 inet static address 192.168.0.2 netmask 255....
WoJ's user avatar
  • 545
6 votes
2 answers
24k views

/etc/network/interfaces missing on Raspbian

I am confused by Raspbian network configuration. I'd like to edit /etc/network/interfaces to setup the loopback interface to start automatically but I cannot find the configuration file. root@...
mariosangiorgio's user avatar
4 votes
2 answers
31k views

Wifi Configuration wlan0 unassociated

Using: Model B Version 2 Dongle: TP-Link model TL-WN823N os: raspbian Tutorial: http://www.circuitbasics.com/raspberry-pi-wifi-installing-wifi-dongle/ Following the tutorial above i have altered ...
TPreston's user avatar
6 votes
4 answers
14k views

Connecting RPi to 2 different networks

I'm pretty new to Raspberry and I searched the net for a while now trying to find a good and simple answer to this question. Ok, so I have a network that is connected to the internet. I want to start ...
Sagi Rokach's user avatar
5 votes
3 answers
27k views

WiFi not working on Raspbian Jessie

I just made a clean install of Raspbian Jessie, and my WiFi adapter doesn't seem to work. It was working on wheezy. > lsusb Bus 001 Device 004: ID 148f:7601 Ralink Technology, Corp. I did have ...
tejas's user avatar
  • 260
2 votes
2 answers
20k views

No wireless interfaces

The icon in the tray does not show any wireless interfaces when I click on it. I know my adapter SHOULD work (Tenda W522U), but it does not appear to. I am running Raspbian Jessie. The output of ...
smithb99's user avatar
4 votes
3 answers
16k views

Realtek USB wifi module - RTL8188EUS is not working and also it is disconnecting LAN connection as well on Raspbian Jessie

I have Rapberri pi module. It is "Raspberry Pi 1 model B+" and it has Rapbian installed on it OS Version: Installed OS is Rapbian Jessie (2015-11-21-raspbian-jessie.img) "Linux Raspberry pi 4.1.13+ #...
user2196448's user avatar
5 votes
2 answers
26k views

Setting Subnet Mask with DHCPD Conf

I'm using Raspberry PI 3 with Raspbian Jessie to make an industrial datalogger product. For obvious reasons I need to tell the Rasp to use a static IP configuration, in order to make it work in other ...
Andrew's user avatar
  • 83
1 vote
3 answers
25k views

Static IP for eth0 not working

There are a lot of these posts around here but none of them actually solved my problem. I tried to set up my Pi B to use a static IP in my home network. Here are the things I did so far: Changed /src/...
Jqss's user avatar
  • 13
6 votes
1 answer
19k views

Pi3 "unable to resolve host" message

I have a message saying:"sudo: unable to resolve host (myhostname)" each time i write a command. My hostname do not contain any capital letter or number. thank you
Niz.Dam's user avatar
  • 315
5 votes
1 answer
11k views

How can I make dhcpcd ignore an interface?

There are two NICs eth0 and eth1 (on Raspbian buster). For eth0 DHCP is used which works fine. eth1 is supposed to be up but otherwise go untouched (NO static address since I‘m trying to setup my own ...
ViToni's user avatar
  • 153
5 votes
2 answers
5k views

How can I replace Raspian SSH host keys if I can't login to pi? ("connection refused")

After configuring a new Raspberry Pi Zero W, I have not been able to ssh into it over WiFi. The IP address is assigned and pingable, but I get 'connection refused' errors. After some research, I ...
clearlight's user avatar
3 votes
1 answer
14k views

Static IP adddress on Raspbian not using dhcp service at all

I have Raspbian Jessie on RPI 2 B, I cannot set my wired NIC with a static IP address. I have uninstalled raspberrypi-net-mods ifplugd, because have a lot of stability issues and insists on uses ...
sebelk's user avatar
  • 161
5 votes
3 answers
13k views

Connecting to RPi from Linux with the ethernet cable without touching RPi

I have a Raspberry Pi 3 that runs on Raspbian and has SSH enabled. However, I don't have any monitor to connect it to (to set up WiFi connection), so my only chance to communicate with it is a basic ...
mtbno's user avatar
  • 215
2 votes
2 answers
34k views

Remove static IP and Enable DHCP?

Raspberry Pi-3 running Stretch. There are dozens of posts here and on other forums about how to set a static IP for the Pi. My problem is the other direction. I have several Pi's, esp switches and ...
user3573562's user avatar

15 30 50 per page
1 2 3
4
5
35