Linked Questions

103 votes
3 answers
269k views

How do I update software and firmware?

I understand that the software on the Raspberry Pi is divided into three sections: the closed-source GPU firmware, the patched ARM Linux kernel and the user space software. Is the GPU firmware on the ...
Alex L's user avatar
  • 7,605
11 votes
4 answers
20k views

Why am I getting a rainbow screen and flashing red PWR LED with a new Raspberry Pi 3B+?

I think there might be a problem with my new Pi. I'm using the same power supply (purchased from PiHut for my previous 3B) in the new 3B+ but I get the rainbow screen and the red power light flashes ...
Shawson's user avatar
  • 213
1 vote
2 answers
13k views

libmmal_core.so missing

I'm sorry to say that I'm a complete newbie to linux and Raspberry Pi. I installed Raspbian on my pi years ago and just started working with it again. I'm trying to install kodi on my system but ...
Exxi's user avatar
  • 13
3 votes
1 answer
10k views

Now that Raspbian Stretch has been released, should Jessie users rush out and do the upgrade? Is it safe?

It has taken a while, but RaspberryPi.org has now announced the official release of Stretch to replace Jessie. Does this mean everybody should start changing their repos and doing the upgrade? Myself, ...
SDsolar's user avatar
  • 2,358
3 votes
2 answers
2k views

Do I need to upgrade any firmware on a new board to make it work and produce a video signal?

I received my 3rd Pi4 4GB kit from Velros and all I did is move the known working sdcard from my working Pi#2 board into this new one. However, after it boots I see 4 raspberries in the upper left ...
Meryan's user avatar
  • 131
1 vote
1 answer
6k views

Moving SD cards from 3B to 3B+ [duplicate]

I have an SD card which works fine on a Pi 3B, with network config on it (it runs a wireless AP and has DHCP setup on the wired port). I move it to a new 3B+, and I see that it doesn't come up on ...
lwr20's user avatar
  • 312
5 votes
2 answers
2k views

Halting inevitably leads to reboot

I always shut down the system with halt, which is the equivalent of shutdown -h now. On every linux system I've ever used, including up until recently the pi, this halts the system and turns off the ...
goldilocks's user avatar
  • 59.2k
0 votes
1 answer
3k views

Unknown filesystem type 'hfsplus' when mounting HFS+ volume on Raspbian Stretch

I am looking to mount an HFS+ volume on my Raspberry Pi running Raspbian Stretch. I have just installed the packages hfsplus hfsutils and hfsprogs. When I run cat /proc/filesystems it looks like ...
Maximillian Laumeister's user avatar
2 votes
3 answers
1k views

Why does pi3 b+ not boot in pi-top? [duplicate]

In September 2016 I bought a Pi-top with its Pi3B, which I assembled and it runs with the Pi-top software recommended at the time. I recently bought two Pi3B+. Expecting complete computability, I ...
Yogi3's user avatar
  • 21
1 vote
0 answers
636 views

Raspbian problem after upgrade from stretch to buster

I tried upgrading raspbian from Stretch to Buster using this tutorial: https://pimylifeup.com/upgrade-raspbian-stretch-to-raspbian-buster/ At the end of step 6 (maybe at 99% of the upgrade), I had ...
jaja360's user avatar
  • 11
0 votes
0 answers
574 views

PiCamera with RPi v3 B+: gpioman_get_pin_num: pin CAMERA_LED not defined

Sorry for the long-winded post. I understand this issue has been posted throughout various forums (including here), but even after following all of the advice I have seen, I am unable to get the Pi ...
mlilley's user avatar
  • 113
1 vote
1 answer
241 views

RPI is not visible in LAN when using ethernet over usb

I'm following this tutorial for converting RPI to usb gadget. I've modified setup script a little to fit my needs: err_file=$HOME/usb_setup_err echo "Time: $(date -Ins)" >> $err_file echo '...
haxscramper's user avatar