Skip to main content

Questions tagged [apt]

APT is a package manager used on Raspbian and includes commands such as 'apt-get'.

Filter by
Sorted by
Tagged with
1 vote
1 answer
170 views

`dpkg` breakage in bookworm 64-bit?

This morning, while doing a routine apt update followed by apt full-upgrade of 3 packages (dpkg, dpkg-dev, libdpkg-perl) on my RPi Zero 2W, I received the following message: dpkg: warning: This ...
Seamus's user avatar
  • 22.4k
0 votes
1 answer
289 views

How to add backports to /etc/apt/sources.list

I've read that some of the necessary pipewire modules for bullseye are available through the backports repo. I tried this, but had problems as described below: Add following line to /etc/apt/sources....
Seamus's user avatar
  • 22.4k
0 votes
1 answer
48 views

I cannot login to my raspberry after uninstalling zsh

Raspberry is running fine, but I cannot login via ssh or directly on the device. Problem: I executed following command: sudo apt remove --purge zsh Yes I know I am a moron. I know I have to access /...
Watzefak's user avatar
1 vote
1 answer
312 views

Samba packages on Rpi 5 64-bit

I downloaded a new version of rasberry pi operating system on a brand new SD card. Linux xxx 6.1.0-rpi7-rpi-2712 #1 SMP PREEMPT Debian 1:6.1.63-1+rpt1 (2023-11-24) aarch64 GNU/Linux I am getting ...
Voltage Spike's user avatar
0 votes
1 answer
57 views

uv4l configuration file missing

I ran "sudo apt-get install uv4l-uvc" and no errors were reported. The service status reported that the configuration file was missing. I found that /etc/uv4l was empty. However, "dpkg -...
Howard's user avatar
  • 1
0 votes
0 answers
18 views

dpkg fatal error while installing libxmlsec1:armh package

I am getting the following error while executing the following code on raspberry pi 3B+: sudo apt install --reinstall libxmlsec1:armhf It is to be mentioned that, I am using this code after removing ...
Mehta G Agarwal's user avatar
0 votes
1 answer
803 views

rpi-imager not working in ubuntu 22.04.2 LTS x86

I want to use rpi-imager in ubuntu sudo -i apt update apt install rpi-imager rpi-imager but it couldn't work.The log is: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root' ...
chaganhu's user avatar
1 vote
1 answer
5k views

My RPi won't update

Raspberry Pi 4b 8gb ram 64x bullseye sudo apt update -y && sudo apt full-upgrade -y && sudo apt autoremove -y [sudo] password for luqman: Hit:1 http://deb.debian.org/debian bullseye ...
Robot Athand's user avatar
0 votes
1 answer
3k views

raspberry pi fail to fetch the update and upgrade

I am using raspberry pi zero and raspbian buster os. I was trying to install samba on it, but it failed to fetch the packages. following is the terminal log, pi@raspberrypi:~ $ sudo apt-get install ...
sagar's user avatar
  • 3
3 votes
3 answers
7k views

I am not able to use sudo-apt upgrade whenever i try this error shows up like this how can i fix it?

$ sudo apt upgrade Reading package lists... Done Building dependency tree... Done Reading state information... Done Calculating upgrade... Done The following packages were automatically installed ...
MRADUL SAXENA's user avatar
0 votes
2 answers
129 views

an Apt-vs apt-get questiom

I need to learn about the so called 'apt' command, which apparently now replaces the old apt-get.is apt-get depreciated? how do I upgrade a maching still running apt-get?
Kirk Bailey's user avatar
0 votes
1 answer
109 views

apt failing to install due to connection failure to source which isn't in /etc/apt/sources.list

Apt can't install anything as it failes with an error of "Temporary failure resolving 'raspbian.playstar.se'". Updates run fine. I have an empty /etc/apt/sources.list.d, and the default /etc/...
mangelmentmanager's user avatar
1 vote
1 answer
667 views

Can't log in after apt upgrade

I ran a sudo apt upgrade, rebooted, and now I can't log in. The odd thing is this... when I provide known invalid credentials the login dialog reports 'Incorrect password' in a red block, like so: ......
InteXX's user avatar
  • 145
4 votes
5 answers
2k views

Raspberry Pi 3b+ - Turning off power LED from /boot/config.txt no longer works with kernal 5.15.56-v7+

I successfully turned off all my LEDs on my Raspberry Pi 3B+ according to this guide, by adding these lines in the /boot/config.txt: [all] # Turn off Power LED dtparam=pwr_led_trigger=none dtparam=...
SneakyShrike's user avatar
2 votes
0 answers
611 views

apt is broken and the fix is too because of too-long line or missing newline in '/var/lib/dpkg/diversions'

I installed the RPi os lite using the imager and it boots up and all but I can't install packages: $ sudo apt install sl Reading package lists... Done Building dependency tree... Done Reading state ...
MA28's user avatar
  • 21
2 votes
2 answers
539 views

trying to install multiple php versions on rasbian 8 / raspberry pi 2

I have two Raspberry Pi's: a Raspberry Pi 2 with Raspbian GNU/Linux 8 (jessie) a Raspberry Pi 4 with Raspbian GNU/Linux 10 (buster). I was able to get multiple versions of PHP running on the ...
neubert's user avatar
  • 145
1 vote
2 answers
1k views

How to increase timeout for apt update

I live in the boondocks, where internet connection can be...well...let's just say "not so good." While trying to keep my system (Buster) up to date, using 'apt update,' the reported ...
Gordon Shephard's user avatar
0 votes
1 answer
2k views

Cannot install libc6: Depends: libgcc-s1 but it is not installable

I got my rPi in a major mess, after setting a newer apt source and upgrading. I can no longer install libc6, e.g. This is my /etc/apt/sources.list.d/raspi.list contents: deb http://archive.raspberrypi....
Bram's user avatar
  • 172
-1 votes
1 answer
2k views

Unable to update packages due errors of corrupted cache files

When I my trying to update packages by "sudo apt update" I have got the errors: Hit:1 http://raspbian.raspberrypi.org/raspbian bullseye InRelease Hit:2 http://archive.raspberrypi.org/debian ...
Piotr's user avatar
  • 1
1 vote
2 answers
1k views

No wpa_supplicant executable

I'm running Rasbpian 10 (buster) on raspberry pi 3 b+. Where can I find the wpa_supplicant binary? $ sudo apt install wpa_supplicant E: Unable to locate package wpa_supplicant # Same for wpa and ...
errolflynn's user avatar
0 votes
2 answers
559 views

I have accidentally destroyed my apt binaries. How can I reinstall without re-imaging?

I was trying to install docker and accidentally ran a script I wasn't meant to (yeah I know) and now I have lost all my apt-get binaries. I have tried looking through http://raspbian.raspberrypi.org/...
jabroni's user avatar
  • 101
0 votes
0 answers
321 views

MySQL service is missing

In my raspberry pi 400, I'm trying to install phpMyAdmin. I don't know why but I think mysql service is missing. If I try to run sudo apt-get dist-upgrade I get the following error: pi@raspberrypi:~ $ ...
Adrian Hernando Solanas's user avatar
-1 votes
1 answer
179 views

apt install stuck on mirrordirector

pi@raspberrypi:~ $ apt show rsync Package: rsync Version: 3.1.1-3 Maintainer: Paul Slootman <[email protected]> Installed-Size: 645 kB Depends: libacl1 (>= 2.2.51-8), libattr1 (>= 1:2.4.46-8)...
Joymaker's user avatar
  • 109
0 votes
2 answers
2k views

apt-get timing out

So I've been smashing my face against this for the last few hours. I'm not terribly familiar/comfortable with linux yet, so I'm sure I missed some obvious fix. When I attempt sudo apt-get update, I ...
Ineptitude's user avatar
0 votes
0 answers
41 views

How to resolve stalled data transfer during 'sudo apt-get upgrade'?

My board is a Raspberry Pi Zero W. I have freshly installed Raspberry Pi OS Lite. Release date: October 30th 2021, Kernel version: 5.10 I have connected USB hub, mouse, keyboard, and monitor. The PSU ...
Dylan Kane's user avatar
1 vote
3 answers
1k views

OBS doesn't work

I am a user of obs, Open Broadcaster Software. I am using raspbian bullseye 32 bits OS. I have installed OBS with this command: sudo apt-get install obs-studio && sudo apt-get install obs-...
In_ The_Nether's user avatar
2 votes
1 answer
3k views

apt issue, unmet libc6/libc-bin dependencies

I was in the middle of upgrading to Bullseye from Buster when my SSH session failed, and I couldn't ssh into the machine anymore. I rebooted it, and now am presented with this problem. I have ...
dalanmiller's user avatar
3 votes
1 answer
1k views

What exactly is "libarmmem-${PLATFORM}.so" and how to update it?

I recently got a problem involving /usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so: VLC was crashing when calling this library (which overrides memory related functions from libc6), and ...
Dmitry Grigoryev's user avatar
0 votes
0 answers
175 views

Can Not Install crossbuild-essential-arm64 On RaspberryPi 4 Model B: Held Broken Packages

I am attempting to install crossbuild-essential-arm64 on my Raspberry Pi 4 Model B, running Raspbian. However, I am getting an error saying "you have held broken packages", along with a list ...
Brendan R.'s user avatar
-2 votes
1 answer
365 views

Libreoffice version not up to date

The current Libreoffice version seems to be 7.2.2, but on my Raspberry Pi it's 6.1.5.2. I understand that maybe the ARM version of Libreoffice is a bit behind, but this can't be right. I used sudo apt ...
Schweini's user avatar
-1 votes
1 answer
2k views

sudo apt update doesn't work

Hi if i try sudo apt update, I get the following errors: Err:1 http://apt.adafruit.com/raspbian wheezy InRelease Something wicked happened resolving 'apt.adafruit.com:http' (-5 - No address ...
Dschew's user avatar
  • 3
1 vote
1 answer
1k views

Unable to use 'apt-get update' because of suite value changes at repository on 64-bit raspbian [duplicate]

Thanks, I upgraded and it works now.
The one and only spahatticat's user avatar
1 vote
1 answer
1k views

Ca-certificates won't allow complete RP Update

I'm trying to install 'Syncthing' on Raspberry Pi, which I have done several times in the past, the install requires that I run apt-get update. This is using Rpi OS "stretch". The update ...
Pete B's user avatar
  • 11
0 votes
1 answer
1k views

Can't install packages anymore because of raspberrypi-kernel failure: bad dkms conf file

I somehow messed something up with my Raspbian; it's a fairly new install on a RPi 3B+. When I run sudo apt update and the sudo apt upgrade I get this error: Reading package lists... Done Building ...
Standard's user avatar
  • 113
0 votes
3 answers
2k views

Can't install software with the "Add/Remove Software" graphical interface, nothing happens

Running a freshly installed Raspberry Pi OS Desktop on a Raspberry Pi 4, I'm trying to install software using the graphical Add/Remove Software tool. For example, Visual Studio Code. After checking ...
Lion's user avatar
  • 207
5 votes
5 answers
17k views

update problem with apt-get after new install of OS

When ever I try to go to recommended updates I get the following error and I don't know how to fix it. I had a boot problem before I reinstalled the operating system. Thank you ahead of time for your ...
Dan's user avatar
  • 59
1 vote
4 answers
6k views

apt update problem - 404

I've got a Raspberry Pi 3B running Jessie. "Sudo apt update" is throwing many 404 errors. Here's an example: Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB Ign http:...
JB McK's user avatar
  • 21
0 votes
1 answer
833 views

RPi 3b+; updating bluez to 5.50-1.2~deb10u2 fails/hangs/

As topic says, after running apt update the OS (running Raspbian GNU/Linux 10 (buster) on kernel 5.10.52-v7+) wants me to update bluez and its dependencies. The version it's trying to update to is 5....
blubbafett's user avatar
0 votes
1 answer
1k views

Kernel panic when using apt on RPi Zero, RPi OS Buster

I’m getting ’kernel panic’ when I try to use apt (or apt-get) to install a package or update/upgrade; I’m using a Raspberry Zero W with the latest version of Raspberry Pi OS available on their website ...
Auniverse's user avatar
2 votes
1 answer
962 views

How do I use NumPy and Pandas in my virtual environment?

I'm using Raspberry 4 to host a web service with FastAPI. In my code, there's a dependency on Pandas. When I ran the web service, it gives me the error message below: File "/home/pi/Projects/...
BurgerBurglar's user avatar
4 votes
2 answers
2k views

Up-to-date Syncthing on Raspberry Pi

How can I get the current latest version of Synchthing on Raspberry Pi without building from source? I'm running Raspberry OS on a Raspberry Pi 4 and everything is recently updated. Running: $ apt ...
gray's user avatar
  • 181
0 votes
0 answers
989 views

Package gcc-arm-linux-gnueabi is not available, but is referred to by another package

I try to compile a piece of software with a pre-defined Docker-enviroment, where following packages are getting installed: gcc-arm-linux-gnueabi, g++-arm-linux-gnueabi, gcc-arm-linux-gnueabihf and g++-...
Standard's user avatar
  • 113
0 votes
1 answer
665 views

Can't run `apt --fix-broken install` as normal user

`apt --fix-broken install E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied) E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?...
horsey_guy's user avatar
3 votes
4 answers
2k views

apt and apt-get cause pi to crash

I'm running into quite a frustrating problem with my Raspberry Pi Zero W. When I try to run apt or apt-get, having done nothing on the installation aside from modifying wpa_supplicant and changing the ...
bobbutnotbob's user avatar
1 vote
1 answer
439 views

What is the difference between apt and apt-get

What is the difference between 'apt' and 'apt-get'? I have seen both used in various places and they appear to do the same thing, is there any difference between the two?
dmeehan's user avatar
  • 599
0 votes
1 answer
287 views

How to install a newer version of a package using apt on Raspberry Pi OS?

I would like to avoid compiling zbar from source. Latest version available on Raspberry Pi OS (found using apt-cache madison zbar-tools) is 0.22 while latest release on GitHub is 0.23.90.
sunknudsen's user avatar
-1 votes
1 answer
231 views

How to full-upgrade without interactive prompt for config file merge (e.g., /etc/ssh/sshd_config)?

I am performing a full upgrade on the Raspberry Pi 4 B+ on the 2020-08-20-raspios-buster-arm64-lite.zip image after I have modified the /etc/ssh/sshd_config file to my liking. I have tried setting the ...
Gordon Fogus's user avatar
0 votes
0 answers
1k views

Pi Zero W with Raspbian Lite apt-get upgrade issues

I have a new Raspberry Pi Zero W and I downloaded the latest Raspbian Buster Lite installing it on a brand new 32 GB microSD card using Rufus. I created a wpa_supplicant.conf file so that it would ...
Liz Livingston's user avatar
5 votes
0 answers
1k views

raspi ubuntu 20 - apt-get update problem - linux firmware / linux-raspi / linux-image-raspi

Hy my raspi has this fstab: UUID=7d298733-8450-4adb-b654-6de49954db5c / btrfs defaults 0 0 UUID=AD5E-0725 /boot/firmware vfat defaults 0 1 Then the ...
Domagoj Ulamec's user avatar
0 votes
1 answer
2k views

running apt-get update/upgrade through a proxy

I'm having issues keeping a Pi up-to-date in a customers network. The pi is there for controlling a piece of equipment, and it needs to be updated once in a while, among other things to keep backward ...
UncleBob's user avatar
  • 163

1
2 3 4 5
9