Questions tagged [apt]

APT is a package manager used on Raspbian and includes commands such as 'apt-get'.

79 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
5
votes
1answer
302 views

Kernel/Firmware as Debian package

It says on the official site that "the kernel and firmware are installed as a Debian package, and so will also get updates when using [apt-get upgrade]" I run apt-get update / apt-get dist-upgrade ...
3
votes
0answers
534 views

Apt-get upgrade broken

I've got an error while trying to upgrade my pi. I can't even reboot it. My SD Card wasn't full. pi@raspberrypi ~ $ sudo apt-get dist-upgrade Lecture des listes de paquets... Fait Construction de l'...
2
votes
0answers
362 views

Unable to install php7.2-intl Depends php7.2-common 7.2.4-1 but 7.2.4-1+b1 is to be installed

While trying to install a NGINX server on a Raspberry Pi 3 Model B Rev 1.2 I was following this tutorial, also tried this answer but both return the error The following packages have unmet ...
2
votes
0answers
114 views

Wrong sources.list entry after adding resilio sync repository

I followed this Guide to install resilio sync on my RPI1. Installation works but I get an Error if I run sudo apt-get update. W: Failed to fetch http://mirrordirector.raspbian.org/raspbian/dists/...
2
votes
0answers
3k views

How do the Raspbian and OSMC repositories differ?

My stock Raspbian system has libswscale2 available in the repositories, but OSMC does not. How do the repositories differ? In Raspbian: $ cat /etc/apt/sources.list deb http://mirror.internode.on.net/...
1
vote
1answer
66 views

connection failed in apt-get upgrade

I am using Raspberry Pi 3 Model B, and installed raspbian-buster on it. sudo apt-get update works well. But sudo apt-get upgrade shows connection failed. Err:29 http://archive.raspberrypi.org/...
1
vote
0answers
42 views

sudo apt-get update isn't working / networking problem

I am getting following errors repeatedly upon using apt-get update command : pi@raspberrypi:~ $ sudo apt-get update Err:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease Cannot ...
1
vote
0answers
116 views

Update Transmission to 2.94

I have found an answer given in 2014, here, which suggests a method for updating the Transmission version available on the Raspberry Pi's default repositories to the latest version. This appears to be ...
1
vote
0answers
246 views

Segmentation fault apt-get

I have Debian Jessie installed and needed to reinstall Apache. When I typed sudo apt-get remove apache2 I managed to remove this package. However, any subsequent commands to apt-get produce a ...
1
vote
1answer
469 views

ssmtp fails to install

I tried to install ssmtp but it fails. I updated and upgraded everything before trying this command but it displays this error message. pi@raspberrypi:/etc $ sudo apt-get install ssmtp Reading ...
1
vote
0answers
2k views

Apt-get update stays on 0% [Working] for ever and i cannot install anything anymore

on my Raspberry with Strecth all of a sudden i cannot run apt-get anymore It hangs on 0% working for ever. I'm connected to the internet because i can CURL, ping and everything... if i try to ...
1
vote
0answers
80 views

Data socket timed out with apt-get, stretch, and ssh

Trying to utilize ssh with apt-get over ssh on a stretch RPi. When doing so, however, I receive a data socket timeout error. It works fine using jessie. It might be a bug as similarly described by ...
1
vote
0answers
177 views

HOW TO FIX: “The valid stable is invalid for APT::Default-Release as such a release is not available in the sources”

So as I'm working on a project I type in "sudo apt-get install feh" but after I pressed enter it gave me a "The valid stable isinvalid for APT::Default-Release as such a release is not available in ...
1
vote
0answers
668 views

Problems with PyQt5

Quoting: I developed a similar application using PyQt4 and Qt4-designer. You have to install pyqt4 all modules: sudo apt-get install qt4-default qt4-designer qt4-doc qt4-dev-tools python-...
1
vote
0answers
159 views

Errors retrieving packages from raspbian.org

Trying to install hostapd with apt-get fails with a 404 error "Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/w/wpa/hostapd_2.3-1+deb8u4_armhf.deb When I go to the link and look,...
1
vote
0answers
466 views

Remove repository from sources.list.d

I have a repo in my sources.list.d/raspi.list that I can't seem to remove. I'm able to remove the repo from the list (sudo vi) and save it, but when I reboot the old file is restored. How can I ...
1
vote
0answers
244 views

Trying to install mysql-server and it throws a mariadb error

While trying to install mysql-server, I get this error: root@raspberrypi:~# sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done ...
1
vote
0answers
637 views

I'm unable to install samba

I'm having trouble with samba that won't install. I did try several time with purge uninstalling and reinstalling but i'm always ending with an error related with a shared library, it seems that the ...
1
vote
0answers
34 views

Pi rebooting on 1 specific apt-get installation

I am experiencing a very peculiar problem with my Raspberry Pi 3 (model B V1.2), running the latest version of Raspbian (the June 2017 version). Whenever I try to install nginx using apt-get, my Pi ...
1
vote
0answers
227 views

sudo apt-get install not working

when I try apt-get install upgrade this error shows up: pi@raspberrypi:~ $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want ...
1
vote
0answers
182 views

Unable to install vnc server as unable to update

I have just installed Raspbian on my Raspberry Pi. Now I want to install the GUI. So for that, I tried to install VNC server by runing sudo apt-get update Which gave me the error: temporary failure ...
1
vote
0answers
617 views

Help with Raspbian apt-get update - mirrordirector.raspbian.org not resolving

I just ran a sudo apt-get update and received error messages saying Err http://mirrordirector,raspbian.org jessie InRelease --Etc-- W: Failed to resolve.... and it said that some index files ...
1
vote
0answers
368 views

Dpkg error when make apt-get install

When I try to install a package, I get this error every time: Setting up ntp (1:4.2.6.p5+dfsg-7+deb8u2) ... update-rc.d: warning: start and stop actions are no longer supported; falling back to ...
1
vote
0answers
144 views

cron-apt is always unable to connect to network

I am using cron-apt to keep my Pi up to date. However, since a few weeks, I always get these error messages in the mail, when cron-apt runs: CRON-APT RUN [/etc/cron-apt/config]: Sat Feb 25 04:00:01 ...
1
vote
0answers
1k views

Correct sources.list when upgrading from stable to testing

Last night I followed this guide to upgrade my headless pi server from Jessie to Stretch. Everything worked as expected and the version output is now Stretch: cat /etc/os-release PRETTY_NAME="...
1
vote
0answers
928 views

apt-get install fails to install OpenMediaVault - php5-pam dependency not available

While installing Open Media Vault following instructions on https://forum.htpcguides.com/Thread-Installing-OpenMediaVault-on-Pi3 or http://forum.openmediavault.org/index.php/Thread/5302-Howto-install-...
1
vote
2answers
1k views

Missing dpkg after sudo apt-get update

I've tried to update my raspberry, received 503 Service Unavailable message and now I can't install anything, because of missing dpkg directory.. root@raspberrypi:/sys/bus/w1/devices# sudo apt-get ...
1
vote
1answer
3k views

Unable to install dialog package

I'm using wheezy on my raspi and wanted to install dialog. sudo apt-get install dialog E: Package 'dialog' has no installation candidate So I look up the source Package: dialog Versions: 1.1-...
1
vote
0answers
56 views

apt-get stopped working

I randomly started having trouble using apt-get on a Raspberry Pi 3 running Raspian. I can remove packages just fine, but when I try to install one, I always get the message E: Unable to locate ...
1
vote
1answer
759 views

Failing to install Jenkins on Raspberry Pi 3 Model B

I have been following some excellent tutorials on How to Install Jenkins onto a Raspberry Pi. After changing the Raspberry Pi 3 Model B's default Java version to 1.8.0_101 and completing the steps to ...
1
vote
1answer
238 views

Can't install rails3 - unmet dependencies

I just got a Raspberry Pi 3 (I already have a fair amount of UNIX experience) and installed Raspbian. I'm trying to install Rails 3 with apt-get. When I try, I get a message about unmet dependencies. ...
1
vote
0answers
839 views

E: Package '<any package>' has no installation candidate

I am unable to apt-get install any packages because E: Package '<package name>' has no installation candidate. Unlike the other similarly named questions, I have not been able to get any ...
1
vote
1answer
1k views

ln: failed to create hard link ‘/boot/initrd.img-3.6-trunk-rpi.dpkg-bak’ => ‘/boot/initrd.img-3.6-trunk-rpi’: Operation not permitted

pi@igla:~ $ cat /etc/os-release PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)" NAME="Raspbian GNU/Linux" VERSION_ID="8" VERSION="8 (jessie)" ID=raspbian ID_LIKE=debian HOME_URL="http://www.raspbian.org/" ...
1
vote
0answers
996 views

Unable to run upgrade on Raspbian

I'm running Raspbian inside QEMU, and I'm getting an error when I try to run sudo apt-get upgrade: dpkg: error: fgets gave an empty string from `/var/lib/dpkg/triggers/File' Google finds almost no ...
1
vote
0answers
286 views

How to upgrade bluez to 5.37

I've got a Raspberry Pi 3 with Raspbian Jessie installed. I am trying to get flic buttons working with my pi (based on this github project). To get this to work I need Bluez 5.37. When I update I ...
1
vote
0answers
345 views

Why aren't the current kernel headers available via apt-get

I am trying to compile some usb drivers for the pi and therefore, I need to get the headers that correspond to my present kernel uname -r produces 4.1.7+ Based on my experiences with Debian and ...
1
vote
0answers
108 views

Random Perl error occurs when trying apt-get upgrade

As of today, suddenly following error occurred while I tried to execute apt-get upgrade Unrecognized character \xA8; marked by <-- HERE after sys_stat_h<-- HERE near column 15Compilation failed ...
1
vote
1answer
3k views

Installing MySQL server in latest (NOOBS) Raspbian

Here I was, following this tutorial (http://www.penguintutor.com/linux/raspberrypi-webserver), because I wanted to host a pretty simple PHP site on my Raspberry Pi. But once again, as it usually ...
1
vote
0answers
726 views

Problem with debconf when trying to upgrade

I have problem with upgrade my system. When i used command: sudo apt-get upgrade I get an error: Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File....
0
votes
2answers
111 views

Installing docker on Raspberry pi

Trying to set up docker on my pi, getting errors I’m not sure what to do with. the generally recommended thing to do is to run the following: $ curl -sSL https://get.docker.com | sh But that script ...
0
votes
2answers
44 views

Missing packages suggestions won't work on Raspbian buster

I'm trying to get command-not-found package to work. That's the one which tells what to install when the user types a missing command, for instance: $ zbarcam The program 'zbarcam' is currently not ...
0
votes
1answer
40 views

Raspbian: dpkg hangs during raspberrypi-kernel package upgrade

while doing an apt upgrade on my Raspberry Pi 4 (Raspbian 10 - Buster), dpkg was interrupted during setup of the raspberrypi-kernel package: raspberrypi-kernel (1.20190819-1) wird eingerichtet ... »...
0
votes
0answers
57 views

Raspberry PI apt update files failed to download

I am trying to issue the following command on my Rpi sudo apt-get update but I've the following error message pi@raspberrypi:~ $ sudo apt-get update Hit:1 http://archive.raspberrypi.org/debian ...
0
votes
1answer
39 views

'sudo dpkg --configure -a' crashing Pi 4

Trying various ways to install Docker on Buster I have now run into this. I get the message that E: dpkg was interrupted and to run the sudo dpkg --configure -a command. When I do I get this: ...
0
votes
0answers
115 views

Error installing lirc on raspberry pi 3

I would like to install lirc on my raspberry pi 3B+. Unfortunately there is an error message when installing with apt-get. I just reinstalled raspbian using Noobs to avoid any problems due to changed ...
0
votes
1answer
47 views

Installing openssl 1.0.2g on jessie

I need to use libssl-dev 1.0.2g to compile some old codes. I followed the guides in stackoverflow but it does not work in my case. This is my /etc/apt/sourcelist deb http://mirrordirector.raspbian....
0
votes
0answers
50 views

Cant upgrade Raspbian neither run Python

I am trying to upgrade my Raspberry Pi 3 B+: $ uname -a Linux plexmediaserver-pi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux But I am getting this weird error: pi@...
0
votes
1answer
34 views

How to skip a package version?

How can I be informed when a new version of a specific package is available for install? Is there a way to have apt-get skip a specific version, but install when the next one is available? I am ...
0
votes
0answers
40 views

Can't install development files for QT on RPi Zero W

I've been following this tutorial trying to get working QT cross-compilation from my PC to a Raspberry Pi Zero W. It is failing on Step 5 ("Install a bunch of development files"). Running sudo apt-...
0
votes
0answers
21 views

How to suppress the “The desktop has been updated…” prompt?

I have written a "setup" script to customize a stock Raspian (stretch) image for use in my application, and it includes apt-get update && apt-get upgrade. This was working great last time I ...