Questions tagged [apt]

APT is a package manager used on Raspbian and includes commands such as 'apt-get'.

Filter by
Sorted by
Tagged with
95
votes
3answers
60k views

What is rpikernelhack?

When doing an apt-get upgrade on my RPi 3, many lines of output show up like this: Adding 'diversion of /boot/bcm2708-rpi-b-plus.dtb to /usr/share/rpikernelhack/bcm2708-rpi-b-plus.dtb by ...
20
votes
5answers
87k views

apt-get installation doesn't work on Raspberry Pi

I tried to install python-pip by typing this command: sudo apt-get install python-pip And the result is below: Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main python2.6-minimal armhf 2....
19
votes
7answers
87k views

Cannot connect to mirrordirector.raspbian.org

I can't connect to mirrordirector.raspbian.org in Raspbian, but I don't know why. I've already re-installed Raspbian, but it looks like this is not the problem. How can I resolve this? After I ...
15
votes
2answers
12k views

apt-get update and upgrade says “packages have been kept back”

I ran an update and an upgrade (apt-get update and apt-get upgrade) and I get the following message: The following packages have been kept back: alsa-base scratch What do I do to get these ...
13
votes
3answers
41k views

Installing Python 3.4 on Raspberry Pi

Is it possible to run python 3.4 on a Raspberry Pi? Currently I have python 3.2, but the odd thing is that running sudo apt-get update sudo apt-get install python3 results in my Raspberry Pi ...
13
votes
1answer
4k views

Automatic updating recommended?

Is it recommended to configure something to automatically keep an RPi updated? And if so, which method (cron-apt or something else)?
13
votes
2answers
33k views

Raspberry Pi apt-get update/upgrade on Raspbian hangs?

Whenever I try to update my pi using sudo apt-get update && sudo apt-get upgrade it will often hang at some point during the installation. It's been different ones each time, but the last was ...
12
votes
2answers
16k views

How to use Stretch/testing packages?

I want to install the last version of Deluge on my Raspbian. The current distribution, Jessie (stable), contains the 1.3.10 version but I want the last one 1.3.13. The next distribution, Stretch (...
12
votes
2answers
20k views

How can I install PHP 5.6 (instead of 5.4)?

I'm actually stuck with a little problem. I want to use Laravel on my pi but it requires at least PHP 5.5.9. But actually, the latest version of PHP that I am able to install (via the official ...
12
votes
7answers
41k views

apt-get update gives me errors with mirrordirector.raspbian.org

I am trying to install tightvncserver on my rPi model A running Raspbian. I am connecting to the rPi via SSH from my laptop. I can connect to the internet, but cant install the package. It seems to be ...
11
votes
1answer
2k views

What is the difference between rpi-update and sudo-apt upgrade?

I'm wondering what the difference is between running the git-hub obtained program rpi-update and using sudo apt-get update followed by sudo apt-get upgrade. I've checked around and cannot find the ...
10
votes
1answer
1k views

Why do I always have to run apt-get update twice? Or do I?

Every time I run apt-get update, I get the following message (the exact duplicate package is different depending on the last entry in sources.list): W: Duplicate sources.list entry http://ftp.uk....
10
votes
2answers
23k views

Official MongoDB Repo for ARM Processor for Debian base

Is there an official MongoDB repo for the Raspberry Pi Following: http://docs.mongodb.org/manual/tutorial/install-mongodb-on-debian/ Got this issue: W: Failed to fetch http://downloads-distro....
8
votes
5answers
78k views

isc-dhcp-server install and run problem

Im trying to set up my pi as an access point with the instructions from Adafruit. However, for some reason, sudo apt-get install isc-dhcp-server always fails. I have looked at this link, but there is ...
8
votes
1answer
26k views

How to add ppa entries manually on Raspberry Pi

I would like to know how I can add a "ppa" entry manually on the Raspberry Pi for the "apt" program. Where should I add my "ppa" entry (in which file) ? For example, I want to add the following ppa ...
8
votes
2answers
18k views

Unable to use apt-get: dpkg: unrecoverable fatal error … is missing final newline

I am unable to use the apt-get command to install any packages on my pi. I started trying to install python-pip using sudo apt-get install python-pip which results in the error dpkg: unrecoverable ...
7
votes
4answers
2k views

Why can't I install Postgresql-10? (how does the raspbian archive work)

I was recently trying to install Postgresql-10 on my raspberry pi running Stretch. When I run sudo apt-get install postgresql-10 I get E: Unable to locate package postgresql-10. However, when I go ...
7
votes
2answers
19k views

Changing to XFCE from LXDE

Apologies if this seems straight forward but I've recently downloaded XFCE to replace LXDE environment. I did this by using sudo apt-get install xfce4 and following all the instructions. Then to ...
7
votes
3answers
3k views

Why there is a collabora.list on my raspbian wheezy source repo?

Why there are more sources repos on my raspbian wheezy? They are /etc/apt/sources.list.d/raspi.list and /etc/apt/sources.list.d/collabora.list. For what are they needed?
7
votes
2answers
13k views

Having trouble updating - how to fix problem with MergeList?

pi@raspberrypi:/$ sudo apt-get update Hit http://archive.raspberrypi.org wheezy InRelease Hit http://mirrordirector.raspbian.org wheezy InRelease Hit http://archive.raspberrypi.org wheezy/main armhf ...
7
votes
1answer
5k views

How do I install lighttpd (lighty) on Debian “squeeze”?

How do I install lighttpd on my Raspberry Pi? I tried running sudo apt-get install lighttpd, which works fine on a regular Debian 'squeeze' installation, but on a Raspberry Pi I get the following ...
7
votes
1answer
2k views

How to add a package to official raspbian repositories?

How to add a package to official raspbian repositories ? Debian has a very extensive guide into the matter : https://www.debian.org/doc/manuals/distribute-deb/distribute-deb.html#adding-packages-to-...
6
votes
2answers
4k views

How does apt-get work?

Normally, when I want to download something on my pi (for instance this vnc app, I use apt-get <insert app>? But, sometimes an app is not in the apt-get area (not sure what proper name is) and ...
6
votes
5answers
10k views

Raspbian Stretch: Getting Error: missing `server' JVM at `/usr/lib/jvm/java-8-openjdk-armhf/jre/lib/arm/server/libjvm.so'

I am trying to get the arduino utilite installed to my Pi Zero, so I did sudo apt-get install arduino And it chugs away for a moment, then barfs this: pi@raspberrypi:~ $ sudo apt-get install ...
6
votes
1answer
7k views

Getting a deb repository error for collabora

I'm brave enough to try out the upgrade from wheezy to jessie on my pi according to this: Upgrade to Raspbian Jessie So far it runs pretty smooth, except that I get an error when updating the ...
6
votes
6answers
30k views

What means “Segmentation fault” error using apt?

I'm getting an error every time I try to run commands on my RPi: pi@rpi ~ $ apt-get install wkhtmltopdf Segmentation fault Even when I try running other commands: pi@rpi ~ $ uptime -bash: /usr/bin/...
6
votes
3answers
2k views

Installing GitLab messed things up, how to get it out?

Yesterday I started setting up my Raspberry Pi 2 (with Raspbian Jessie) to run my own server for some things. Amongst others I want to run GitLab on my Pi. I connected to my Pi through SSH (using ...
5
votes
2answers
550 views

Who controls what software is on raspbian & apt-get?

I just updated to the new version of Raspbian and the first thing I noticed was some new software. I'm wondering how these programs get to be on Raspbian & apt-get. Do you have to ask or are you ...
5
votes
3answers
21k views

Unable to install mongodb 3.4 on Pi 3

I have been trying to install the latest version of mongodb on my Pi 3. I currently am running the latest version of node (8.0.0) and am running Raspbian lite - Jessie (8). I have been following this ...
5
votes
2answers
2k views

apt-get hangs at Reading database when installing anything

One of my raspberry pi's is hanging whenever I try to install or update anything using apt-get. Running Raspbian 7 (wheezy). Symptoms (using watchdog as an example as it has no dependencies): # apt-...
5
votes
4answers
7k views

Raspberry Pi 3 Ubuntu 16.04 Server upgrade error

So last week I bought the Raspberry Pi 3 model B with the complete Canakit. I installed Ubuntu 16.04 server standard image on the micro sd card with my Windows computer. I used SF Formatter to ...
5
votes
1answer
4k views

Sub-process /usr/bin/dpkg returned an error code (1) on apt-get upgrade

I'm using Raspberry Pi 1 model B without GUI and when I try to upgrade software using sudo apt-get upgrade I get the following error: Segmentation fault dpkg: warning: subprocess old pre-removal ...
5
votes
1answer
306 views

Kernel/Firmware as Debian package

It says on the official site that "the kernel and firmware are installed as a Debian package, and so will also get updates when using [apt-get upgrade]" I run apt-get update / apt-get dist-upgrade ...
4
votes
1answer
9k views

Install Raspbian packages directly from Ubuntu with chroot to Raspbian file system (on SD card)

I'm connecting to internet with my pc using Ethernet cable, I just have one internet cable input and one RJ45 cable, so I cant share internet with my Raspberry. is there any solution to install ...
4
votes
2answers
6k views

nginx 1.9.2 on raspbian

Installing nginx using "apt-get install nginx" seems to install 1.2.1, however examining the repository, it looks like both 1.6.2 and 1.9.2 are available: http://mirrordirector.raspbian.org/raspbian/...
4
votes
4answers
14k views

how to install libtbb-dev in raspberry-pi

I am trying to install libtbb-dev on my raspberry-pi as part of installing opencv. sudo apt-get install libtbb-dev But i am getting an error as Package libtbb-dev is not available,but is refered ...
4
votes
2answers
634 views

Apache internal host of repository for Raspberry Pi

Is there a way to store .deb files on a Apache server on Ubuntu and be able to install them on a Pi with the sudo apt-get install command?
4
votes
2answers
11k views

Unable to apt-get update but connected to internet?

So I got a pi 3.0 and it has been running a apache webserver with php just fine. I have not logged into it in a while. Today, however, I was planning to install openvpn which failed to install. So I ...
4
votes
2answers
21k views

raspbian - sudo apt-get update not working

I have problems when trying to update the apt repositories. pi@raspberrypi:~ $ sudo apt-get update Err http://mirrordirector.raspbian.org jessie InRelease Err http://mirrordirector.raspbian.org ...
4
votes
1answer
537 views

The following packages have been kept back: mopidy

After performing sudo apt-get update && sudo apt-get upgrade, I got the message The following packages have been kept back: mopidy What I usually do in this case, is sudo apt-get install ...
4
votes
2answers
4k views

Why APT can't locate GNURADIO package even though it apparently exists in repository?

I have been trying to install the GNURADIO package that is listed on the raspbian mirror: http://archive.raspbian.org/raspbian/pool/main/g/gnuradio/ I've added the repo to my sources.list as below: ...
4
votes
3answers
14k views

held broken packages

When I try and do sudo apt-get update it seems to me that I have 4 newer packages than what is to be installed. Any help would be appreciated. Thank you. Module Index Update Packages Building ...
4
votes
1answer
15k views

How do I restore the default repositories?

I accidentally messed up my apt-sources list in raspberian n my Raspberry PI 3. my distro is: Linux host 4.4.9-v7+ #884 SMP Fri May 6 17:28:59 BST 2016 armv7l GNU/Linux Is there any way to get back ...
4
votes
1answer
1k views

tmux doesn't want to be installed

I had my Raspberry Pi running for a while and needed to uninstall all the junk I left behind for a project. I used tmux before and it was a blessing. I am trying to install it again, but it doesn't ...
4
votes
2answers
3k views

SSH session keeps exiting my terminal

I have set up my Raspberry PI though these instructions and was able to connect to it through SSH. I have installed RASPBIAN WHEEZY. However, when I run sudo apt-get update it keeps closing the whole ...
4
votes
3answers
5k views

Command apt-get upgrade crashes Raspbian

The image file I am using is quite old. How old exactly I am not sure, because this image I have inherited from previous developer. I have learnt that running: sudo apt-get update sudo apt-get ...
4
votes
1answer
96 views

Are there any downsides to using “apt” on the raspberry pi?

I normally use apt-get on the raspberry pi to update/install/etc., but I like just plain apt better because of the better interface and text coloring, etc. I can't seem to find anything on google that ...
4
votes
1answer
3k views

apt-get connections time out when updating

i am currently a newbie fro rp2. I am currently facing the problem when i am using putty and vnc server. When i am going to press sudo apt-get update. It shows this: pi@raspberrypi ~ $ sudo apt-...
4
votes
2answers
5k views

Raspberry Pi Zero Stretch /etc/resolv.conf DNS problem

I cannot use apt update as every reboot my sudo vim /etc/resolv.conf file resets to the below # Generated by resolvconf search home nameserver 127.0.0.1 I have tried to change the nameserver to a ...
4
votes
1answer
865 views

Why are the Raspbian repositories so out of date?

I'm trying to install Owncloud, which is currently at version 6.0.3. However, Raspbian's version is from about two years ago. $ apt-cache show owncloud Package: owncloud Version: 4.0.4debian2-3.3 ...