Questions tagged [apt]

APT is a package manager used on Raspbian and includes commands such as 'apt-get'.

Filter by
Sorted by
Tagged with
1
vote
0answers
751 views

Problems with PyQt5

Quoting: I developed a similar application using PyQt4 and Qt4-designer. You have to install pyqt4 all modules: sudo apt-get install qt4-default qt4-designer qt4-doc qt4-dev-tools python-...
1
vote
0answers
189 views

Errors retrieving packages from raspbian.org

Trying to install hostapd with apt-get fails with a 404 error "Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/w/wpa/hostapd_2.3-1+deb8u4_armhf.deb When I go to the link and look,...
1
vote
1answer
11k views

Stretch apt-get update error: 'http://archive.raspberrypi.org/debian stretch Release' does no longer have a Release file

Cannot do first update for a straight from raspberrypi.org download of 2017-09-07-raspian-stretch image due to errors: pi@RWPi:~ $ sudo apt-get update Ign:1 http://mirrordirector.raspbian.org/...
2
votes
1answer
666 views

What repositories to add for apt-get to find python-opencv

I've been trying to install the packages necessary to play with shape recognition with a camera. Virtually all sites recommend using opencv, and tell, like here, here and here, to install it with apt‐...
0
votes
1answer
136 views

Error installing wpasupplicant

I received the following error whilst installing wpasupplicant $ sudo apt-get install wpasupplicant Reading package lists... Done Building dependency tree Reading state information... Done The ...
0
votes
1answer
782 views

Cannot Connect to Wifi

So to begin, I have a brand new Raspberry Pi 3 B with Raspbian installed from NOOBS. I am trying to connect it to Wi-Fi however the GUI says No Wireless Interfaces. When I hop into Terminal, I can see ...
1
vote
0answers
935 views

Remove repository from sources.list.d

I have a repo in my sources.list.d/raspi.list that I can't seem to remove. I'm able to remove the repo from the list (sudo vi) and save it, but when I reboot the old file is restored. How can I ...
0
votes
1answer
51 views

Did dumb thing and removed GTK3.0 folder

So I removed the folder. OK...dumb move Now, when I try to install again.... sudo apt-get install libgtk-3-dev It responds: "libgtk-3-dev is already newest version" So how can I re-install ...
1
vote
0answers
293 views

Trying to install mysql-server and it throws a mariadb error

While trying to install mysql-server, I get this error: root@raspberrypi:~# sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done ...
1
vote
1answer
715 views

Failing to apt-get update

I've been scouring the net trying to find the answer to this and all answers that are close talk about not connecting to the net. I have no problems on the internet, I am typing this on the pi3 that ...
1
vote
1answer
429 views

Could not open locked file when trying to install with apt-get

Now, here is my question: Who hates apt-get? Almost no one. Who gets problems with apt-get? I do. And I am. Sometimes, using sudo apt-get upgrade takes sooooo long you just close off terminal to ...
4
votes
3answers
2k views

apt-get update error: 500 no space left on device

Fresh install of NOOBS 2_4_3 Stretch using http://goddess-gate.com for repository mirror. Here is what I'm getting: sudo apt-get upgrade Reading package lists... Done Building dependency tree ...
3
votes
4answers
5k views

Unable to install mysql

I am trying to install mysql on my pi. I've installed mysql server successfully, but get the following error when I try to run $ sudo apt-get install php5-mysql Some packages could not be ...
0
votes
2answers
58 views

I don't know how to link a compiler to an IDE

I AM NOT BEING DUMB HERE! Maybe I kind of am, but right now the Raspberry Pi IDE QTCreator does not come with a compiler. Okay, now I'm a bit confused. Not really. Upon discovering that QTCreator ...
0
votes
1answer
474 views

dpkg: unrecoverable fatal error when installing ImageTK

I get the following error when installing ImageTK. % sudo apt-get install python-pil python-imaging python-imaging-tk Reading package lists... Done Building dependency tree Reading state ...
1
vote
1answer
2k views

Raspberry Pi 3 with Ubuntu 16.04.3 LTS sudo apt-get update exits with dpkg error code (1)

I'm running a Raspberry Pi 3 with Ubuntu 16.04.3 LTS xenial. sudo apt-get update exits with: dpkg: error processing archive /var/cache/apt/archives/linux-firmware_1.157.11_all.deb (--unpack): trying ...
0
votes
2answers
837 views

Unable to use apt-get: raspberrypi-net-mods is missing

I've installed 2017-07-05-raspbian-jessie and trying to upgrade apt-get. The problem is I keep getting this error: Preconfiguring packages ... dpkg: unrecoverable fatal error, aborting: files list ...
1
vote
2answers
2k views

apt-get install [any package] has no installation candidate

I'm having trouble installing any package on my Raspberry Pi v1 B. Whenever I run apt-get install [any package here], it always failed with E: [package name] has no installation candidate. I don't ...
1
vote
0answers
857 views

I'm unable to install samba

I'm having trouble with samba that won't install. I did try several time with purge uninstalling and reinstalling but i'm always ending with an error related with a shared library, it seems that the ...
0
votes
2answers
1k views

Can't install Heroku CLI on Raspberry Pi 3 running Raspbian

I've just started using my RP3 as my development box, and got everything working fine: Python 3.6, created venv's, installed posgresql, working with Django. All is fine. Except that, if I want to work ...
1
vote
1answer
707 views

How do you use Gnash?

So. Looking over the internet to find some kind of substitute to adobe flash, I landed on the raspberry pi forum or something (Forgot the link). I saw somebody talking about Gnash from GNU, and after ...
1
vote
0answers
37 views

Pi rebooting on 1 specific apt-get installation

I am experiencing a very peculiar problem with my Raspberry Pi 3 (model B V1.2), running the latest version of Raspbian (the June 2017 version). Whenever I try to install nginx using apt-get, my Pi ...
1
vote
0answers
309 views

sudo apt-get install not working

when I try apt-get install upgrade this error shows up: pi@raspberrypi:~ $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want ...
-1
votes
1answer
411 views

problem in importing RPI.GPIO as GPIO

Hi guys i suriously tired to solve this problem i have a raspberry pi 3 model B i'm running the raspberry using putty and raspbian using vnc viewr i open the terminal window to creat a simple project "...
0
votes
1answer
1k views

“apt-get remove python” removed a ton of other stuff, RPi messed up

So I was trying to install the Python library lzma, and somehow I got to the point of removing python2.x, and I don't know why I did that. I'm tired, that probably why. I think I learned my lesson. ...
5
votes
3answers
23k views

Unable to install mongodb 3.4 on Pi 3

I have been trying to install the latest version of mongodb on my Pi 3. I currently am running the latest version of node (8.0.0) and am running Raspbian lite - Jessie (8). I have been following this ...
5
votes
1answer
2k views

tmux doesn't want to be installed

I had my Raspberry Pi running for a while and needed to uninstall all the junk I left behind for a project. I used tmux before and it was a blessing. I am trying to install it again, but it doesn't ...
1
vote
1answer
681 views

Download from apt-get through HTTPS only?

Today during a sudo apt-get dist-upgrade I noticed that at the beginning of the process it lists a series of lines starting as: Get: 1 http:/mirrordirector.raspberrypi.org ... Get: 2 http:/archive....
1
vote
0answers
196 views

Unable to install vnc server as unable to update

I have just installed Raspbian on my Raspberry Pi. Now I want to install the GUI. So for that, I tried to install VNC server by runing sudo apt-get update Which gave me the error: temporary failure ...
0
votes
2answers
865 views

GTk+3 version not the lastest stable version

I'm in trouble with gtk version i think. When i run pkg-config --modversion gtk+-3.0 in my Raspberry Pi that is running Raspbian OS, i get 3.14.5 version. If i try to update with sudo apt-get update ...
1
vote
0answers
639 views

Help with Raspbian apt-get update - mirrordirector.raspbian.org not resolving

I just ran a sudo apt-get update and received error messages saying Err http://mirrordirector,raspbian.org jessie InRelease --Etc-- W: Failed to resolve.... and it said that some index files ...
1
vote
2answers
3k views

installing package error “sudo apt-get install ppp”

I'm trying to install the ppp packaged for the raspberry pi so i can connect a 3g dongle to the internet but i get the following error. It seems that some modules install except one. overall the ppp ...
0
votes
1answer
5k views

Installed kernel headers and $(uname -r) differ

Raspberry Pi 1 Model B. If I run: uname -a I get: 4.9.16+ Gcc version: 4.9.2 If I execute: sudo apt-get install raspberrypi-kernel-headers it installs me 4.4.50+ Why and how can I install the ...
5
votes
3answers
3k views

apt-get hangs at Reading database when installing anything

One of my raspberry pi's is hanging whenever I try to install or update anything using apt-get. Running Raspbian 7 (wheezy). Symptoms (using watchdog as an example as it has no dependencies): # apt-...
0
votes
1answer
392 views

Apt-get returns several errors

I'm a newbie running Raspian (Debian 8 Jessie) and managed to mess up something with apt-get. Any advice or hints to fix the errors below would be greatly appreciated! sudo apt-get upgrade Reading ...
-1
votes
2answers
1k views

Unable to install from apt-get

I have searched for a solution and before I explain the issue, I have run apt-get update but I still get the problem. sudo apt-get upgrade is also experiencing the same problem. I am assuming mirror....
1
vote
0answers
394 views

Dpkg error when make apt-get install

When I try to install a package, I get this error every time: Setting up ntp (1:4.2.6.p5+dfsg-7+deb8u2) ... update-rc.d: warning: start and stop actions are no longer supported; falling back to ...
1
vote
0answers
163 views

cron-apt is always unable to connect to network

I am using cron-apt to keep my Pi up to date. However, since a few weeks, I always get these error messages in the mail, when cron-apt runs: CRON-APT RUN [/etc/cron-apt/config]: Sat Feb 25 04:00:01 ...
3
votes
2answers
259 views

Julia not available in Raspbian?

I am trying to install Julia: $ sudo apt-get install julia Reading package lists... Done Building dependency tree Reading state information... Done Package julia is not available, but is referred to ...
2
votes
1answer
1k views

problems with sudo apt-get update

I just received my new pi3 today and was setting it up. I managed to get raspbian working but now when I try to run the command sudo apt-get update or sudo apt-get upgrade I get an error saying ...
1
vote
0answers
1k views

Correct sources.list when upgrading from stable to testing

Last night I followed this guide to upgrade my headless pi server from Jessie to Stretch. Everything worked as expected and the version output is now Stretch: cat /etc/os-release PRETTY_NAME="...
5
votes
4answers
8k views

Raspberry Pi 3 Ubuntu 16.04 Server upgrade error

So last week I bought the Raspberry Pi 3 model B with the complete Canakit. I installed Ubuntu 16.04 server standard image on the micro sd card with my Windows computer. I used SF Formatter to ...
1
vote
1answer
2k views

Cannot use 'apt-get' at all

I have had this problem for a while now and have now decided to ask here. I asked on the raspberry pi subreddit, but found no help. Whenever I try to use apt-get to update or install something, the ...
0
votes
1answer
513 views

Can't rpi-update

I can't update the kernel of my pi anymore. When I try I have those errors : pi@raspberrypi ~ $ sudo rpi-update *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom *** ...
0
votes
1answer
2k views

Issues with apt-get install vlc

I am using a RPi 2 B and Raspbian I am trying the following command via ssh to install VLC sudo apt-get install vlc I also tried sudo apt-get install vlc --fix-missing I get two prompts about ...
-1
votes
1answer
145 views

apt-get update returning error

Whenever I try to do sudo apt-get update or sudo apt-get upgrade, this is what is returned: invalid section len 536870958, max remaining 46 Any ideas what could be the cause of this problem?
1
vote
0answers
1k views

apt-get install fails to install OpenMediaVault - php5-pam dependency not available

While installing Open Media Vault following instructions on https://forum.htpcguides.com/Thread-Installing-OpenMediaVault-on-Pi3 or http://forum.openmediavault.org/index.php/Thread/5302-Howto-install-...
12
votes
2answers
18k views

How to use Stretch/testing packages?

I want to install the last version of Deluge on my Raspbian. The current distribution, Jessie (stable), contains the 1.3.10 version but I want the last one 1.3.13. The next distribution, Stretch (...
4
votes
0answers
682 views

Apt-get upgrade broken

I've got an error while trying to upgrade my pi. I can't even reboot it. My SD Card wasn't full. pi@raspberrypi ~ $ sudo apt-get dist-upgrade Lecture des listes de paquets... Fait Construction de l'...
3
votes
1answer
1k views

How do I get/compile a source package for version with “+”?

I have a version with a "+" in it - what does this mean? How do I figure out which source I want if I am compiling a patch? How do I go about finding it? Any links are much appreciated! Example $ ...

1 2 3
4
5
8