Questions tagged [apt]

APT is a package manager used on Raspbian and includes commands such as 'apt-get'.

Filter by
Sorted by
Tagged with
4
votes
1answer
4k views

Does Raspbian mirror has a problem updating or is something wrong with bzip2 apt-get method

I get this error while running sudo apt-get update Hit http://mirrordirector.raspbian.org wheezy InRelease Hit http://archive.raspberrypi.org wheezy InRelease Hit http://archive.raspberrypi.org ...
3
votes
2answers
212 views

Julia not available in Raspbian?

I am trying to install Julia: $ sudo apt-get install julia Reading package lists... Done Building dependency tree Reading state information... Done Package julia is not available, but is referred to ...
3
votes
2answers
14k views

apt-get not installing software. Repositories are not updating

I am trying to use apt-get to install lynx. However I am having issues with the repositories. This is what my sources.list looks like: #deb http://mirrordirector.raspbian.org/raspbian/ wheezy main ...
3
votes
3answers
18k views

Linux headers in Raspbian Jessie

I have problem to install linux-headers in Raspbian on my RPi2. My kernel version is 4.1.17-v7+. I can't find the linux-headers package with apt-get.
3
votes
2answers
2k views

Difference between Raspbian repositories

When installing raspian via NOOBS the following repository can be found in /etc/apt/sources.list: deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi But there are a lot ...
3
votes
4answers
7k views

How to solve “Encountered a section with no Package: header” error?

I am running a bunch of class Raspberry Pi computers behind a school proxy. I'm using Raspbian off a very recent NOOBS image. The internet connection is supplied through the school WiFi and after ...
3
votes
1answer
726 views

pi1, armv6, how to disable armhf packages?

I dusted off a Pi 1, which is armv6, then installed Raspbian on it. The base OS works, but many of the packages I install won't even start- they say illegal instruction. That's because the armhf ...
3
votes
4answers
4k views

Unable to install mysql

I am trying to install mysql on my pi. I've installed mysql server successfully, but get the following error when I try to run $ sudo apt-get install php5-mysql Some packages could not be ...
3
votes
4answers
25k views

E: Package has no installation candidate

I am unable to install any package using command "apt-get install". Whenever I execute above command to install any package, it shows me a common error saying E: Package <PackageName> has no ...
3
votes
1answer
819 views

proper apt-get configuration for epiphany browser

I have been using the epiphany browser beta for a while, having installed it using these instructions. Now that the browser is part of the raspbian distribution, should I continue to include ...
3
votes
2answers
18k views

Why can't I remove Apache?

I installed a LAMP stack with the following commands: $sudo apt-get install apache2 php5 libapache2-mod-php5 $sudo service apache2 restart $sudo apt-get install mysql-server mysql-client php5-mysql ...
3
votes
3answers
738 views

DrRacket seg fault

I'm trying to install racket on my RaspBerry Pi. I've installed racket via sudo apt-get install racket When I enter 'racket', it runs just fine. But when I run 'drracket' or 'sudo drracket', it ...
3
votes
2answers
971 views

how to create a restore point before an apt-get install to effectively remove the package

I discoverd aplay could not play a sound immediately after another aplay command. I reported the issue. It seems to be working in other systems. So I started from scratch and after each apt-get ...
3
votes
1answer
4k views

Install (or build) experimental Debian package for rpi (NetworkManager 1.0)

So I need NetworkManager 1.0 on my Rpi to be able to setup new wifi connections via nmcli. There is a package in experimental debian repo: https://packages.debian.org/network-manager I made $ sudo ...
3
votes
2answers
4k views

apt-get upgrade fails because of some dependency loop

If I update my Raspberry PI with: sudo apt-get upgrade I run into follwoing dependency errors: lighttpd (1.4.31-4+deb7u3) wird eingerichtet ... insserv: warning: script 'mathkernel' missing LSB ...
3
votes
1answer
917 views

How do I get/compile a source package for version with “+”?

I have a version with a "+" in it - what does this mean? How do I figure out which source I want if I am compiling a patch? How do I go about finding it? Any links are much appreciated! Example $ ...
3
votes
1answer
826 views

Cannot install xpra: unmet dependancies

I'm trying to install Xpra, however it seems that there are missing packages I cannot install. Xpra fails with the following error: Some packages could not be installed. This may mean that you have ...
3
votes
1answer
2k views

Cannot use apt-get, 404 not found on Pi 2, Model B

I am working with a Pi 2, Model B, with wheezy installed. It is connected to the Internet with an Ethernet cord and has a keyboard and Bluetooth dongle plugged into its USB ports, as well as a ...
3
votes
1answer
130 views

sudo apt-get update does not connect to 10.10.5.18

I am having this prob since morning only and before that everything was normal. I can connect to my Pi through ssh using putty on my windows 7. The problem is when I run sudo apt-get update, it gets ...
3
votes
1answer
1k views

Why does apt-get dist-upgrade want to remove upstart again?

I usually do apt-get dist-upgrade instead of a mere apt-get upgrade for consistency reasons. However, for the first time on one of my RaspberryPis I got the following: # apt-get dist-upgrade Reading ...
3
votes
1answer
98 views

apt-get not working on raspberry pi zero w [Internal error: Oops: 17 [#1] ARM]

I bought a new raspberry pi zero w. I flashed the raspbian lite image on a sd-card, the pi booted normally. But when I try to update it with sudo apt-get update sudo apt-get upgrade I get the ...
3
votes
1answer
152 views

Automatic clean of unattended upgrades

Following the Debian wiki documentation and this answer I have successfully set up unattended upgrades. I have confirmed that upgrades are really run. However, I want to avoid eventually getting disk ...
3
votes
1answer
97 views

How can I install Mosquitto on a Raspberry Pi 3?

I have a Raspberry Pi 3 and I am struggling with installing Mosquitto. It seems to be caused by a bad mosquitto-jessie.list file: deb https://repo.mosquitto.org/debian jessie main It could not ...
3
votes
1answer
2k views

Apt-Get Remove Does Not Fully Remove

I have noticed that when I in Raspbian run the commands: sudo apt-get remove package and sudo apt-get purge package there are still files related to the package on my system such as folders with the ...
3
votes
1answer
146 views

Script Installation Problems RP 2 | iojs | node | npm

I am trying to install this Script on my RaspberryPi 2 with wheezy on it. I think I am having problems installing npm. Here is the script: if [[ "$USER" != 'root' ]]; then echo "Sorry, you need to ...
3
votes
1answer
1k views

How to install pre-compiled Ruby 2.0 on Raspbian?

I am usually recommend to people who want to install Ruby to use something like RVM or rbenv (my preference). However, I'm in the process of installing Ruby from source (using rbenv) and it has taken ...
3
votes
2answers
390 views

Is it safe to configure unattended-upgrades to use Debian security updates on Raspbian Lite?

When setting up Raspbian Lite and installing unattended-upgrades, the origins list defaults to this: "o=Debian,codename=${distro_codename},label=Debian-Security"; Is it safe (or wise) to use this, ...
3
votes
0answers
534 views

Apt-get upgrade broken

I've got an error while trying to upgrade my pi. I can't even reboot it. My SD Card wasn't full. pi@raspberrypi ~ $ sudo apt-get dist-upgrade Lecture des listes de paquets... Fait Construction de l'...
3
votes
1answer
1k views

Can't install iceweasel on RPi3 using apt-get or aptitude - Failed to fetch

I cant install Iceweasel on my Pi for some reason. I have tried the following options: sudo apt-get install iceweasel Error: Reading package lists... Done Building dependency tree Reading ...
2
votes
1answer
8k views

Raspberry Pi's apt-get cannot find repositories

After entering: apt-get install python3-pip on bash for my Raspberry Pi 2 (Model B) I get this output (linky). I've tried the usual dance of apt-get install -f, apt-get update and apt-get upgrade to ...
2
votes
2answers
238 views

update-command-not-found gives « KeyError: 'rpi' » after upgrading to Rapsbian Buster (testing)

I just updated my Raspbian to Buster (testing) by editing /etc/apt/sources.list and replacing all stretch with buster and doing apt update && apt dist-upgrade. Now apt update always shows an ...
2
votes
2answers
6k views

Error on sudo apt-get update

I'm getting the below error when updating raspian. I connect via SSH via putty on the fixed wlan0 ip. Now when i run sudo apt-get update i get errors like below. Err http://raspberrypi.collabora.com ...
2
votes
1answer
2k views

how do I install the djpeg binary? [closed]

I have a suite of scripts which I require and which make extensive use of djpeg. but 'which djpeg' returns nothing. How do I get the djpeg binary installed on my raspberry?
2
votes
1answer
242 views

I cannot install a very popular component, libmysqlclient-dev. What's wrong?

On an up to date stretch, I want to install libmysqlclient-dev libmysqld-dev, but apt tells me it was not available in my sources. /etc/opt/sources.list looks like this: deb http://raspbian....
2
votes
1answer
3k views

Why does sudo apt-get build-dep not work for emacs24?

this is my first post on this SX Forum. After doing some searching myself (and failing), I wanted to ask why the command sudo apt-get build-dep emacs24 fail on a Pi running Raspbian Jessie? The ...
2
votes
1answer
123 views

What is ffmpeg “rpt1” version?

When I run apt-cache show ffmpeg, there are two versions available. One of them has "rpt1" on the end of the version number. I can't find any info about this; what is the difference between the two? ...
2
votes
2answers
3k views

raspbian + libavcodec + which source repository

I have a Raspberry Pi 2 which is running Raspbian (Noobs 1.9.2). I'm able to install the libavcodev-dev package with the following command: sudo apt-get install libavcodec-dev It seems libavcodec ...
2
votes
4answers
5k views

sudo apt-get not working

I was trying to install re2c but terminal replies the following: sudo apt-get install re2c Reading package lists... Done Building dependency tree Reading state information... Done The ...
2
votes
2answers
6k views

Raspberry Pi B+ can't install node-red

I read an article on the newest MagPi about node-red and I decided to install it. I used: sudo apt-get update sudo apt-get upgrade sudo apt-get dist-upgrade sudo apt-get install nodered The 4th ...
2
votes
1answer
673 views

apt-get install and resource temporarily unavailable

When I try and install a package with apt-get, I get the error message: E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
2
votes
3answers
6k views

apt-get install/upgrade 403 Forbidden

I'm trying to install watchdog on a Pi running Raspbian v 3.12: 2014-09-09, it's currently connected to the internet fine. However if I try to install it sudo apt-get install watchdog I receive 403 ...
2
votes
2answers
183 views

“apt-get: command not found” issue on raspberry pi os built using Buildroot

I have built a sdcard.img for raspberry pi using Buildroot. When I run apt-get command it throws error "apt-get: command not found". I did not find apt-get/dpkg package to enable in 'make menuconfig' ...
2
votes
2answers
136 views

Not enough space for 105M archives when 869M is left

The command sudo apt-get upgrade says [...] Need to download 105 MB in archives. After this operation, 2.108 kB disk space will be used E: Not enough space in /var/cache/apt/...
2
votes
2answers
175 views

Why does 'apt install node-body-parser' fail?

I have a small Node.js app of my own running on a Raspberry Pi 3 B. A recent apt full-upgrade bumped the nodejs packet from version 4.8.2 to version 8.11.1, and in the process it removed the package ...
2
votes
1answer
161 views

Why can you only have one root user terminal process running at a time? [closed]

This question was asked out of mostly curiosity. I've just flashed a new SD card with Rasbian Stretch Lite and when I did, little did I know that Stretch Lite is very similar to Arch Linux Arm. And ...
2
votes
1answer
3k views

What repository to add for apt to find raspberrypi-kernel?

In the default Raspbian image I find *raspberrypi* kernel, bootloader, firmware etc. Using a bootstraped Installation I don't find them but using the same entries in /etc/apt/sources.list. In ...
2
votes
2answers
6k views

MongoDB 3.2 or higher on Raspberry Pi 3

I'm trying to update my mongodb version on my raspberry pi. I've runned following commands $ sudo apt-get install mongodb So far so good. I can access the mongo shell by typing mongo in the console. ...
2
votes
1answer
1k views

Raspberry 3.0 apt-get fails

I have a Raspberry 3.0. I am unable to ping yahoo.com, google.com, and a couple of other sites on Raspberry. I am not able to do apt-get update on the Raspberry. Heres the output of the same. root@...
2
votes
1answer
243 views

sudo apt-get update error

I am getting following errors repeatedly upon using apt-get update command : Ign http://mirrordirector.raspbian.org jessie InRelease Err http://mirrordirector.raspbian.org jessie Release.gpg ...
2
votes
2answers
2k views

Keyboard and mouse stopped responding in GUI after apt-get upgrade

We have a Raspberry Pi 2 Model B using Raspbian installed from/on NOOBS card. The GUI desktop was fully functional for several days. While trying to get Python picamera module to work, decided to do:...