The Stack Overflow podcast is back! Listen to an interview with our new CEO.

Questions tagged [apt]

APT is a package manager used on Raspbian and includes commands such as 'apt-get'.

Filter by
Sorted by
Tagged with
1
vote
1answer
40 views

Updating my application across thousands of nodes. What are the standard tools/procedures?

Are there any standard practice/procedures/tools to perform a software update (OTA) of my c++ application across thousands of battery powered IoT nodes. I don't want to reinvent something, and ...
1
vote
1answer
791 views

raspberrypi-bootloader error when apt installing/upgrading

I've never had this complex of an apt issue. I was trying to install nodejs when I came upon this unmet dependency. Updating, upgrading, and fix-broken install do not solve anything. I need to take a ...
1
vote
2answers
532 views

Downgrade libc6 to resolve breaks?

I was near the end of the process of upgrading my pi from Wheezy to Stretch (which worked according to cat /etc/os-release, I was trying to clean out old packages after reboot). The following ...
1
vote
2answers
2k views

Raspberry pi : apt-get update failes

I was following a tutorial and as dumb as it sounds I was ended up with editing sources.list file and adding new gpg key. now when i'm updating the apt-get i'm getting this error. Any help to get me ...
1
vote
1answer
626 views

Failing to apt-get update

I've been scouring the net trying to find the answer to this and all answers that are close talk about not connecting to the net. I have no problems on the internet, I am typing this on the pi3 that ...
1
vote
1answer
1k views

Raspberry Pi 3 with Ubuntu 16.04.3 LTS sudo apt-get update exits with dpkg error code (1)

I'm running a Raspberry Pi 3 with Ubuntu 16.04.3 LTS xenial. sudo apt-get update exits with: dpkg: error processing archive /var/cache/apt/archives/linux-firmware_1.157.11_all.deb (--unpack): trying ...
1
vote
2answers
2k views

apt-get install [any package] has no installation candidate

I'm having trouble installing any package on my Raspberry Pi v1 B. Whenever I run apt-get install [any package here], it always failed with E: [package name] has no installation candidate. I don't ...
1
vote
1answer
2k views

Cannot use 'apt-get' at all

I have had this problem for a while now and have now decided to ask here. I asked on the raspberry pi subreddit, but found no help. Whenever I try to use apt-get to update or install something, the ...
1
vote
1answer
3k views

Error apt-get install: E: Unable to correct problems, you have held broken packages

I have this raspberry PI 2, which I run Resilio and SSH for backups. I installed a couple of stuff without any issue (APCUPSD, web interface for APCUPSD, apache2). I am trying to install RPI-Monitor ...
1
vote
1answer
543 views

The mirror that apt-get is trying to use is down

I'm living in China and am working on getting OSMC up and going. However, when trying to apt-get install anything, it keeps trying to use mirrors.zju.edu.cn, which is down. I know I can edit sources....
1
vote
1answer
629 views

Command to find source files for apt-get install locations - specifically libasound2-dev

Just downloaded and installed the libasound2-dev package using apt-get install My gcc compile command now references alsa/asound.h correctly But I just want to have a look at all the source files ...
1
vote
2answers
450 views

Is it safe to purge nodejs when replacing “/usr/bin/nodejs” with “/usr/local/bin/node”?

System - Raspbian (Jessie): sudo apt-get install npm sudo npm install -g n sudo n stable Now I have two instances of node. /usr/bin/node -v returns v0.10.29 /usr/local/bin/node -v returns v6.2.1 ...
1
vote
1answer
112 views

Bluez 5.40 not reconized when try to install modules

I have compiled(make ,make install ,etc) bluez 5.40 on Raspbian Jessie 8 successfuly but if i try : sudo apt-get install pulseaudio-module-bluetooth give mean output : extra packages need to be ...
1
vote
3answers
477 views

Download Problems

I bought an Raspberry Pi 3 Model B, and I cannot, in anyway, install the Pi Store or Chromium. I have only been able to somehow install the Google App, which wasn't what I was exactly looking for. I'...
1
vote
1answer
2k views

I can't access the internet through my raspberry pi when connected through ssh

Proof of the error When I try ping 8.8.8.8 through SSH I get this: PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. --- 8.8.8.8 ping statistics --- 3 packets transmitted, 0 received, 100% packet loss, ...
1
vote
1answer
2k views

Raspbian apt-get dependency error with Python?

I've ran the following command on Raspbian: $ sudo apt-get upgrade But now when I try to do: $ sudo apt-get install -f or any other apt-get command, I got this error and I can't get rid of it: ...
1
vote
2answers
556 views

dconf-gsettings-backend:armhf' contains empty filename

Question How to fix error code #2 when updating and upgrading on the raspbian OS? Background I get this error when I'm trying to update and upgrade: dpkg: unrecoverable fatal error, aborting: ...
1
vote
1answer
913 views

csync2 won't install

I've tried to install csync2 using apt-get, but I am getting the error below. I was wondering if anyone knew how to solve this or failing that, could you tell me if this problem could be because the ...
1
vote
0answers
14 views

Floating point exception while upgrading via apt

When I attempt an apt upgrade on my Raspberry Pi Zero W I get the following output: Fetched 5,864 kB in 10s (580 kB/s) Floating point exception E: Sub-process /usr/bin/apt-listchanges --apt || test $?...
1
vote
1answer
85 views

connection failed in apt-get upgrade

I am using Raspberry Pi 3 Model B, and installed raspbian-buster on it. sudo apt-get update works well. But sudo apt-get upgrade shows connection failed. Err:29 http://archive.raspberrypi.org/...
1
vote
0answers
46 views

sudo apt-get update isn't working / networking problem

I am getting following errors repeatedly upon using apt-get update command : pi@raspberrypi:~ $ sudo apt-get update Err:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease Cannot ...
1
vote
0answers
130 views

Update Transmission to 2.94

I have found an answer given in 2014, here, which suggests a method for updating the Transmission version available on the Raspberry Pi's default repositories to the latest version. This appears to be ...
1
vote
1answer
63 views

apt aborts while reading package lists

When trying to run sudo apt-get update, I get three lines of output when all is said and done: Hit:1 http://archive.raspberrypi.org/debian stretch InRelease Hit:2 http://raspbian.raspberrypi.org/...
1
vote
1answer
1k views

add-apt-repository does not work

I am trying to install Atom text editor on my Raspberry Pi 3 B+ with Raspbian as OS. I would like to install it via a package manager using the following commands (instructions found here): sudo add-...
1
vote
1answer
100 views

updating openSSL gives error “files list file for package 'vim-tiny' is missing final newline”

When ever i run apt-get install with openssl or libssl-dev i get the following error After this operation, 10.3 MB of additional disk space will be used. Do you want to continue? [Y/n] y Reading ...
1
vote
0answers
250 views

Segmentation fault apt-get

I have Debian Jessie installed and needed to reinstall Apache. When I typed sudo apt-get remove apache2 I managed to remove this package. However, any subsequent commands to apt-get produce a ...
1
vote
1answer
483 views

ssmtp fails to install

I tried to install ssmtp but it fails. I updated and upgraded everything before trying this command but it displays this error message. pi@raspberrypi:/etc $ sudo apt-get install ssmtp Reading ...
1
vote
0answers
3k views

Apt-get update stays on 0% [Working] for ever and i cannot install anything anymore

on my Raspberry with Strecth all of a sudden i cannot run apt-get anymore It hangs on 0% working for ever. I'm connected to the internet because i can CURL, ping and everything... if i try to ...
1
vote
0answers
80 views

Data socket timed out with apt-get, stretch, and ssh

Trying to utilize ssh with apt-get over ssh on a stretch RPi. When doing so, however, I receive a data socket timeout error. It works fine using jessie. It might be a bug as similarly described by ...
1
vote
0answers
180 views

HOW TO FIX: “The valid stable is invalid for APT::Default-Release as such a release is not available in the sources”

So as I'm working on a project I type in "sudo apt-get install feh" but after I pressed enter it gave me a "The valid stable isinvalid for APT::Default-Release as such a release is not available in ...
1
vote
0answers
673 views

Problems with PyQt5

Quoting: I developed a similar application using PyQt4 and Qt4-designer. You have to install pyqt4 all modules: sudo apt-get install qt4-default qt4-designer qt4-doc qt4-dev-tools python-...
1
vote
0answers
164 views

Errors retrieving packages from raspbian.org

Trying to install hostapd with apt-get fails with a 404 error "Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/w/wpa/hostapd_2.3-1+deb8u4_armhf.deb When I go to the link and look,...
1
vote
0answers
498 views

Remove repository from sources.list.d

I have a repo in my sources.list.d/raspi.list that I can't seem to remove. I'm able to remove the repo from the list (sudo vi) and save it, but when I reboot the old file is restored. How can I ...
1
vote
0answers
246 views

Trying to install mysql-server and it throws a mariadb error

While trying to install mysql-server, I get this error: root@raspberrypi:~# sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done ...
1
vote
1answer
337 views

Could not open locked file when trying to install with apt-get

Now, here is my question: Who hates apt-get? Almost no one. Who gets problems with apt-get? I do. And I am. Sometimes, using sudo apt-get upgrade takes sooooo long you just close off terminal to ...
1
vote
0answers
662 views

I'm unable to install samba

I'm having trouble with samba that won't install. I did try several time with purge uninstalling and reinstalling but i'm always ending with an error related with a shared library, it seems that the ...
1
vote
1answer
471 views

How do you use Gnash?

So. Looking over the internet to find some kind of substitute to adobe flash, I landed on the raspberry pi forum or something (Forgot the link). I saw somebody talking about Gnash from GNU, and after ...
1
vote
0answers
34 views

Pi rebooting on 1 specific apt-get installation

I am experiencing a very peculiar problem with my Raspberry Pi 3 (model B V1.2), running the latest version of Raspbian (the June 2017 version). Whenever I try to install nginx using apt-get, my Pi ...
1
vote
0answers
231 views

sudo apt-get install not working

when I try apt-get install upgrade this error shows up: pi@raspberrypi:~ $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want ...
1
vote
0answers
185 views

Unable to install vnc server as unable to update

I have just installed Raspbian on my Raspberry Pi. Now I want to install the GUI. So for that, I tried to install VNC server by runing sudo apt-get update Which gave me the error: temporary failure ...
1
vote
0answers
623 views

Help with Raspbian apt-get update - mirrordirector.raspbian.org not resolving

I just ran a sudo apt-get update and received error messages saying Err http://mirrordirector,raspbian.org jessie InRelease --Etc-- W: Failed to resolve.... and it said that some index files ...
1
vote
0answers
370 views

Dpkg error when make apt-get install

When I try to install a package, I get this error every time: Setting up ntp (1:4.2.6.p5+dfsg-7+deb8u2) ... update-rc.d: warning: start and stop actions are no longer supported; falling back to ...
1
vote
0answers
144 views

cron-apt is always unable to connect to network

I am using cron-apt to keep my Pi up to date. However, since a few weeks, I always get these error messages in the mail, when cron-apt runs: CRON-APT RUN [/etc/cron-apt/config]: Sat Feb 25 04:00:01 ...
1
vote
0answers
1k views

Correct sources.list when upgrading from stable to testing

Last night I followed this guide to upgrade my headless pi server from Jessie to Stretch. Everything worked as expected and the version output is now Stretch: cat /etc/os-release PRETTY_NAME="...
1
vote
0answers
954 views

apt-get install fails to install OpenMediaVault - php5-pam dependency not available

While installing Open Media Vault following instructions on https://forum.htpcguides.com/Thread-Installing-OpenMediaVault-on-Pi3 or http://forum.openmediavault.org/index.php/Thread/5302-Howto-install-...
1
vote
2answers
1k views

Missing dpkg after sudo apt-get update

I've tried to update my raspberry, received 503 Service Unavailable message and now I can't install anything, because of missing dpkg directory.. root@raspberrypi:/sys/bus/w1/devices# sudo apt-get ...
1
vote
1answer
3k views

Unable to install dialog package

I'm using wheezy on my raspi and wanted to install dialog. sudo apt-get install dialog E: Package 'dialog' has no installation candidate So I look up the source Package: dialog Versions: 1.1-...
1
vote
0answers
56 views

apt-get stopped working

I randomly started having trouble using apt-get on a Raspberry Pi 3 running Raspian. I can remove packages just fine, but when I try to install one, I always get the message E: Unable to locate ...
1
vote
1answer
759 views

Failing to install Jenkins on Raspberry Pi 3 Model B

I have been following some excellent tutorials on How to Install Jenkins onto a Raspberry Pi. After changing the Raspberry Pi 3 Model B's default Java version to 1.8.0_101 and completing the steps to ...
1
vote
1answer
240 views

Can't install rails3 - unmet dependencies

I just got a Raspberry Pi 3 (I already have a fair amount of UNIX experience) and installed Raspbian. I'm trying to install Rails 3 with apt-get. When I try, I get a message about unmet dependencies. ...