We’re rewarding the question askers & reputations are being recalculated! Read more.

Questions tagged [apt]

APT is a package manager used on Raspbian and includes commands such as 'apt-get'.

Filter by
Sorted by
Tagged with
1
vote
1answer
245 views

Can't install rails3 - unmet dependencies

I just got a Raspberry Pi 3 (I already have a fair amount of UNIX experience) and installed Raspbian. I'm trying to install Rails 3 with apt-get. When I try, I get a message about unmet dependencies. ...
1
vote
0answers
866 views

E: Package '<any package>' has no installation candidate

I am unable to apt-get install any packages because E: Package '<package name>' has no installation candidate. Unlike the other similarly named questions, I have not been able to get any ...
1
vote
1answer
1k views

ln: failed to create hard link ‘/boot/initrd.img-3.6-trunk-rpi.dpkg-bak’ => ‘/boot/initrd.img-3.6-trunk-rpi’: Operation not permitted

pi@igla:~ $ cat /etc/os-release PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)" NAME="Raspbian GNU/Linux" VERSION_ID="8" VERSION="8 (jessie)" ID=raspbian ID_LIKE=debian HOME_URL="http://www.raspbian.org/" ...
1
vote
0answers
1k views

Unable to run upgrade on Raspbian

I'm running Raspbian inside QEMU, and I'm getting an error when I try to run sudo apt-get upgrade: dpkg: error: fgets gave an empty string from `/var/lib/dpkg/triggers/File' Google finds almost no ...
1
vote
0answers
287 views

How to upgrade bluez to 5.37

I've got a Raspberry Pi 3 with Raspbian Jessie installed. I am trying to get flic buttons working with my pi (based on this github project). To get this to work I need Bluez 5.37. When I update I ...
1
vote
0answers
346 views

Why aren't the current kernel headers available via apt-get

I am trying to compile some usb drivers for the pi and therefore, I need to get the headers that correspond to my present kernel uname -r produces 4.1.7+ Based on my experiences with Debian and ...
1
vote
0answers
109 views

Random Perl error occurs when trying apt-get upgrade

As of today, suddenly following error occurred while I tried to execute apt-get upgrade Unrecognized character \xA8; marked by <-- HERE after sys_stat_h<-- HERE near column 15Compilation failed ...
1
vote
1answer
3k views

Installing MySQL server in latest (NOOBS) Raspbian

Here I was, following this tutorial (http://www.penguintutor.com/linux/raspberrypi-webserver), because I wanted to host a pretty simple PHP site on my Raspberry Pi. But once again, as it usually ...
1
vote
0answers
743 views

Problem with debconf when trying to upgrade

I have problem with upgrade my system. When i used command: sudo apt-get upgrade I get an error: Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File....
0
votes
2answers
101 views

Should I change the installation directory for apt?

I was recently attempting to update some files using apt-get and was given an out space error. I then realized everything was being installed to the boot partition which is only 40mb (on a 32gb card). ...
0
votes
2answers
568 views

Pre-built OpenCV on Raspbian Buster

The hassle of installing OpenCV on Raspbian is something many want to avoid, and the easiest way to do this is to use a prebuilt image. I decided to take this route, only to find most pre-built images ...
0
votes
3answers
2k views

How to run an installed program that is not in the main menu?

I opened a terminal window using the launch bar icon (next to the "Menu" button on Jessie) and typed in sudo apt-get install omxplayer. After doing its thing without errors, it said that I already had ...
0
votes
3answers
4k views

sudo apt-get update Not working

Pi connected via ssh remotely. This is the log running pi@raspberrypi:/etc $ sudo apt-get update Err http://mirrordirector.raspbian.org jessie InRelease Err ht**://raspbian....
0
votes
1answer
252 views

Failed to fetch https://dev2day.de/pms/dists/jessie/main/binary-armhf/Packages HttpError404

I'm trying to do a simple sudo apt-get update on my Raspberry Pi 2, but I keep getting 404 error: W: Failed to fetch https://dev2day.de/pms/dists/jessie/main/binary-armhf/Packages HttpError404 ...
0
votes
1answer
115 views

Permission denied error when using apt and apt-get as root on raspbian

I keep getting an error when I use apt or apt-get as a root user or using sudo with the default pi account. Ign:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease Ign:2 http://archive....
0
votes
1answer
241 views

How to remove `raspi-copies-and-fills` from Raspbian

I did apt update && apt upgrade as root and now my Raspbian system is corrupt and won't boot anymore. After some debugging I noticed there's the package raspi-copies-and-fills. Fortunately, ...
0
votes
1answer
955 views

“apt-get remove python” removed a ton of other stuff, RPi messed up

So I was trying to install the Python library lzma, and somehow I got to the point of removing python2.x, and I don't know why I did that. I'm tired, that probably why. I think I learned my lesson. ...
0
votes
1answer
4k views

Installed kernel headers and $(uname -r) differ

Raspberry Pi 1 Model B. If I run: uname -a I get: 4.9.16+ Gcc version: 4.9.2 If I execute: sudo apt-get install raspberrypi-kernel-headers it installs me 4.4.50+ Why and how can I install the ...
0
votes
1answer
2k views

G++4.9 not found, Raspberry Pi Jessie

I am trying to install gcc4.9 and g++4.9 on my raspberry pi jessie. I am following this tutorial, however when it comes to running: sudo apt-get install gcc-4.9 g++4.9 I get: Reading Package Lists....
0
votes
1answer
1k views

I can't upgrade!

I was installing and removing packages recently and i noticed that it said: 0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded. as soon as i ran the command. But, when i ran sudo apt-get ...
0
votes
2answers
4k views

Changed sources.list, but still updates from archive.raspberrypi.org

i am using a local apt-mirror to mirror raspbian and ubuntu and changed to /etc/apt/sources.list on my pi. But it still updates from archive.raspberrypi.org. From apt-mirror config: #Raspbian deb-...
0
votes
2answers
3k views

RPI2 raspban wheezy on can't install autoconf

I am using a raspberry pi 2 model b running raspbian wheezy. I am trying to install a package autoconf and it says: $sudo apt-get install autoconf E: no such package autoconf
0
votes
2answers
176 views

Why don't I get all available packets from apt?

I wanted recently to install profanity, a xmpp client, on my raspi. I ran a apt-get update, then a apt-get dist-upgrade, and tried to install the package. but it doesn't find it! But on this link: ...
0
votes
1answer
5k views

apt-get “cannot locate the package”

I was following a tutorial online so I can install a USB DisplayLink monitor, and it told me to type: sudo apt-get install git-core gcc-4.6-arm-linux-gnueabi I tried that, and it says it "cannot ...
0
votes
2answers
4k views

Hash sum mismatch error

Context: I have 8 Raspberry Pi Computers in my class. After flashing the most recent version of Raspbian onto 8GB SD cards which were originally sold with NOOBS on them (the cards are therefore ...
0
votes
1answer
23 views

Chromium wont open - Attempted Reinstall left me with dpkg error processing package mime-support (--configure)

My Chromium wouldn't open - it was giving me the loading icon then nothing. I found the following topic and tried using the commands written in it. sudo apt-get remove chromium-browser sudo apt-get ...
0
votes
1answer
32 views

Raspian apt returns to prompt without doing anything - any ideas?

apt and the associated tools are not working using any of them: sudo apt, apt-get, apt-config, aptitude, ..., just returns me to the prompt. I checked /var/log/apt and nothing is getting written to ...
0
votes
2answers
5k views

Raspberry Pi sudo apt-get update not working

I am getting the following message whenever I try to run: sudo apt-get update : pi@raspberrypi:~ $ sudo apt-get update Get:1 http://archive.raspberrypi.org/debian stretch InRelease [8,084 B] Err:1 ...
0
votes
1answer
197 views

how to install libdb4.8 on jessie?

since jessie has libdb5.3 which is incompatible with libdb4.8 how to install the latter. I added oldstable main contrib ... to the mirrordirector but no chance in finding it. Where are the old ...
0
votes
1answer
717 views

Raspbian Jessie Lite apt-get problem

every apt-get install operation runs in to the following error dpkg: error: fgets gave an empty string from `/var/lib/dpkg/triggers/File' E: Sub-process /usr/bin/dpkg returned an error code (2) it ...
0
votes
1answer
793 views

Install NFS server

On my Raspberry I try to install NFS like following: $ sudo apt-get update $ sudo apt-get upgrade $ sudo apt-get install nfs-common nfs-kernel-server The last command returns: Reading package lists....
0
votes
2answers
154 views

USB ports unrespnsive after dist-upgrade

I was running apt-get dist-upgrade when my pi froze up. Afterwards, I booted it up and the keyboard and mouse went unresponsive. How do I fix this? edit: By freeze I mean it locked up. I do not know ...
0
votes
1answer
844 views

my raspberry wont let me upgrade

Every time I try to upgrade I receive the following ouptu: sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run '...
0
votes
2answers
68 views

Change to Testing Suite

I want to run raspbian testing (bullseye). By default the following repos were enabled http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi http://archive.raspberrypi.org/...
0
votes
1answer
111 views

Installing openssl 1.0.2g on jessie

I need to use libssl-dev 1.0.2g to compile some old codes. I followed the guides in stackoverflow but it does not work in my case. This is my /etc/apt/sourcelist deb http://mirrordirector.raspbian....
0
votes
1answer
310 views

Illegal instruction when trying to update package on Raspbian-Lite

On Raspbian Lite I'm trying to run apt-get upgrade but running into following issue: Setting up libssl1.0.2:armhf (1.0.2r-1~deb9u1) ... dpkg: error processing package libssl1.0.2:armhf (--configure): ...
0
votes
1answer
329 views

OpenCV install 'so' files not found cant insall via apt

Rasp 3 B+, Raspbian I installed OpenCV using pip3 install opencv-python Then tried to import cv2 which threw the error.. ImportError: libcblas.so.3: cannot open shared object file: No such file or ...
0
votes
1answer
266 views

raspberrypi-bootloader error during apt-get upgrade after restore form backup, how to fix?

I recently restored a pi 3 from a backup. Before the incident that required the restore I had it booting from a USB SSD hard drive. To restore the operating system I simply copied the root directory ...
0
votes
1answer
116 views

Butal error on apt-get [closed]

pi@raspberrypi:~ $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to ...
0
votes
2answers
9k views

Upgrade or install using apt-get results in dpkg error

Raspbian Stretch OS I tried sudo apt-get update and then upgrade There is no issue with update but upgrade or while installing any package for instance sudo apt-get install tightvncserver gives the ...
0
votes
3answers
316 views

How to install packages via “apt-get” while ssh connected to MacBook via ethernet cable?

I'm very new in Rpi community and sure enough had to spent the last 24 hours to figure out how to ssh connect from my MacBook to my Pi3 via an ethernet cable. I'm following the steps in the second ...
0
votes
1answer
672 views

Cannot Connect to Wifi

So to begin, I have a brand new Raspberry Pi 3 B with Raspbian installed from NOOBS. I am trying to connect it to Wi-Fi however the GUI says No Wireless Interfaces. When I hop into Terminal, I can see ...
0
votes
1answer
49 views

Did dumb thing and removed GTK3.0 folder

So I removed the folder. OK...dumb move Now, when I try to install again.... sudo apt-get install libgtk-3-dev It responds: "libgtk-3-dev is already newest version" So how can I re-install ...
0
votes
1answer
482 views

Can't rpi-update

I can't update the kernel of my pi anymore. When I try I have those errors : pi@raspberrypi ~ $ sudo rpi-update *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom *** ...
0
votes
1answer
1k views

Issues with apt-get install vlc

I am using a RPi 2 B and Raspbian I am trying the following command via ssh to install VLC sudo apt-get install vlc I also tried sudo apt-get install vlc --fix-missing I get two prompts about ...
0
votes
1answer
318 views

Dependency/configuration problems upgrading firmware and bootloader

As you can see the log , there seem to be a problem with the raspberrypi-bootloader. I do not know whats going, but it looks like a dependency problem. But because it happens alter a upgrade I suppose ...
0
votes
1answer
602 views

Dependency problems with nginx

I'm trying to install nginx, but I get the error message: Get:1 http://mirrordirector.raspbian.org/raspbian/ jessie/main nginx-common all 1.6.2-5+deb8u2 [86.7 kB] Fetched 86.7 kB in 10s (8,617 B/s) (...
0
votes
2answers
116 views

Where are the python picamera docs?

I installed the package python-picamera-docs successfully, with the command sudo apt-get install python-picamera-docs, on raspbian, but I can't actually find the docs. I looked in /usr/share/doc/...
0
votes
1answer
3k views

Problems installing build-essential in RASPBERRY PI 1 MODEL B+

I tried to install the package build-essential under 2015-05-05-raspbian-wheezy: sudo apt-get install build-essential –y but that is the result: Reading package lists... Done Building dependency ...
0
votes
2answers
580 views

How to force rsync upgrade

I'm currently using Raspbian as my raspberry OS, but the rsync package that comes with it is at version 3.0.9, and I need version 3.1.0 or above. I've tried to upgrade but there's no new package ...