All Questions

Tagged with
Filter by
Sorted by
Tagged with
1
vote
0answers
28 views

Aux and HDMI audio options missing

Background (To give some perspective on the issue): I am using mopidy and mopify as an audio server on a Raspberry Pi 3 B+. WHen setting this up, I found that it would not output through a USB audio ...
1
vote
0answers
125 views

Connect Raspberry Pi via Bluetooth to Sound Bar

after spending the last couple of weeks trying to connect my bluetooth soundbar to my Raspberry Pi 3 B+ and playing all audio output on it I am close to giving up. Using the GUI I can successfully ...
0
votes
0answers
190 views

Problem with aplay: “set_params:1363: Unable to install hw params”

I have been successfully using the command aplay -D bluealsa:HCI=hci0,DEV=EB:06:BF:19:C2:D3,PROFILE=a2dp Open.wav to play sound over a BlueTooth device. HOWEVER after a few hours of trouble free ...
2
votes
1answer
179 views

How can I direct the output both of mpg123, and of eSpeak to the same ALSA sound device?

I'm currently struggling with the following scenario: I'd like to make my Raspi (3B) play a short MP3 jingle and then, after a 250 µsec pause, speak a short text by using an add-on sound card (...
1
vote
1answer
603 views

Command aplay does not work without sudo

The command aplay only works if preceded by sudo. omxplayer test.wav will play the audio I recorded with arecord just fine. aplay text.wav does not, but sudo aplay test.wav does. The suggestions from ...
0
votes
2answers
3k views

Linux ALSA one sound card for input one sound card for output

I have a raspberry pi 3 model B+ with raspbian jessy lite from July. cat /proc/asound/version Advanced Linux Sound Architecture Driver Version k4.4.50-v7+. I have a USB soundcard that has two 3.5 ...
1
vote
1answer
408 views

gmediarender configure output mono

I have configured gmediarender on the RPi 3. However I prefer only mono output. Following this guide to downmix to mono did not output mono from the gmediarender. /etc/asound.conf pcm.card0 { ...
0
votes
1answer
248 views

Sudo Alsactl Store Not Saving Capture Settings

I am working on a project with alsa on the Raspberry Pi, and whenever I reboot my capture settings are reset. I have tried saving them via sudo alsactl store but this only saves the playback ...
2
votes
0answers
694 views

Loopback to aux out and record audio at the same time from audio in

I am currently developing a device that silences adverts from a streaming radio. Im taking audio input from a radio to a USB sound card.To silence the ads, I have am currently using the arecord ...
2
votes
2answers
5k views

Possible to route audio directly from usb-audio line-in to same usb audio line-out?

I have a Raspberry Pi 3 - and was able to get my ASUS USB audio device to work both with mic/line-in and output to speakers. Right now I can do it it in two steps: arecord will record to a wav file ...
3
votes
2answers
1k views

What's the difference between aplay -l and aplay -L?

I'm trying to configure my Raspberry Pi (model B) to work as an AirPlay to Bluetooth bridge of sorts. I'm using Shairport-Sync to receive the AirPlay audio successfully, and can get it to output via ...
1
vote
1answer
1k views

Wrong ALSA volume when starting playback

I run into the same problem than exposed in this post: ALSA volume ignored when beginning playback Here is the context: OS: raspbian Kernel 3.10.36+ #665 just updated the firmware with rpi-update ...