Questions tagged [debug]

The action of finding and removing bugs in computer code.

Filter by
Sorted by
Tagged with
0 votes
0 answers
67 views

Pi 4B OTG USB advanced troubleshooting/debug or logs

I followed this wonderful guide: https://magpi.raspberrypi.com/articles/pi-zero-w-smart-usb-flash-drive and I was able to made it working on my loved Pi4B. Everything works fine as mass storage ...
flic47921's user avatar
0 votes
1 answer
120 views

Raspberry Pi Debug Probe fails with `Error: Unknown flash device (ID 0x00ffffff)`

I am trying to debug a custom rp2040b2 board with Winbond W25Q128JVSQ with the debug probe and am following the Raspberry Pi Debug Probe tutorial. The board is intended to be similar to a Pico (for ...
Akutra Cea's user avatar
0 votes
0 answers
84 views

SWD debugging for Raspberry Pi Zero W

I am developing a bare metal program that will be run on a Raspberry Pi Zero board. Is it possible to debug the program with the SWD protocol? Are RPi0/1 boards (which are based on BCM2835 SoC) able ...
علاء الليبي's user avatar
1 vote
1 answer
502 views

Debugging using raspberry debug probe fails with SWD error

I am trying to debug some code on a Raspberry Pi Pico W. I'm using PlatformIO. After some Issues with the OpenOCD version shipped with PlatformIO (Access Violations), which I fixed by replacing the ...
Lukas's user avatar
  • 11
1 vote
0 answers
456 views

Debugging micropython code using raspberrypi pico debug probe

I was wondering if there is a way to debug micropython code on raspberrypi pico with/without the "debug probe". Documentations described steps for C language in details, but nothing was said ...
Omid Ataollahi's user avatar
0 votes
0 answers
207 views

VSCODE integration of debugging Raspberry Pico with Debug probe. On MacOS host platform not able to configure

I asked the same question in stackoverflow.com but it may be more appropriate to ask this question here: I have been pulling my hair out trying to configure VSCode on MacOS to support the debugging of ...
Hans van Schaick's user avatar
1 vote
1 answer
997 views

debug dhcpcd using the lease file at /var/lib/dhcpcd/*.lease

I am having problems with the dhcp leases of my eth0 interface. My rpi does not renew its lease when it expires. My lease file has many special characters, is this normal? My configuration : Compute ...
maxmet's user avatar
  • 13
1 vote
1 answer
278 views

GDB pointing to the wrong file when debugging with picoprobe + openOCD

I'm trying to debug a Raspberry Pi Pico project using openOCD + Picoprobe. I go through the steps that appear to be correct to do all this from my Linux PC (the Get started with Pico and C++ guide is ...
Francisco Ayrolo's user avatar
1 vote
0 answers
871 views

Chromium crashes after reinstallation on pi4

I noticed, today, that pages weren't loading in chromium, but If I pinged them in bash, using ping google.com, it went through just fine. So, I reinstalled chromium, but, now a different problem has ...
Project Awesome's user avatar
0 votes
1 answer
472 views

Why does dhcpcd flood my logs with with useless messages when I use the `inform` option?

In accordance with man dhcpcd.conf I used the inform option to set a static IP address. Using this option seems to cause my DHCP client dhcpcd to flood my logfile with useless messages. Here is a ...
Seamus's user avatar
  • 22k
0 votes
1 answer
124 views

Debug Suggestions for Crashing Remote Pi4

I have a RPI4 in a remote location that has become unresponsive (not network) twice in the last 6 months. It will be another 6 months until I can travel and replace the device. My gut says it's a ...
NJL's user avatar
  • 13
1 vote
1 answer
527 views

Raspberry Pi Mailbox Interface Difficulties

I have been working on a bare metal program on my Raspberry Pi 3 B and am currently working on using the Mailbox Property Interface. I have been able to use it to initialize a framebuffer using the ...
Someone's user avatar
  • 111
0 votes
2 answers
429 views

Debugging potentially broken uart pins

I have recently been working on a bare metal project on a raspberry pi. I have been using a uart to usb cable to for logging, which has been able to send messages to my computer. Recently however, it ...
Someone's user avatar
  • 111
0 votes
1 answer
106 views

Starting up GCompris on a RPI4 for a specific user

I have installed GCompris on a RPI4 which is running the latest Raspberry Pi OS. I have 2 users. the default pi user and i also created a user call "student". I can start GCompris when ...
N. K. D's user avatar
0 votes
0 answers
101 views

Retropie that works fine on a computer monitor but shows no signal in a car

For the same Retropie (4.7.1) on a Pi 3B+ and the same HDMI cable, the Pi works fine on a computer monitor but shows no signal on the display of a car's rear entertainment system. This is an Acura MDX ...
yurnero's user avatar
  • 113
0 votes
0 answers
94 views

Optimize C code for ARM Cortex A53 (using RPi 3B+ for debugging)?

I need to debug (and possibly verify, profile and optimize) some audio algorithms for Arm Cortex A53. The algorithms take input from file as PCM samples, and also drop the output the same way, as PCM ...
Danijel's user avatar
  • 123
1 vote
2 answers
617 views

How to get netboot debug info from start.elf

I am attempting to netboot Ubuntu 20.04.1LTS arm64 on a Raspberry Pi 3B v1.2. To do this, I have replaced the Ubuntu u-boot boot loader with the Pi boot loader, as instructed in the Ubuntu ...
Zsub's user avatar
  • 111
-1 votes
2 answers
84 views

How to stop this code

I am using this script to play notes on a Piezo in Python, but need help making it stop. Here is the full code, it is still a work in progress. A lot of it is probably irrelevant to the problem, but I'...
user avatar
0 votes
0 answers
155 views

How to debugg kernel panics?

I have an Raspberry Pi V3 running as a home server for some years. Since a while ago, it doesn't run stable anymore, instead, after it is up for a couple of days sometime after a couple of hours, it ...
user5950's user avatar
  • 182
3 votes
0 answers
137 views

Raspberry Pi button bug, what is happening?

I am new user of raspberry pi. I have two buttons, and some code to run, yet the led will not react to the buttons. It's probably a easy fix, but keep in mind, I am new to robotic and have only ...
Robotechnology's user avatar
2 votes
0 answers
123 views

g++ and gdb debugging does not provide full backtrace

I never experienced this behaviour on classic desktop platform thus I'm asking here. The question is how to correctly debug C++ application (g++ build) using GDB on Raspberry Pi? When my application ...
bigmuscle's user avatar
  • 241
4 votes
1 answer
818 views

Accessing Raspberry Pi JTAG randomly fail

I am trying to debug a Raspberry Pi 3B (rev 1.2) bare metal application using JTAG. I have no JTAG adapter so I am using another Raspberry Pi (3B rev 1.2) as JTAG adapter. I am using OpenOCD and it ...
Misaz's user avatar
  • 118
1 vote
0 answers
761 views

Client can't connect to pivpn

I have a custom setup and wish someone could help. I have a main router(R1) and a secondary router(R2). I will refer to main router as (r1) and secondary router as (R2). (R1) is used for home ...
Nsain38's user avatar
  • 11
0 votes
1 answer
1k views

How do I use the send_message method on a Raspberry Pi 3?

When I run this code: import datetime import smtplib import re import email from email.mime.text import MIMEText import email.message from robobrowser import RoboBrowser from bs4 import BeautifulSoup ...
arujbansal's user avatar
4 votes
2 answers
397 views

Visualize execution of scripts

I have a script that always runs on the Raspberry Pi. I defined with sudo nano /etc/rc.local so that they turn even after a reboot or a power failure. My question is how can visualize the execution ...
Amélie's user avatar
  • 41
0 votes
1 answer
553 views

Printing Python Variables for Debugging

I'm a Python newb so please bear with me if I'm asking a stupid question. I have a RPi3 running Jessie lite. I have Apache and PHP installed. I also have netatalk installed and have mounted my pi e....
Stuart Brown's user avatar
0 votes
1 answer
664 views

Eclipse PyDev remote debugger Raspberry Pi

I have just created a SSH connection between my Raspberry Pi 3 b+ and my computer using WiFi. I have downloaded Eclipse and the PyDev and RSE plugins so I can use Eclipse as IDE for my Python scriptss ...
Dani's user avatar
  • 21
0 votes
2 answers
2k views

Routing table gets reset with new ip address

I am using the AT&T Avnet IoT Starter Kit to provide cellular connectivity to my Raspberry Pi 3b+. In order to establish the routing table I added an ip command to the file /lib/dhcpcd/dhcpcd-...
Connor McCormick's user avatar
1 vote
0 answers
310 views

Raspberry Pi Version 1 B (512 MB) - Using JTAG

I want to use an FT2232H Mini Board as Raspberry Pi JTAG (based on https://github.com/dwelch67/raspberrypi/tree/master/armjtag). I use a raspberry pi B version 1 (this one with the 26-pin connector ...
Kampi's user avatar
  • 203
9 votes
1 answer
15k views

How to correctly restart wpa_supplicant debug with networkd-systemd?

I am trying to debug setting up wifi with networkd-systemd managing wpa_supplicant. The overall objective is to get wifi AP and managed client modes working at the same time. I can get managed ...
dazz's user avatar
  • 175
2 votes
0 answers
219 views

RPi & VisualGDB - running GUI application

I am trying to run an application compiled in VisualGDB on my Raspberry Pi. In Visual Studio debugging works fine, but I need to run this application on an HDMI monitor. I tried to run the file on RPi,...
kajoje's user avatar
  • 21
3 votes
1 answer
10k views

Clients cannot connect to pivpn server anymore

I have been using and enjoying pivpn for nearly a year now. I am running pivpn and Pi-hole on the same RasPi without issues until now. Recently I have not changed anything besides the occasional apt ...
jaaq's user avatar
  • 173
0 votes
0 answers
173 views

Parallax MS5607 and Raspberry Pi 3?

I am trying to connect the MS5607 to the Raspberry Pi via I2C. I can confirm that it connected when I run sudo i2cdetect -y 1. I then went ahead and tried to use rsolomon's python code. First error I ...
Sailanarmo's user avatar
1 vote
0 answers
224 views

Python 3 Debugging Symbols for Raspbian Stretch

I am trying to track down a segfault when using Pip on my Raspberry Pi Model 3B running Raspbian Stretch. I've configured the pi to do a core dump, and I've gotten gdb to load the core. The ...
user9414732's user avatar
3 votes
2 answers
8k views

How to see debug logs from Raspberry Pi 3 during boot process?

I am currently trying to debug a "black screen" on a Raspberry Pi. The Pi is plugged to an in-house PCB using connector of the Pi and the LCD screen is connected on this in-house board. The Linux ...
user avatar
0 votes
2 answers
76 views

command not doing anything when executing

Sketch of situation I am running a small game server, openttd, on my (headless) raspberry pi 3B. I have been able to play this game, with a huge map, so resources are fine (if you don't mind waiting ...
Nick Dewitte's user avatar
3 votes
1 answer
196 views

Where to find debug output from SD driver?

I have trouble with some SD Cards so I enabled debug output from SD driver with sd_debug=on in /boot/config.txt. I have looked with journalctl and checked the files in /var/log and in /tmp but cannot ...
Ingo's user avatar
  • 42.1k
0 votes
1 answer
855 views

Direct connect router UART 3.3v to pi3B UART 3.3v and use debug console

Can I use a Raspberry PI model B to interact directly to a router debug console (undocumented) via "screen". TX <-> RX RX <-> TX GND <-> GND # screen -L /dev/ttyAMA0 115200,-...
01BTC10's user avatar
  • 103
3 votes
1 answer
1k views

Raspberry pi 3 openocd debugging jtag scan interrogation fail all zeroes problem

I am trying to debug a bare metal application using openocd (seggers does not provide support for the cortex a-53 so jlink won't work). I installed openocd following this set of instructions. However ...
Makogan's user avatar
  • 171
1 vote
0 answers
649 views

Remote python debugging with Visual Studio Code from Mac

I am trying to remote debug from Visual Studio Code on Mac OS. I would like to know if anyone has managed this or if it only possible from Visual Studio for Windows, or if not, what am I doing wrong? ...
Alfred's user avatar
  • 11
-2 votes
1 answer
13k views

Have the GPIO pins changed between the Pi 2 and the Pi 3?

I am trying to get jtag debugging to work and I was wondering whether the pins between the Pi 2 and Pi 3 have any important differences. Because the jtag seggers device I have is connected to a ...
Makogan's user avatar
  • 171
0 votes
1 answer
2k views

Segmentation Fault on mplayer and mpv

I'm trying to run mplayer or mpv on my Raspberry Pi, but even after multiple apt-get removes and even apt-get install --reinstalls, I'm still getting the annoyingly undetailed Segmentation fault error ...
David Refoua's user avatar
0 votes
2 answers
3k views

Auto-login for Raspberry Pi

Let me first say I have a rpi 2 model B with the official 7" display and a old tablet lipo battery. It has Kali Rolling on it. I have tinkered with it quite a bit at this point... I need to auto ...
Bionic Bouncer's user avatar
3 votes
1 answer
188 views

OS-less raspberry pi 2 debugging of Assembly language

I have a Raspberry Pi 2 without an OS installed. I have an assignment where I have to create and display some code in assembly language for the Pi 2. The lab that we have set up at school has ...
SeesSound's user avatar
  • 131
2 votes
2 answers
4k views

Unable to install npm onoff

I'm trying to install onoff via this command $ npm install onoff Every time I try I get this error. I'm new to pi and programming so I'm completely lost. Any help? pi@raspberrypi:~ $ npm install ...
GMit's user avatar
  • 21
7 votes
0 answers
841 views

Debugging a RPi using SWD

Has anybody been able to figure out how to debug a Raspberry Pi 3 model B using SWD? To be clear, I'm looking to debug the Pi itself using SWD. We've tried setting up the GPIO pins to use JTAG-SWD, ...
jloloew's user avatar
  • 71
8 votes
3 answers
3k views

What's causing these crashes after cross-compiling?

I'm trying to cross-compile a large library (TensorFlow) using gcc on Ubuntu. I've installed the g++-arm-linux-gnueabihf toolchain, and was able to successfully build my binary. The process I'm using ...
Pete Warden's user avatar
5 votes
4 answers
6k views

Remote debugging with Visual Studio 2015

I am trying to debug my app that I just deployed to my RPi 2 using Visual Studio Remote Debugger. Does anybody have experience doing this and can point me to how to get started with it?
IngeniouSeven's user avatar
4 votes
4 answers
7k views

Cannot deploy to Raspberry Pi from Visual Studio

I'm having exactly the same issue than here: When I'm in Visual Studio, and I try to deploy I got some error messages: 1>Error: Unable to connect to the Microsoft Visual Studio Remote Debugger ...
J4N's user avatar
  • 293
1 vote
1 answer
1k views

Remote develeopment with Netbeans: debugger goes to disasembly

I managed to set up remote development on RPi with Netbeans 8.0.2 over direct connection to my laptop. my simple program compiled, run and debugged. #include <iostream> using namespace std; ...
Andrey Pro's user avatar