Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [dpkg]

A multi-purpose command associated with package management used on Debian derived systems such as Raspbian.

1
vote
1answer
39 views

Errors while installing OpenSSL from source (.deb) files

I am fairly new to raspberry pi's and Linux so forgive me if my question is trivial. I have been trying to install openssl and libssl via ssh on a Raspberry Pi zero that does not have access to the ...
0
votes
0answers
71 views

Updated apt-transport-https, now `sudo apt-get update` doesn't return any information

I attempted to run sudo apt-get update, but got the error E: The method driver /usr/lib/apt/methods/http could not be found. Following to this answer, I checked /etc/apt/sources.list.d/ and found no ...
1
vote
2answers
351 views

Resolve dpkg was interrupted

I'm still very much a newbie, so please be gentle with me. We had a power cut while running apt-get dist-upgrade [Raspian Jessie] . When the power came back on, I ran apt-get dist-upgrade again but ...
0
votes
2answers
4k views

Upgrade or install using apt-get results in dpkg error

Raspbian Stretch OS I tried sudo apt-get update and then upgrade There is no issue with update but upgrade or while installing any package for instance sudo apt-get install tightvncserver gives the ...
0
votes
0answers
103 views

Kali pkg: error: failed to open package info file '/var/lib/dpkg/updates/0051' for reading: Structure needs cleaning

Using Kali to apt upgrade but get error as: E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem. So I use dpkg --configure -a get error as : dpkg: ...
0
votes
0answers
353 views

How can I install Logmein Hamachi on Raspbian alongside OpenMediaVault?

I have a Raspbian Jessie Image on which I have an installation of Openmediavault. I wish to install LogMeIn hamachi VPN with the Openmediavault installation. The problem is that I am only able to do ...
2
votes
1answer
127 views

Error with Packages, cannot update/install, cannot remove package

I keep having an error installing / updating / basically doing anything that concerns packages. I am trying to get an I2C library going and I can't get sudo-apt-get install i2c-tools to work from a ...
0
votes
0answers
81 views

apt-get upgrade not working anymore

I'm trying to reinstall Raspbian Stretch Lite version to make a fresh install on my Rpi 2 B. I use to follow the every same steps everytime I do this; sudo raspi-config //to expand file system ...
0
votes
1answer
232 views

/boot/upgrade not found on Ubuntu 16.10 with Berryboot

Hi! I am using Berryboot on my Raspberry PI 3 to boot between Raspbian, OPENElec, RetroPie & Ubuntu Server 16.10, Everything works smoothly except for one thing; When using the Apt-get command ...
0
votes
1answer
288 views

Dependencies fail to install, cannot install picamera on pi3

When I run apt-get install python3-picamera it fails with different dependency issues like: files list file for package 'libparams-util-perl' is missing final newline or files list file for package '...
0
votes
1answer
283 views

dpkg: unrecoverable fatal error when installing ImageTK

I get the following error when installing ImageTK. % sudo apt-get install python-pil python-imaging python-imaging-tk Reading package lists... Done Building dependency tree Reading state ...
1
vote
1answer
1k views

Raspberry Pi 3 with Ubuntu 16.04.3 LTS sudo apt-get update exits with dpkg error code (1)

I'm running a Raspberry Pi 3 with Ubuntu 16.04.3 LTS xenial. sudo apt-get update exits with: dpkg: error processing archive /var/cache/apt/archives/linux-firmware_1.157.11_all.deb (--unpack): trying ...
1
vote
0answers
198 views

sudo apt-get install not working

when I try apt-get install upgrade this error shows up: pi@raspberrypi:~ $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want ...
1
vote
1answer
3k views

dpkg was interrupted

I got an error while trying to install phpmyadmin on my Raspberry Pi 3, the error message is: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' I think it's a problem related ...
0
votes
1answer
294 views

Apt-get returns several errors

I'm a newbie running Raspian (Debian 8 Jessie) and managed to mess up something with apt-get. Any advice or hints to fix the errors below would be greatly appreciated! sudo apt-get upgrade Reading ...
2
votes
0answers
336 views

Dpkg error when make apt-get install

When I try to install a package, I get this error every time: Setting up ntp (1:4.2.6.p5+dfsg-7+deb8u2) ... update-rc.d: warning: start and stop actions are no longer supported; falling back to ...
0
votes
1answer
137 views

Error with partially installed package

I was recently trying to install php on my pi: sudo apt-get install php5-common php5-cli php5-fpm It ran for awhile and then froze. I had to leave so I left my laptop open and when I got back, it ...
0
votes
1answer
679 views

Raspbian Jessie Lite apt-get problem

every apt-get install operation runs in to the following error dpkg: error: fgets gave an empty string from `/var/lib/dpkg/triggers/File' E: Sub-process /usr/bin/dpkg returned an error code (2) it ...
1
vote
2answers
628 views

DPKG failing with fail2ban

Everything was working fine until I ran an update. Since the fail2ban package is giving me errors now. I decided that I would try to uninstall it and then reinstall it again. So I ran sudo apt-get ...
2
votes
2answers
574 views

Unable to install systemd on debian 7

I am following the link [ packages.elastic.co/beats/apt stable main ] to install systemd on my raspberry pi b+. When I try the command $ sudo apt-get -t wheezy-backports install systemd It gives ...
1
vote
1answer
2k views

dpkg error on fresh install

i am new to the raspberry and just setup my first one with a fresh NOOBS installation. First thing i did was mounting my external hard drive. Next i did sudo apt-get update && sudo apt-get ...
1
vote
1answer
72 views

What package is /home/pi/python_games coming from?

I tried to find the package with dpkg -S tetromino.py (tetromino.py is a file inside the folder) but there seems to be no package, that installed it. I also tried other files inside the directory. I ...
4
votes
1answer
4k views

Sub-process /usr/bin/dpkg returned an error code (1) on apt-get upgrade

I'm using Raspberry Pi 1 model B without GUI and when I try to upgrade software using sudo apt-get upgrade I get the following error: Segmentation fault dpkg: warning: subprocess old pre-removal ...
1
vote
0answers
596 views

Unable to clean up mess surrounding `./usr/lib/gcc/arm-linux-gnueabihf/5' before installing another version: Read-only file system

I have the following error, how can I fix it please ? root@raspberrypi:/usr/lib/gcc/arm-linux-gnueabihf# sudo apt-get -f install Reading package lists... Done Building dependency tree Reading ...
0
votes
0answers
201 views

can't install locales HELP

When trying to solve this problem here How to fix perl : warning : setting local failed http://stackoverflow.com/questions/31990851/how-to-fix-perl-warning-setting-local-failed-on-raspberry-pi?...
3
votes
2answers
6k views

nginx 1.9.2 on raspbian

Installing nginx using "apt-get install nginx" seems to install 1.2.1, however examining the repository, it looks like both 1.6.2 and 1.9.2 are available: http://mirrordirector.raspbian.org/raspbian/...
0
votes
1answer
9k views

E: Sub-process /usr/bin/dpkg returned an error code (1)

Recently, I tried to install some software for raspbian. But after I type sudo apt-get install upgrade, I got this: debconf: Perl may be unconfigured (Can't locate strict.pm in @INC (@INC contains: /...
1
vote
2answers
5k views

Running “sudo dpkg --configure -a” fails

I set up RaspBMC on my Pi. I had a broken repo, so I SSH'd into it and ran sudo apt-get update and sudo apt-get upgrade to fix it. From that, I get E: dpkg was interrupted, you must manually run '...