Questions tagged [ds1307]

a low-power I2C serial real-time clock (RTC) with full binary-coded decimal (BCD) clock/calendar plus 56 bytes of non-volatile SRAM

Filter by
Sorted by
Tagged with
0 votes
0 answers

How to use two different RTC modules (ds1307/ds3231) on the same PI

The question is: How to use the same SD image when you don't know which RTC module will be connected on top of Raspberry PI? I have two modules in use in config.txt: dtparam=i2c_vc=on dtoverlay=i2c-...
Dmitry's user avatar
  • 101
1 vote
1 answer

Issue in RTC DS1307 delay when powering off Raspberry PI 4

I am interfacing a Raspberry PI4 with RTC DS1307 IC. The conditions that I checked are mentioned below: First install i2c-detect library in Pi4 and check whether my RTC interfaces properly or not ...
Dheeraj SmartIam's user avatar
0 votes
1 answer


I'm having a problem creating a DTB for a HAT auto-configuration. I have a DS3231 RTC module attached on I2C0 (GPIO0 and GPIO1). It incorporates an AT24C32 EEPROM at address 0x50. To get it working, ...
Bryan Horna's user avatar
-1 votes
1 answer

How to Use RTC Module (DS1302) to specifically Execute a Program at a Certain Time

I had already completed a Setup of DS1302 on my Raspberry Pi 3B+ and fortunately its working just fine. I also already solved the Problem of Turning On and Off the USB Port using "uhubctl". ...
Little Intoxicated's user avatar
0 votes
0 answers

i2cdetect detects the device but also shows a full row of addresses

I have successfully setup a RTC clock ( DS3231 ) on a RPi zero. The whole process was explained here. It works as expected but with only a minor difference: Row 5 is filled with numbers from 0x50 to ...
BHP's user avatar
  • 101
0 votes
1 answer

DS3231 doesn't update its internal time?

UPD: with another chip of the same model RTC works just fine, presumably that the chip was broken/damaged. I installed DS3231 RTC clock ( which is detected as DS1307 for some reason). My config.txt ...
jdevelop's user avatar
  • 113
-1 votes
1 answer

Raspberry pi ds1307 integration

I would like to integrate ds1307 clock module as a part of my 'garden automation project' to raspberry pi. The concept of the project is the servo will rotate in a specific time. So should I ...
Aboo Sidhu's user avatar
0 votes
2 answers

Why is my RTC DS3231 but seems DS1307?

I bought a RTC DS3231 because of the accuraty of time (2ppm, I was searching an accurate RTC). When I received it, I checked that in the encapsulating it is as well marked like DS3231. But, after ...
user940969's user avatar
0 votes
1 answer

RTC DS3231 could not be detected

HardwareSet up: Pi Model B, with Raspian Stretch. Boots up. Now try to install RTC Ds3231 module (with yellow capacitor at back) and plugged into the GPIO pins. Software: $ lsmod shows part of the ...
mark's user avatar
  • 121
0 votes
1 answer

rtc module in Raspbian Stretch

I'm following this guide to set up the rtc module in Raspbian Stretch. First question: after the changes described, the RPi doesn't sync anymore with the actual time from the Internet. Second ...
Mark's user avatar
  • 509
0 votes
2 answers

UPS PIco on Raspberry Pi B+ with Jessie

I have been using a PiModules UPS PIco add-on board on my Raspberry Pi B+ using Wheezy for over a year now. No problems. I just created a new boot SD with Jessie and while the PIco unit seems to be ...
RDK's user avatar
  • 201
-1 votes
3 answers

Cannot perform echo command to load driver for rtc module

I've come across a few tutorials for adding an rtc module to a pi. They all include a step in which you do echo ds1307 0x68 > /sys/class/i2c-adapter/i2c-1/new_device. When I try this, I get a bash: ...
cfye14's user avatar
  • 177
12 votes
3 answers

How to install Real Time Clock (RTC) on Raspbian?

I have: Raspberry Pi with 2015-05-05-raspbian-wheezy ds1307 attached (it's an Adafruit board, pullup resistors not installed). How do I: configure drivers make sure the Pi actually uses the RTC ...
greggo's user avatar
  • 621
18 votes
5 answers

i2cdetect shows every possible address

I was trying to turn on I2C following this tutorial But I have problem which I cannot solve. The command ...
wja's user avatar
  • 183
2 votes
0 answers

Why is my RTC DS1307 not being recognized?

I'm trying to wire up a DS1307 RTC to my Model B Pi. I'm following the diagram as shown in this crude image and I've also tried it like this but it isn't recognized by the Pi. When I run i2cdetect -...
DustinDavis's user avatar
2 votes
4 answers

Connecting RTC DS1037, Pin 5 already occupied

I think of adding a RTC Module to my Raspberry Pi. I found the following tutorial. In general it's ...
Christoph Daum's user avatar
1 vote
2 answers

How to connect DS1307 5V Real time clock (RTC) to 3.3V?

I have DS1307 small SMD parts so I can't simply leave out the resistors easily to make it work with 3.3V by default as with adafruit kit tutorial. How could I connect this device to my Raspberry Pi ...
DominicM's user avatar
  • 155
5 votes
4 answers

How can I automatically update the hwclock with NTP when I have internet connection

I'm using an RPi with Raspbian which runs the NTP-daemon by default. I have connected an rtc-ds1307 external i2c hardware clock. I was following the instructions given here to set it up: http://learn....
Thomas's user avatar
  • 81
1 vote
2 answers

Configuring to read RTC at boot time

I have added an RTC to the I2C bus of the Raspberry Pi. If I follow the steps mentioned here (I am using the DS1307 RTC IC), I can run hwclock and read the time. root@raspberrypi:~# modprobe rtc-...
Lord Loh.'s user avatar
  • 657