Questions tagged [eeprom]

This tag is for questions about using external EEPROMs with any model of Pi. For questions about the EEPROM on the Pi 4, use the 'pi4-eeprom' tag. For questions about the EEPROM on hats, use the 'hat' tag.

Filter by
Sorted by
Tagged with
0 votes
0 answers
15 views

EEPROM as alternative for FLASH STorage for Booting Pico 2040

I am reaching out to gain more insights on using EEPROM via SPI for booting the RP2040 Pico. Kindly guide with your experience of using or not using it, we have EEPROM in our inventory & would ...
Chubs's user avatar
  • 1
-1 votes
2 answers
297 views

Raspberry PI 4 Solid Red and Green light

I just set up my Raspberry Pi with the Pi Imager and everything was working fine, suddenly the power cord was unplugged and I had installed an application, after that now I get the solid red and green ...
Shahbaz Malik's user avatar
0 votes
0 answers
77 views

Connect Raspberry Pi Pico to 93C46 trought Microwire (3-wire Protocol)

i searched to know if someone did that before, but i didn't find anything, some C code to read and write using Arduino, but when i try to convert it i failed because i'm new at MicroPython and ...
Hitotam's user avatar
-3 votes
2 answers
283 views

How do I erase the RPI EEPROM and install one for a different OS that I coded myself?

I would like to completely erase the EEPROM and then shutdown the RaspBerry Pi 4 that I bought. When you then insert a USB-stick with your own bootloader, it should search for it and automatically ...
Emile Michel Hobo van Oranje's user avatar
1 vote
1 answer
165 views

New Pi 400 Won't Boot

I’ve received the Pi 400 yesterday and was unable to boot properly. These are the items I’m using to test the device. I have the official RPi HDMI to Micro HDMI cable The official RPi power adapter ...
Pascal Suissa's user avatar
0 votes
0 answers
33 views

Why my Raspberry pi 2 b v1.1 not booting?

My raspberry pi is not booting and the act led is strong bright green, (knowing that i have the official power supply and cable) I tried multiple and different sd card with different os and nothing ...
Islem's user avatar
  • 9
1 vote
0 answers
133 views

HAT EEPROM address is said to be 0x50, but 0xA0 is most common when A0-A2 are tied low [closed]

CAT24C32 is a widely recommended HAT EEPROM. The data sheet says the 4 MSBs are 1010 or Ah. But 0x50 is widely stated to be the correct EEPROM address. Some who recommend the CAT24C32 also say the ...
JSP's user avatar
  • 19
0 votes
1 answer
140 views

HAT EEPROM DTB and RTC on I2C0

I'm having a problem creating a DTB for a HAT auto-configuration. I have a DS3231 RTC module attached on I2C0 (GPIO0 and GPIO1). It incorporates an AT24C32 EEPROM at address 0x50. To get it working, ...
Bryan Horna's user avatar
0 votes
0 answers
214 views

Help with EEPROM log: RPI4 does not boot

This is another "RPI does not boot". I have tried many thins now and I'm not able to figure out why my RPI4 (that is quite valuable these days) does not boot. EEPROM is working fine and I ...
Miguel's user avatar
  • 233
1 vote
1 answer
1k views

How to connect EEPROM to Raspberry Pi 3? [closed]

I was wondering on how to connect an EEPROM chip to the Raspberry Pi 3? And any suggestions on which EEPROM chip model is best to use with RPi3?
Shawn Khoo's user avatar