Questions tagged [gcc]

The GCC (GNU Compiler Collection) is a set of compilers for various high-level languages. Use this tag for questions related to how to install and use the GCC.

10 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
2
votes
0answers
1k views

Which gcc compilation flags should use for RPi1 model B ? what is the ABI, architecture and CPU?

I want compile some binaries for RPi model B (revision 2.0) 512MB , I got installed arm-linux-gnueabi-gcc on Fedora 23 dnf copr enable lantw44/arm-linux-gnueabi-toolchain dnf install arm-linux-...
1
vote
0answers
70 views

How do I use the proper linux header extension folder

I am trying to build a TP-Link driver and when I run make I get... "******************************************" "NO SKRC,we will use default KSRC" "******************************************" make ...
1
vote
1answer
459 views

symbol lookup error: undefined symbol: _ZN7QWidget8qwsEventEP8QWSEvent

I have cross-compiled executable file from QT 4.8.7. I am running it on a Raspberry PI (Ubuntu), with QT 4.8.7 and QT declarative module installed. When i run the executable file on my raspberry pi, i ...
1
vote
0answers
143 views

Strange segfault after several hours of running program

I created a program fairly closely related to hello_pi/hello_video.c. And for some reason after several hours of running the program I get these very strange segfaults that I cannot for the life of me ...
1
vote
1answer
575 views

Adding gcc compiler to Poky image for raspberry Pi

I am using raspberry Pi 3 running a poky image built using the Yocto project. Is there any possible solution to add gcc compiler to the image? I found the cross-compilation very complicated and ...
1
vote
0answers
207 views

Cross Compile on maxOS fails linking System library (CMake), but other libraries succeed

tl;dr - CMake fails at linker not finding System library with precompiled RaspberryPi toolchain when other libraries work So I've been fighting this for a few days, and I believe I'm nearing the end ...
0
votes
0answers
24 views

Downgrade GCC version from 8 to 4.8 or 4.6 in Raspbian

I am using raspberry pi 3 and installed raspbian lite os. I need GCC version 4.8 or 4.6 for one of SDK. I was trying to downgrade the GCC but later everything got messed up. Again i have installed the ...
0
votes
1answer
244 views

Not able to compile the u-boot 2017.09

This is the OS info that I am using in my pi3 (BCM 2837) board. pi@raspberrypi:~ $ uname -a Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux [ am I using the ...
0
votes
3answers
890 views

GCC version for compiling a loadable kernel module

I am not very familiar with Linux, so may be my question is a little bit foolish. I would like to compile kernel module without recompiling the kernel (USB Wi-Fi stick driver for MT7106U chip). I ...
0
votes
1answer
200 views

NXP XTRINSIC-SENSE-BOARD using C

https://www.element14.com/community/thread/37836/l/reverse-engineered-sensorso-with-source https://github.com/larsch/rpi-mems-sensor Hello Everyone :) I have a raspberry V1 and a NXP senseboard, ...