Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [pip]

PIP is a tool for installing and managing Python packages. This topic covers issues installing packages from repositories with PIP.

0
votes
2answers
91 views

Rasp Pi, pip error setup.py egg_info

I am new to pi and I wanted to test it out on a python module for talking to building automation devices. Its called BAC0 From the documentation: https://bac0.readthedocs.io/en/latest/getstarted.html#...
1
vote
1answer
392 views

Error when installing Flexget

Having some problems trying to install flexget. I get the following error when I run the command: pi@rpi:~$ sudo pip install flexget Requirement already satisfied (use --upgrade to upgrade): ...
0
votes
1answer
1k views

I can't install anything with pip

Every package I try to install using pip, I get this error. I already updated the pip but even so doesn't work my pip version is 9.0.1 Exception: Traceback (most recent call last): File "/usr/...
0
votes
1answer
32 views

Direct all storage requirement to usb drive

I've mounted a usb drive. I'm attempting to exclusively use this drive for installations and execution of programs. If I pip install and execute programs from the same drive will no space will be ...
2
votes
0answers
508 views

Slow pip Raspberry PI 1

i have a issue with slow pip on Raspberry PI 1 on fresh install Raspbian Stretch. When i ran pip freeze it take a long time. pi@raspberrypi:~ $ time pip freeze > /dev/null real 0m43.337s user ...
1
vote
0answers
552 views

Cannot install pip3.5. Pip is configured with locations that require TSL/SSL?

I'm trying to install pip3.5 with python3.5 on raspbian on my raspberry pi, and I can not get it to work for the life of me. I have already installed python 3.5 without problems but I cannot seem to ...
1
vote
0answers
318 views

Change pip from 3.4 to 3.5

Recently, I have installed python3.5 on raspi, while I had 3.4 (by default). So now I have a problem with pip, because it is linked with 3.4 and not 3.5, so whenever I install package, it is done for ...
1
vote
0answers
398 views

Unable to install CEC in Virtualenv with Python 3.4

I am trying to install CEC pip install cec but I am unable to do so. I get the following error: (venv) pi@MyPi3:~/my_projects_pi $ pip install cec Collecting cec Using cached cec-0.2.5.tar.gz ...
1
vote
0answers
1k views

pip can not install pillow into virtualenv

I tried to install pillow inside a virtualenv under the interpreter: $VIRTUAL_ENV/bin/python3.4 I used the command: pip install pillow and got the following error: Traceback (most recent call ...
0
votes
0answers
24 views

install pymc3 on raspberry

I would like to install pymc3 on my raspberry pi 3 model b+ for my hobby project. But installing pymc3 by pip took forever and it was never able to finish installing. It there any other way to install ...
0
votes
0answers
315 views

.whl is not supported wheel on this platform Raspberrypi(B+)

I am trying to install webrtc for audio processing purpose on raspberrypi(B+). I am using pip 9.0.1 from python 2.7 When I write the following command: pip install ./webrtc*.whl I ...