Questions tagged [qt]

a cross-platform application framework for developing application software

Filter by
Sorted by
Tagged with
13 votes
2 answers

Qt applications don't work due to libEGL

I am developing some (simple) GUI applications for the RPi2 in Qt5. The setup: The code development is performed on a Windows laptop using Netbeans + Qt Designer and remotely built on the RPi running ...
Andrey Pro's user avatar
14 votes
5 answers

PyQt5 on a Raspberry Pi

I have a Raspberry Pi 3 with Raspbian installed, along with a 7" touch screen. I'm in the process of creating an application in Python to read several DS18B20 Thermocouples to monitor the temperature ...
CharlieHorse's user avatar
13 votes
1 answer

Turning 'tvservice' on and off leaves screen blank

I'm running the Qt5 application on my raspberry pi and I would like to introduce some kind of a power-saving feature. I don't use x11 or wayland, because I don't need it, but I use gles2 (OpenGL for ...
lewiatan's user avatar
  • 713
8 votes
2 answers

QtMultimedia on RaspBerry Pi

I've been trying to get QtMultimedia working on Raspberry Pi for a few weeks now, cross-compiling using the BakeQtPi script, yet the QtMultimedia plugin never seems to find an appropriate service to ...
Andreas Eriksson's user avatar
2 votes
1 answer

Failed to cross compile Qt 5.6 on RPi 2 (fatal error: bcm_host.h: No such file or directory)

I tried to cross compile Qt 5.6 for RPi 2 by following the tutorial RaspberryPi2EGLFS, but I got this error: qeglfsbrcmintegration.cpp:35:22: fatal error: bcm_host.h: No such file or directory #...
Hamed's user avatar
  • 21
1 vote
1 answer

Disable default bluetooth dialog box for accept pairing in raspberry pi3

I am developing a Bluetooth application using Qt5 on Raspberry Pi3. I have implemented my own Pairing agent which will automatically accept the pairing request from the remote device. The code is ...
Mahesh Mohandasan's user avatar
1 vote
0 answers

pi4 crashes when running any QT apps like RPi imager, VLC, OBS

when opening for example VLC in stock rpiOS the window that asks for metadata network access opens, but its so large that the text in the menu bar takes almost all of my screen and after some time my ...
Itai Nelken's user avatar
0 votes
1 answer

QtPy5 on Raspbian, getting ImportError: cannot import name QtCore

I need to be able to use the latest WebKit that includes WebRTC support How do I install Qt5+QtPy5 on Raspbian? What I have tried so far... Installed Qt5 on RPi2 - PASS Native build Qt5 on RPi2 ...
zabumba's user avatar
  • 257