Skip to main content

Questions tagged [qt]

a cross-platform application framework for developing application software

56 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3 votes
0 answers
645 views

QML without X11

Is it possible to run QML files without X_Desktop environment in raspbian Jessie for Raspberry Pi3? I found this tutorial: EGLFS , but I would prefer if it is possible to compile directly on RPi, ...
Shiro's user avatar
  • 41
2 votes
0 answers
27 views

Waveshare (goodix) touchscreen not working in PyQT eglfs (non-X11) application

I have a Waveshare 4" DSI round touch display, I am using Raspberry Pi OS bookworm to drive this display on a Raspberry Pi 4 Model B. I have the following line added to my /boot/firmware/config....
Christi's user avatar
  • 230
2 votes
1 answer
67 views

magnetic field generated by the engine alternator affects gpio value

I am working on a dashboard for a motorcycle. I created a Qt application on my raspberry pi 4 on a raspberry pi os lite. I have configured one of my GPIO as interrupt using the wiringPi library. ...
mina's user avatar
  • 375
2 votes
0 answers
310 views

OpenCV cross-compilation fails

I have cross-compiled Qt on my CentOS host for my Raspberry Pi and now I want to cross-compile OpenCV with the following script: CORES=4 IP=192.168.178.52 TEMP_PATH=/home/kampi/OpenCV SYSROOT_PATH=/...
Kampi's user avatar
  • 203
2 votes
0 answers
2k views

Why GLX or EGL is not enabled when running QT program?

To start with I have to say I was trying to make cross-compilation work for Ubuntu with Raspberry Pi 3+ B. I used this tutorial https://wiki.qt.io/RaspberryPi2EGLFS and QT in version 5.12.4. Tried it ...
WakeCaine's user avatar
2 votes
1 answer
63 views

Compile Qt application on Raspberry Pi and Run that application on other ARM device. Will it work?

I am compiling One Qt application on Raspberry Pi and Run it on different ARM device like Microchip or TI board without compile again. will it work??? if both the side Qt version is same.
Mehta's user avatar
  • 31
2 votes
0 answers
706 views

Qt cross compilation *QOpenGLShaderProgram: could not create shader program* error

I am using the QT Creator for my laptop (Linux LMDE 3 Cindy OS) And for Raspberry Zero Cross-compiling. I have installed the QT based of this instruction and by this setting: mkdir ~/raspi ...
Soheil Paper's user avatar
2 votes
0 answers
1k views

Latest Qt5 does not provide EGLFS during cross-compilation

Some time ago I set up a Linux host to cross-compile Qt5. I used this configure command: ./configure -release -opengl es2 -device linux-rasp-pi3-g++ -device-option CROSS_COMPILE=~/opt/tools/arm-...
Mark's user avatar
  • 523
2 votes
0 answers
2k views

Live Camera App with Qt

I am trying to write an application using Qt that displays live video from the Pi camera. The Qt example projects "camera" (using QWidgets) and "declarative-camera" (using QML) both run without ...
BrettAustin's user avatar
2 votes
1 answer
1k views

Unable to drag and drop widgets in Qt Designer

I got a Qt 4 installation using sudo apt-get install qtcreator. I am able to get everything to compile using gcc 4.8. However, when it comes to using Qt Designer to edit the UI of a window, Qt ...
Towerism's user avatar
2 votes
1 answer
149 views

Does a binary built on pi 3 will work on pi 2?

I'm building an app on a raspberry pi 3. I'm using Qt. Will the generated binary work on raspberry pi 2? Thanks
Julien's user avatar
  • 131
1 vote
0 answers
51 views

Process/Flow/steps for speeding of the booting time in raspberry pi for the cluster

I am using Raspberry pi for the cluster, that would display the basic data like the CAN data and one wire data. For can I used the Can-Socket and for one wire I am just reading a gpio pin of raspberry ...
John Mist's user avatar
1 vote
0 answers
244 views

Example of libcamera with Qt6 in c++?

I'm trying to build a Qt app on my RPi4 using libCamera in c++, but I keep having build/compile issues. Are there any examples of using libCamera in a Qt app in c++? I'm using Raspbian bullseye, and ...
robotanical's user avatar
1 vote
1 answer
886 views

Download QT 5.12.0 on my Raspberry fails

I currently have the 5.11.3 Qt Version on my Raspberry 3 B+. For another program, I want to use I need at least Qt 5.12.0. When I try sudo apt-get install qt5-default it says that I already ...
PatriciaAM's user avatar
1 vote
0 answers
328 views

QT Creator - Raspberry Pi - 3.5" TFT - Could not initialize egl display

Please forgive my ignorance but I'm new to Raspberry Pi/Linux. I'm trying to make a touch screen app for the Pi using a 3.5" touch screen (xpt2046) and QT Creator (5.12.5). QT Creator is running ...
Glyn Davidson's user avatar
1 vote
0 answers
204 views

pi4 crashes when running any QT apps like RPi imager, VLC, OBS

when opening for example VLC in stock rpiOS the window that asks for metadata network access opens, but its so large that the text in the menu bar takes almost all of my screen and after some time my ...
Itai Nelken's user avatar
1 vote
0 answers
48 views

Horizontal lines on qt 5.13 app . Problem doesn't present with virtual screen (chvt) manipulation

I have a full-screen app in kiosk mode that runs on qt 5.13.2 (Qt compiled from source). Up until 1 week ago, it displayed just fine. Then, I did an apt dist-upgrade and I now get horizontal lines ...
Ross Rogers's user avatar
1 vote
0 answers
250 views

Cross-compiling QT interface to a Raspberry PI 3

I'm trying to install Qt interface to a Raspberry Pi 3, which raspbian is the "2016-05-27-raspbian-jessie". I didn't want to install, directly, all the packages on the raspberry so as to let ...
Nour's user avatar
  • 19
1 vote
0 answers
721 views

RaspberryPi2EGLFS guide - EGL/GLES libraries fix fail

I built Qt 5.12.3 for Raspberry Pi following the RaspberryPi2EGLFS guide from Qt Wiki. I was able to reproduce almost each one of the steps described in the guide, but on step 14 (EGL/GLES libraries ...
rrd's user avatar
  • 111
1 vote
0 answers
220 views

Raspberry Pi Qt toolchain on Ubuntu 16.04

I have issues creating a tool-chain for cross compiling Raspberry Pi 3 Qt applications through Ubuntu. I used directions from this guide, https://wiki.qt.io/Raspberry_Pi_Beginners_Guide, to help me ...
P. Kesh's user avatar
  • 11
1 vote
1 answer
3k views

(Error trying to run qjackctl) libEGL warning: DRI2: failed to authenticate qt5ct: using qt5ct plugin

Running Raspbian installed with NOOBS. qjackctl is installed with all its dependencies using Synaptic. Just trying to run Guitarix on my Pi3 B+. I tried following the instructions in this solution, ...
josh's user avatar
  • 11
1 vote
1 answer
2k views

QCamera get error "mesa-loader failed to retrieve device information"

Qt test code: QCamera* camera = new QCamera; auto viewfinder = new QCameraViewfinder(); camera->setViewfinder(viewfinder); viewfinder->show(); camera->start(); Output: mesa-loader failed ...
JustWe's user avatar
  • 145
1 vote
0 answers
767 views

Qt5.10.1 Cross-Compiled to Raspberry Pi Zero W uses EGLFS instead of XCB

I have been trying to create a GUI application using Qt5 on Raspbian Stretch, but the application doesn't launch correctly unless I specifically tell it to run as XCB. This is fine, as I don't need it ...
Bast's user avatar
  • 11
1 vote
0 answers
1k views

PyQt support for WebEngine on raspberry Pi 3 raspbian-stretch

I have installed PyQt5 for Python3. However while I can import various modules into Python I am finding that none of the WebEngine modules import (WebEngine, WebEngineWidgets, WebEngineCore). They ...
Lee Melbourne's user avatar
1 vote
0 answers
949 views

Problems with PyQt5

Quoting: I developed a similar application using PyQt4 and Qt4-designer. You have to install pyqt4 all modules: sudo apt-get install qt4-default qt4-designer qt4-doc qt4-dev-tools python-...
user3711457's user avatar
1 vote
0 answers
296 views

SUID executable doesn't work for `/dev/mem` access

Here is explained how to gain access to the peripheral without being root. I've just tried in my environment (Raspbian Stretch, RPi2, Qt5.9) in this way: int main(int argc, char *argv[]) { ...
Mark's user avatar
  • 523
1 vote
0 answers
93 views

How to use RF24Mesh on Raspbian in Qt

I want to use the RF24Mesh library in my QT application in Raspbian Jessie. I can compile the example and run it (with the make command) but when I include libs to my QT app, it gives the error: ...
fireghostea's user avatar
1 vote
0 answers
250 views

Cross compiling QT and example program does not find platform

I followed the follwoing guide to cross-compile QT 5.6 on a Ubuntu 16.04 machine for the raspberrypi2 running jessie: https://wiki.qt.io/RaspberryPi2EGLFS#A_modern_guide_for_cross-compiling_Qt_5....
numberCruncher's user avatar
1 vote
0 answers
1k views

Deploy Qt 5.6 onto rPi2 with Jessie

I am working on a Qt project for my pi and I have successfully managed to follow this guide to set up a tool chain from Ubuntu to the Rpi: https://wiki.qt.io/RaspberryPi2EGLFS However, now I am ...
Tom Mclaughlin's user avatar
1 vote
0 answers
2k views

defaultServiceProvider::requestService()

We've run into a problem while to trying to use QCamera and QMediaPlayer. In fact, we need to use a Webcam feedback & a music player (only .mp3). We already installed: gstreamer1.0 qt5-default ...
Thyxx's user avatar
  • 11
1 vote
0 answers
331 views

Run GUI application using sudo from a tightvncviewer

I am trying to run Qtcreator with administrator in my remote raspberry Pi board using tightvncviewer from my windows laptop. I can run Qtcreator and debug my code without using sudo. But I want to ...
Arun Kumar K S's user avatar
1 vote
0 answers
986 views

Syntax error: word unexpected (expecting ")") ERROR when run : python configure.py

I followed this link to install PyQt5 on Raspbian. First I cross compiled Qt5 (this link) for Raspberry and executed an example. It worked fine. When executing this command: python configure.py --...
Mostafa Farzane's user avatar
1 vote
0 answers
495 views

Raspberry Pi + Qt4 + Opencv cross compile from windows

Hi I want to know how to use opencv in raspberry pi. I have cross compiled qt raspberry from windows and succeed but I cannot add library opencv.
You Natan's user avatar
1 vote
0 answers
3k views

cross compile qt 5.2

I'm following this tutorial to cross compile qt 5.2. But I'm getting this error: You have already accepted the terms of the license. /home/vitor/src/rpi/tools/arm-bcm2708/gcc-linaro-arm-linux-...
Vitor Carvalho's user avatar
0 votes
0 answers
42 views

Raspberry Pi 4 with the QT5.15 program running, the resistive touch screen does not respond to pressing

I have Qt5.15 embedded with Linux Raspberry Pi 4. My touchscreen does not respond to pressing. More details: display ids-3210r-40sva1e. ver. Linux pi 5.10.103-v7l+ #1529 SMP Tue Mar 8 12:24:00 GMT ...
Aleksey's user avatar
0 votes
1 answer
66 views

compiler linking error GPIO libraries no longer initialising

I am working on a private project and have run into a linking error described below: undefined reference to `gpioSetMode' collect2: error: ld returned 1 exit status I am using g++ and the terminal to ...
winterx0's user avatar
0 votes
0 answers
102 views

Cross-Compiling Qt6 for Zero 2 W?

I am trying to build a cross compiling setup for the following system configuration: Qt6.5 LTS Running Raspberry Pi OS Lite 64-bit based on Bookworm Host: Ubuntu 22.04.3 LTS on WSL There aren't many ...
Vishesh Varma's user avatar
0 votes
0 answers
51 views

Dual Monitor on Raspberry Pi4 running Ubuntu 23.1 and KDE Plasma

I have a Pi4 which refuses to display two monitors using Ubuntu 23.10 and KDE Plasma The same Pi shows the 2 monitors using Ubuntu Mate Desktop. I am switching to KDE because I want to use PyQt5 not ...
themetman's user avatar
0 votes
1 answer
46 views

PyQt5 Widget Background Color Incorrect on my Pi

I have searched high and low for this problem, but cannot find anything anywhere. I have Python Version 3.8.10 and PyQt5 version 5.15.10 running in a Virtual Environment on my Py4 with 8Gb Memory ...
themetman's user avatar
0 votes
1 answer
219 views

Qt6 compiler binary package

I'm aware I can cross-compile Qt6 on my dev machine or I can build the Qt6 from sources directly on the Rapsberry Pi. But is there any binary package for the compiler? Like when you use the online ...
Mark's user avatar
  • 523
0 votes
0 answers
149 views

PyQt QSoundEffect not working on Pi 4B

I am having a perplexing difficulty, in that I cannot get my PyQt program to produce any sound. I am able to get sound correctly from the Pi over HDMI using speaker-test and paplay, so I am happy ...
Christi's user avatar
  • 230
0 votes
0 answers
333 views

can we send data or files via wifi from a Raspberry PI using a QT graphical interface to another pc under Windows?

so my Raspberry card is connected to a screen by HDMI, I want to develop an interface using the QT platform under linux to give the order to my Rpi card to send data or files and even to receive ...
kail's user avatar
  • 1
0 votes
1 answer
553 views

Running python GUI application with PyQt and python-vlc as a service

I'm trying to run a python GUI application as a service. The application is using PyQt5 and python-vlc packages. I have the following service file: [Unit] Description="Python VLC Service Test&...
Kwigon's user avatar
  • 1
0 votes
0 answers
329 views

Run QT5 app (chiaki remote play) on raspberry OS lite

I would like to run Chiaki (Playstation Remote Play https://github.com/Fredrum/chiaki) on my raspberrypi zero WH running raspberrypiOS lite (so no GUI). running chiaki itself on a raspberry pi(zero ...
Paolo Squadrito's user avatar
0 votes
0 answers
5k views

Could not initialize egl display

I have a CentOS host which should be used to develop Qt applications (version 5.12.8) for a Raspberry Pi. I use the following Raspberry Pi setup: $ cat /proc/cpuinfo ... model name : ARMv7 ...
Kampi's user avatar
  • 203
0 votes
0 answers
743 views

Raspberry pi - QT webenginewidgets problem

I use raspberry pi and QT (version 5.7.1). When I use QT += webenginewidgets , I get an error Project ERROR: Unknown module(s) in QT: webenginewidgets however I try to install -sudo apt-get install ...
şevket Karayılan's user avatar
0 votes
0 answers
70 views

MFRC522 and Bluetooth not work together

I have a program in which I use pyqt5, MFRC522 and bluetooth. I have 3 threads, one for the interface, one for the MFRC522 and one for the bluetooth. If I run the MFRC522 and the bluetooth separately ...
israel's user avatar
  • 1
0 votes
0 answers
32 views

The application stalls when the service is loaded at startup

I have RPI3B + with Raspian Stretch on which I run the QT application. When I create my service to launch the application after starting the rpi i have problems.. The application starts and then the ...
Sqwerize's user avatar
0 votes
0 answers
233 views

Can't install development files for QT on RPi Zero W

I've been following this tutorial trying to get working QT cross-compilation from my PC to a Raspberry Pi Zero W. It is failing on Step 5 ("Install a bunch of development files"). Running sudo apt-...
nbura's user avatar
  • 101
0 votes
0 answers
1k views

Malfunction with Qt5 and touch screen on RPi3

I develop a Q5 embedded application on RPi3 and I'm having trouble with the touchscreen. My problem: The touch area is stretched. In the picture below, the touch area of the buttons at the corners ...
dakridas's user avatar