Questions tagged [software-installation]

Questions regarding issues installing specific applications or operating systems on the Raspberry Pi.

70 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
4
votes
1answer
36 views

Installing Etcher and Octopi: Unable to to Unzip and Install either of these programs?

So I have received my Raspberry Pi 3 B+ in the mail. Plug it in and hook it up. Everything works awesome up until this point...I would like to mention that I have been a Windows user my whole entire ...
4
votes
1answer
225 views

BTSync update: 2.0.93 => latest

Years ago I installed BTSync from debian.yeasoft.net repo. My /etc/apt/sources.list.d/btsync.list: deb http://debian.yeasoft.net/btsync wheezy main contrib non-free deb-src http://debian.yeasoft.net/...
2
votes
1answer
2k views

Installing RStudio on a Raspberry Pi running Ubuntu MATE 16.04

I am planning to do a classroom project using R and RStudio IDE. I am able to run R from command line. I installed the package using the command below sudo apt-get install r-base Now I am trying to ...
2
votes
0answers
965 views

Unable to install Firefox or Thunderbird (Icedove)

I have been trying to install Firefox and Thunderbird on Raspbian Stretch, but I have not been able to. Edit: This issue seems to have been resolved for now. For some reason the sudo apt-get update ...
2
votes
0answers
878 views

how to install netctl on lastest raspbian pi2

I have install lasted raspbian on my raspberry pi2. Unfortunally, it seem that netctl isn't installed, so I did: sudo apt-get update sudo apt-get install netctl Reading package lists... Done ...
1
vote
0answers
38 views

Freecad not working on my raspbian!

I just installed free cad on raspbian from repo . Then after the installation was complete when I preseed the freecad icon from menu it is opening. But when I am pressing new project the software is ...
1
vote
1answer
63 views

How to install previous/older version of octave in buster?

Currently Octave version 4.4.1 is available. It always crashes while start. I am trying to install an older version of octave but I can not find any older packages in the repo and the sources are ...
1
vote
0answers
73 views

Error #35584 when trying to run Minetest with flatpak

I'm trying to install minetest on my Raspberry Pi B+ by running flatpak install net.minetest.Minetest I got it installed but after rebooting my pi it doesn't show up anywhere and trying to open it ...
1
vote
0answers
59 views

Installing Raspbian on mdadm raid

I'm looking to make a serious Raspberry Pi installation, and a micro sd card is not enough performance or redundancy for me. So I'm trying to figure out how to install Raspbian on a mdadm raid5 array ...
1
vote
1answer
108 views

Installing Raspbian without recommended Software from NOOBS

Is it possible to install Raspbian (without the Recommended software) from NOOBS? Last time I chose Raspbian from NOOBS installation menu it also included the recommended software (Mathematica, ...
1
vote
0answers
124 views

I can't install System.Device.Gpio on RPi

I try to use .NET Core for Raspberry Pi 3 and want to install IoT libraries by using the instructions here I want to do development on my Mac and then copy files to the RPi so I created a console ...
1
vote
0answers
146 views

How to install Couchbase onto a Raspberry Pi 3

I am making a discord bot, and I want to use Couchbase as my Database option. (So I can get some practise on it, since work is switching to it) However, Couchbase does not officially target the ARM ...
1
vote
1answer
415 views

Can't Install Packages with apt-get | no installation candidate

I'm using Raspbian Stretch with Desktop(v4.14.62-v7) and I can't seem to be able to install packages on my rPi. For instance, when I type sudo apt-get install autoconf, I get: Reading package lists.....
1
vote
0answers
159 views

raspberry pi model b+ Not booting

I recently bought a raspberry pi 3 b+ from amazon and when I got it delivered the package was already opened, so I just want to check if my raspberry is working or not so I formatted a compatible sd ...
1
vote
0answers
440 views

Unable to get Pi to boot with Kali

I'm trying to flash an SD card with Kali Linux to run on my Pi. I've followed the instructions found here: https://docs.kali.org/downloading/kali-linux-live-usb-install and the image I downloaded came ...
1
vote
0answers
187 views

HOW TO FIX: “The valid stable is invalid for APT::Default-Release as such a release is not available in the sources”

So as I'm working on a project I type in "sudo apt-get install feh" but after I pressed enter it gave me a "The valid stable isinvalid for APT::Default-Release as such a release is not available in ...
1
vote
2answers
1k views

Formatting SDXC Card - Format Size Adjustment option doesn't exist?

So I'm trying to format my 64 GB SD card, using the instructions on the Raspberry Pi website (for Windows). They say to run the SD Formatter with Format Size Adjustment set to ON. But in the SD ...
1
vote
0answers
236 views

phpmyadmin installation issue

I am having trouble installing phpmyadmin on the raspberry pi zero. The raspberry pi is connected to a Windows 10 laptop with SSH using putty and the internet connection is bridge from my laptop. At ...
1
vote
0answers
370 views

Unable to install the driver for “AVerTV Volar HD Nano - A867R” (a DVB-T dongle)

I downloaded the driver (for linux) from the AVerMedia site, unpacked it into an xyz directory, and from that directory I gave the command make. I got the following output Missing files that required ...
1
vote
0answers
489 views

Replacing `jessie` with `stable` in raspbian `sources.list`?

in debian etc/apt/sources.list it is possible to replace the name of the current distribution with the status of a given distribution. For example, if one plans to use always the stable release can ...
1
vote
0answers
36 views

Setting Raspberry Pi up for more than one usage

I am new to Raspberry pi and super excited to start using it. My first raspberry pi project is going to essentially be a entertainment system connected to the tv at all times. First, I will be ...
1
vote
1answer
252 views

Can't install rails3 - unmet dependencies

I just got a Raspberry Pi 3 (I already have a fair amount of UNIX experience) and installed Raspbian. I'm trying to install Rails 3 with apt-get. When I try, I get a message about unmet dependencies. ...
1
vote
0answers
375 views

Emacs Not Properly installing on Raspberry Pi B+

When I type: sudo apt-get install emacs It gives me multiple errors, such as: Err http://mirrordirector.raspbian.org/raspbian/ jessie/main imagemagick-common all 8:6.8.9.9-5+deb8u2 404 Not Found [...
1
vote
0answers
3k views

Install Webmin on my Raspberry Pi 3 B Stops

I've have tried several times to install Webmin on my Raspberry Pi 3 B with no luck. I have expanded the OS to the 32gb micro SD Card, and even changed the SD Card twice. It will download everything ...
1
vote
0answers
239 views

luakit browser installation fail

I am trying to install Luakit browser on Raspberry Pi on Rasbian 7 (Wheezy). However when I execute sudo apt-get install luakit I get following output from console: pi@raspberrypi ~ $ sudo apt-get ...
1
vote
0answers
708 views

Touchscreen - configuration issue?

Good day! I have a rpi B+ with 3,2" display (fb_ili9340) and XPT2046 touch controller. Previously 3.18.10, now 4.0.7 kernel. Display works perfectly as with waveshare32b module, but no touchscreen ...
1
vote
0answers
765 views

Syntax error: word unexpected (expecting “)”) ERROR when run : python configure.py

I followed this link to install PyQt5 on Raspbian. First I cross compiled Qt5 (this link) for Raspberry and executed an example. It worked fine. When executing this command: python configure.py --...
1
vote
0answers
443 views

controlling 12 V RGB LED strip with raspberry pi

We are trying to control a RGB led strip with a 12 V power supply. The servoblaster does not work. Can you please suggest some other software we can use?
1
vote
0answers
284 views

Unable to install the required packages for developing Maynard desktop

I am attempting to install the new Maynard desktop, just to give it a try. I added the # Source packages for Maynard. deb-src http://raspberrypi.collabora.com wheezy wayland lines to /etc/apt/...
1
vote
0answers
1k views

Why I can't compile and install cgminer on my RaspBerry?

I am trying to install Cgminer on my RaspBerry (it use RaspBian that is a Debian minimalistic version) as explained here: https://bitcointalk.org/index.php?topic=494625.0 In particular the ...
1
vote
0answers
960 views

how to install cx_oracle python db driver?

I need to install cx_oracle on my pi but I couldn't find arm-specific version or sources. Any ideas how to do it?
0
votes
0answers
6 views

Error E405 while trying to install discord.js with npm

I'm trying to host a Discord bot in my RPI3B+, but the required node.js package discord.js always fails to install. I've tried purging both NPM and Node.js, and i have upgraded my Raspbian using sudo ...
0
votes
0answers
74 views

Can't install Docker on Raspberry Pi - NextCloudPi Image

I'm trying to install Docker on my Raspberry Pi 4B running the NextCloudPi Image from own your bits. When I run curl -sSL https://get.docker.com | sh I get the following Error: root@nextcloudpi:~# ...
0
votes
1answer
78 views

Rocket Chat Installation HTTPS with Caddy error

I followed the installation instructions listed for the Raspberry Pi version of Rocket Chat on Github. The software installs properly. However, I am having an issue enabling HTTPS using caddy. The ...
0
votes
1answer
42 views

How do I download shellter for Raspbian?

So my question is: How do you download shellter for Raspbian as sudo apt-get install shellter does not work. it says package not found. Or does shellter not exist for the Raspbian I have found ...
0
votes
0answers
39 views

Berryboot stuck at “formatting data partition”

I have a raspberry Pi 3 and I'm trying to install the berryboot onto my wd purple 1tb HDD. It's now at the "formatting data partition" screen for about 2 hours. Is this much time generally required. ...
0
votes
1answer
35 views

How to Install Fedora/Pidora and Ubuntu Mate on Raspberry Pi?

I have a Raspberry Pi 3b+ and a Windows Laptop, through which I have downloaded Pidora and made a bootable SD Card with Etcher Software. When I try to boot my Pi using this SD card it is not doing ...
0
votes
0answers
54 views

Cant upgrade Raspbian neither run Python

I am trying to upgrade my Raspberry Pi 3 B+: $ uname -a Linux plexmediaserver-pi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux But I am getting this weird error: pi@...
0
votes
0answers
72 views

Error installing dotNet4.0 on Wine

sorry if the solution is obvious but this is my first time working with Linux. Backstory (just the reason why I do this): I have to code a Programm for school which has to run on a Raspberry Pi and I ...
0
votes
1answer
56 views

ReSpeaker 2mic drivers can't be installed on Pi 3b

I’m trying to set up a ReSpeaker 2mic Pi HAT. Emphasis on trying. According to the instructions, i’m supposed to do this: sudo apt-get update sudo apt-get upgrade git clone https://github.com/...
0
votes
0answers
131 views

Help installing Zoiper on Raspbian or a .deb/.run file

Can anyone help me instal zoiper (voip) on my raspberry pi 3B+ (Raspbian OS). I’m having great difficulties and would appreciate any assistance.
0
votes
0answers
31 views

install pymc3 on raspberry

I would like to install pymc3 on my raspberry pi 3 model b+ for my hobby project. But installing pymc3 by pip took forever and it was never able to finish installing. It there any other way to install ...
0
votes
0answers
359 views

How to install Android on Raspberry Pi 2B?

I have tried following, but failed at some stage Emteria OS : knowing that this OS is for Raspberry Pi 3 model, anyway I tried to install it for experiment. Screen froze at Kernel Starting KitKat for ...
0
votes
0answers
281 views

Getting error: `/usr/bin/veracrypt: No such file or directory` after installing veracrypt

I am trying to install the armv7 version of Veracrypt on my Raspberry Pi. I downloaded it from: https://launchpad.net/veracrypt/trunk/1.21/+download/veracrypt-1.21-raspbian-setup.tar.bz2, unzipped and ...
0
votes
1answer
50 views

Synergy closing immediately

So I'm running raspbian stretch on a raspberry pi 3 and just installed synergy to run as the client. (installed via terminal "sudo apt-get install synergy") It was working yesterday, but now, when I ...
0
votes
0answers
12 views

Getting Japanese fonts (hiragana & katakana) and entering text into LibreOffice (NB Not changing entire system language to Japanese) Qu Pt 2

Following Goldilocks guidance, I seem to have a series of fonts installed but can find nothing to say/show how they might be 'activated' and input swapped between English letters and Japanese ...
0
votes
0answers
54 views

SD card in read-only after NOOBS installation

I was booting for the first time a Raspberry Pi with NOOBs, the installation was doing fine until it got stuck for more than 20 min. After a quick read on the internet it was apparently fine to power-...
0
votes
1answer
288 views

error trying to set up RFIDIOT on raspberry

I am new to raspberry and python in general. I followed different guides to set up RFIDIOT (even the documentation and the installation guide on the repository on Github). So far, when I run pcsc_scan ...
0
votes
0answers
48 views

Rpi -3 fail to run `esptool`

In order to communicate with ESP32 to run miropython code, I needed to install esptool on my RPI ( done successfully )- using this guide . When executing, I got an error message that it doesnot exit- ...
0
votes
0answers
103 views

Install Arduino IDE in Raspian Strech Desktop

I'm using a Raspian Stretch in Virtual Machine (VMWare). I follow the steps to install Arduino IDE in Linux ARM version. The software are installed OK, but when i click to open IDE, nothing happens. ...