Questions tagged [software-installation]

Questions regarding issues installing specific applications or operating systems on the Raspberry Pi.

Filter by
Sorted by
Tagged with
0
votes
2answers
2k views

Formatting SDXC Card - Format Size Adjustment option doesn't exist?

So I'm trying to format my 64 GB SD card, using the instructions on the Raspberry Pi website (for Windows). They say to run the SD Formatter with Format Size Adjustment set to ON. But in the SD ...
0
votes
3answers
2k views

apt-get error while installing software

I was able to update packages using $ sudo apt-get update but when I tried to install telnet using $ sudo apt-get install telnet, I get the following errors dpkg: unrecoverable fatal error , ...
0
votes
0answers
8 views

Getting error when running node -v

I have been trying to install node.js for the last one hour. After reinstalling and removing nodejs numerous times, every time I run node -v I get the following error: node: /usr/lib/arm-linux-...
3
votes
1answer
3k views

How to restart setup wizard at first time startup?

I started up my raspberry pi, and accidentally pressed escape during new password creation. The startup wizard exited, and now I cant get back to the startup wizard. How do I restart the startup ...
0
votes
0answers
17 views

Teamspeak3 on Raspberry pi4b

i installed a x86 emulator, Quemu and TS3 on my Raspberry pi 4b. The installation works, but if i want to start TS3 an error ocurred. Here is my log. root@raspberrypi:~/teamspeak3-server_linux_x86# ./...
1
vote
1answer
151 views

opencv installation

`I tried installing opencv on my raspi 3B using pip, on trying to import cv2 i am getting an error Edit: code lines: Successfully installed opencv-python-4.1.1.26 `(cv) pi@raspberrypi:~ $ workon cv ...
0
votes
1answer
176 views
0
votes
1answer
250 views

Installing Raspbian without recommended Software from NOOBS

Is it possible to install Raspbian (without the Recommended software) from NOOBS? Last time I chose Raspbian from NOOBS installation menu it also included the recommended software (Mathematica, ...
2
votes
1answer
764 views

Failed to start Load Kernel Modules for installing Ubuntu 18.04 on Raspberry 4

I tried to install Ubuntu 18.04 on Pi4. I followed the link from ubuntu for pi. After inserting the SD card with Ubuntu image, the error appeared after few lines with [FAILED] Failed to start Load ...
3
votes
0answers
195 views

Docker Alpine:latest image fails to get date so everything fails

I just got a Raspberry pi 4 with 8GB and a SD. I ran all the updates and went directly to install docker and discovered that many images were randomly failing. I narrowed it down to the alpine:latest ...
0
votes
0answers
31 views

Update means Respeaker Seeed Soundcard will no longer install. What can I do?

I've been using the Respeaker 6 Mic array and Seeed-Soundcard for months and was just about to start a field deployment with them however I reflashed my SD cards and tried to reinstall the soundcard ...
0
votes
2answers
74 views

Is it possible to do a new Buster/OpenHAB 2.5 install on 4 GB Pi 4b with SSD?

I'm building a new Pi 4b system using the downloaded image of OpenHAB 2.5.3 for a Raspberry Pi on a 64 GB MicroSD card. I'm also going to be using a ridiculously large 500 GB SSD. What I would like to ...
0
votes
4answers
7k views

cannot install python-dev

I have tried to do a sudo apt-get install python-dev however I get this, Reading package lists... Done Building dependency tree Reading state information... Done Package python-dev is not available, ...
0
votes
1answer
140 views

Install pinout command in Rpi 1B

After install RaspiOS lite (2021-01-11-raspios-buster-armhf-lite) in a Rpi 1B model, I get command not found from pinout command. I found this guide to get pinout command in a Rpi zero: sudo apt ...
1
vote
2answers
180 views

Good KDE distros for RP4?

I’m looking to work with a KDE distro on my RP4. I’m most familiar with the Ubuntu family but it doesn’t seem Kubuntu has an ARM image. Fedora has a KDE spin but not sure I want to go that route just ...
0
votes
1answer
108 views

Install problem: “Can't compile with this kernel, aborting”. dkms (bad exit status: 2)

I've been trying to run an install script on my raspberry pi 4, and I keep getting the same error. The script is meant to install a soundcard for a multiple microphone adaptor on the pi, I've got it ...
0
votes
1answer
145 views

ReSpeaker 2mic drivers can't be installed on Pi 3b

I’m trying to set up a ReSpeaker 2mic Pi HAT. Emphasis on trying. According to the instructions, i’m supposed to do this: sudo apt-get update sudo apt-get upgrade git clone https://github.com/...
0
votes
2answers
38 views

Does terminating ssh connection, terminates the installation process too?

I’m running a raspberry pi 3b headless, thus I ssh into rpi from Mac terminal through Ethernet cable ip. I’m currently installing opencv but the terminal kinda not giving any response. If I close the ...
0
votes
3answers
175 views

Install melonDS on a raspberry pi

I'm looking to install a great DS emulator on a raspberry pi4. It's called MelonDS and it is available for Linux. I attempted to install on the 64bit ubuntu image. This is what I tried. sudo snap ...
0
votes
2answers
482 views

Is apt upgrade ; apt update for a fresh raspian buster lite install a default during a 1st boot?

I'm installing 2020-08-20-raspios-buster-armhf-lite. I normally do this headless, but I happen to have a monitor this time. It's spending a LOT of time on what appears to be an update/upgrade. Here'...
2
votes
1answer
3k views

Atom text editor on raspberry pi 4?

I'm looking to install Atom on my Raspberry pi 4. In ARMHF naturally. I have already tried a lot of solution, but nothing works. I tried the atom-arhmf.deb from the official github repository and ...
1
vote
1answer
72 views

Cannot apt-get install, can't authenticate package [closed]

I'm at my wit's end trying to figure this out all night... searched google, stack, ubuntu, and raspberrypi forum a whole bunch, but just can't fix it. What I'm really trying to do is sudo apt-get ...
0
votes
1answer
109 views

How do I download shellter for Raspbian?

So my question is: How do you download shellter for Raspbian as sudo apt-get install shellter does not work. it says package not found. Or does shellter not exist for the Raspbian I have found ...
-2
votes
1answer
21 views

flask_ask won't import after proper installation

I'm trying to use the flask_ask library however I for some reason can't get it to work. Whenever I try to reinstall flask-ask by doing pip install flask-ask I am given the same thing below so I think ...
0
votes
4answers
504 views

How to install package from github

I need to install this package from github: https://github.com/vrai/fdspatch It is said to run on linux but it does not say specifically how to install. Can anyone tell me what commands I need to run? ...
0
votes
1answer
28 views

Installing RPi Software by SD Card Flashing

The recommended process for installing Home Assistant consists of flashing the program image to a SD card. Please see the highlighted line at the bottom of the screenshot. Are they suggesting that I ...
0
votes
0answers
38 views

Swiftshader on Rpi4

I want to turn my rpi 4b 8gb into a low-quality external gpu. It will recieve instructions through usb3.0 and will render them using its cpu and gpu. I found a library, Swiftshader, that allows cpu ...
1
vote
1answer
1k views

UrBackup Server Installation fails

I am trying to install the UrBackup Server on my Raspberry Pi running Raspbian 9 (stretch) (fresh install). I followed the steps described in the installation notes: wget https://hndl.urbackup.org/...
0
votes
4answers
260 views

Will Raspbery Pi OS work on 2GB or 1 GB SD card?

I am ordering a Raspberry Pi Zero WH and I have a 2GB in my storage. I want this pi to run only a pi-hole. I know that it is recomended to use 8GB, or at least 4GB. I am interested if somebody actualy ...
3
votes
1answer
578 views

`npm` and `nodejs` incompatibilities

I installed npm and nodejs today because I wanted to try tldr-pages. After the obligatory sudo apt-get update && sudo apt-get upgrade: $ sudo apt-get install nodejs npm Following a huge ...
1
vote
1answer
600 views

Can't Install Packages with apt-get | no installation candidate

I'm using Raspbian Stretch with Desktop(v4.14.62-v7) and I can't seem to be able to install packages on my rPi. For instance, when I type sudo apt-get install autoconf, I get: Reading package lists.....
0
votes
2answers
1k views

How do I Install Kivy for python 3.4 on my raspberry? Is that possible?

The question is on the title XD How do I Install Kivy for python 3.4 on my raspberry? Is that possible? I tried using the https://kivy.org/docs/installation/installation-rpi.html guide but thats only ...
1
vote
1answer
299 views

Can't install rails3 - unmet dependencies

I just got a Raspberry Pi 3 (I already have a fair amount of UNIX experience) and installed Raspbian. I'm trying to install Rails 3 with apt-get. When I try, I get a message about unmet dependencies. ...
0
votes
1answer
1k views

Unable to install signal-desktop on raspberry pi 4

I think I'm not understanding something because this should be easy. From the signal website (https://signal.org/download/#) the instructions for installing signal-desktop are : curl -s https://...
0
votes
1answer
89 views

How to Install Fedora/Pidora and Ubuntu Mate on Raspberry Pi? [closed]

I have a Raspberry Pi 3b+ and a Windows Laptop, through which I have downloaded Pidora and made a bootable SD Card with Etcher Software. When I try to boot my Pi using this SD card it is not doing ...
4
votes
1answer
245 views

BTSync update: 2.0.93 => latest

Years ago I installed BTSync from debian.yeasoft.net repo. My /etc/apt/sources.list.d/btsync.list: deb http://debian.yeasoft.net/btsync wheezy main contrib non-free deb-src http://debian.yeasoft.net/...
1
vote
1answer
17 views

Updating custom program over 4G

I have been working on a project that uses a Raspberry Pi 3b+ to send collected data to my server. This Raspberry Pi is setup with a 4G module and is able to send and receive data to and from my ...
0
votes
2answers
36 views

Openssl error while installing paho-mqtt python package

I am trying to install paho-mqtt python library using below command: sudo pip3 install paho-mqtt But I am getting below openssl error: Looking in indexes: https://pypi.org/simple, https://www.piwheels....
1
vote
2answers
857 views

Raspberry Pi Virtual Machine using Virtual Box will not install?

I tried creating a Raspberry Pi VM using the official Raspberry Pi for Desktop iso located at https://www.raspberrypi.org/downloads/raspberry-pi-desktop/, but every time I run the install, I get this ...
0
votes
1answer
818 views

Raspberry pi 3 problem with 'make install_autostart' command when installing servoblaster

I am working to create a pan/tilt face tracking system on the raspberry pi 3 and have been following the instructions on http://www.instructables.com/id/Pan-Tilt-face-tracking-with-the-raspberry-pi/ I ...
2
votes
3answers
1k views

Folding@home on RPi 3 model B?

How to install Folding@home on RPi3 B on Raspbian, if it’s possible at all? The Folding@home download page does have 64 and 32 debian versions, but downloading them results in an error “A package ...
18
votes
6answers
37k views

How do you get C# onto your raspberry pi?

I would like to start learning C# and really want to code in it on my raspberry pi. However, I can't find a way to get C# onto my pi. Does anyone know how to do this? I have the Raspberry pi 2 ...
2
votes
1answer
3k views

Installing RStudio on a Raspberry Pi running Ubuntu MATE 16.04

I am planning to do a classroom project using R and RStudio IDE. I am able to run R from command line. I installed the package using the command below sudo apt-get install r-base Now I am trying to ...
0
votes
3answers
7k views

Error installing RPI.gpio

I'm a new enthusiast trying to learn with raspberry pi so I apologize if I don't use the correct programming terms... The problem that i'm having at the moment is that when I try pip install rpi-gpio ...
3
votes
1answer
2k views

Unable to pip install librosa in raspberry pi 3 model b+ (Raspbian stretch)

Respected people, Attempt 1: when I run the command, pip3 install librosa I am stuck here, Running setup.py bdist_wheel for scipy ... \ It was taking more then 2 hours but it was still ...
1
vote
1answer
149 views

Install pypy3 on raspberry pi

I found this to try to help me install pypy3 https://stackoverflow.com/questions/55703832/install-pypy3-on-raspberry-pi However the download command no longer works. I tried: sudo apt-get install ...
1
vote
3answers
9k views

Install KDE Connect on Raspberry Pi 3

I tried installing KDE Connect on my Raspberry Pi 3 with following command...which didn't work. sudo add-apt-repository ppa:webupd8team/indicator-kdeconnect sudo apt update sudo apt install ...
-3
votes
1answer
63 views

Can I somehow install an OS on my Raspberry Pi rather than “burning it onto the card”? [closed]

I have experimented a lot with my Raspberry Pi over the years since I got it. Mostly, however, it has spent its time collecting dust in the wardrobe, because I always run into show-stopping issues ...
0
votes
2answers
606 views

Missing Driver for Canon Printer

Need to install a driver for a Canon Pixma MG2920 printer to use with a Raspberry Pi 3 as a server. Followed all the steps listed in a few online tutorials, but the printer is not listed in CUPS. ...
0
votes
0answers
147 views

Installing Vuze on Raspberry Pi 4 (8 GB)

I've trying to install Vuze on Raspberry Pi 4 8GB with Ubuntu Mate 20.10 OS and it just doesn't work, i'm getting errors about that it has some libraries missing and that it cannot read .so file. Does ...

1
2 3 4 5
9