Questions tagged [software-installation]

Questions regarding issues installing specific applications or operating systems on the Raspberry Pi.

Filter by
Sorted by
Tagged with
0
votes
0answers
545 views

USB to ethernet dongle not working on A+

I have an A+ I wanted to try use on my local network, so I installed Raspbian to an SD card, have a USB to ethernet dongle, and added a blank "ssh" file to the SD card root to be able to log in to it ...
0
votes
2answers
545 views

Why is Raspbian Stretch's image is SO HUGE on Window?

I downloaded Raspbian Stretch with Desktop to install on my PI. Once it completed, I tried to extract the file, but the window complained that there is not enough space that I need some 470 GB MORE. ...
1
vote
0answers
1k views

Installation of perl modules [closed]

I´m running a Rasbian strecth 4.9.59-v7+ and I´m trying to run the following software https://github.com/weaknetlabs/warcarrier which looks really neat! When trying to run the script I receive the ...
0
votes
1answer
716 views

Install problem Telegram on RPI3

I do the steps as written on github.com/vysheng/tg.git but after make I get an error. inter -ggdb -Wno-unused-parameter -fPIC -iquote ./tgl -c -MP -MD -MF dep/crypto/bn_openssl.d -MQ objs/crypto/...
2
votes
1answer
3k views

Installing RStudio on a Raspberry Pi running Ubuntu MATE 16.04

I am planning to do a classroom project using R and RStudio IDE. I am able to run R from command line. I installed the package using the command below sudo apt-get install r-base Now I am trying to ...
1
vote
3answers
9k views

Install KDE Connect on Raspberry Pi 3

I tried installing KDE Connect on my Raspberry Pi 3 with following command...which didn't work. sudo add-apt-repository ppa:webupd8team/indicator-kdeconnect sudo apt update sudo apt install ...
0
votes
3answers
605 views

How to install packages via “apt-get” while ssh connected to MacBook via ethernet cable?

I'm very new in Rpi community and sure enough had to spent the last 24 hours to figure out how to ssh connect from my MacBook to my Pi3 via an ethernet cable. I'm following the steps in the second ...
1
vote
1answer
3k views

installing gphoto2 on a Pi

I downloaded the .gz file from https://sourceforge.net/projects/gphoto/files/ (libgphoto2-2.5.16.tar.bz2), uncompressed it, un-tarred it. Then from the command line, I ran autoreconf --install —...
3
votes
1answer
188 views

How to add an “external” script to be executed at boot?

Background: I have several RPis which I need to re-image. I use the stock Raspbian and they get their IPs via DHCP. This makes it difficult (in my specific environment) to know which IP they received, ...
1
vote
1answer
7k views

MQTT.FX - how to install on RPI 3 from MQtt.fx website

I’m new to RPI and MQTT.fx. I have mosquito installed on my RPI and tested Ok, per the instructions on http://www.switchdoc.com/2016/02/tutorial-installing-and-testing-mosquitto-mqtt-on-raspberry-pi/...
0
votes
1answer
3k views

Running Windows executables in Raspbian?

I found an interest in Unity programming a few days ago and decided to try it out on linux, specifically, Raspbian Stretch. My question here has to do with the running of .exe files on Raspbian so I ...
6
votes
2answers
5k views

Install base Raspbian from repository, not using an image

Raspbian has no installer, so how can I install it by starting with debootstrap? How it works with Debian can you find here: install Debian with debootstrap and the package can be found here: ...
0
votes
1answer
128 views

I can't install VNC

Recently I have been trying to install VNC on my raspberry pi 3 but it won't work. It may be because I used the incorrect name for the file. I have used: sudo apt-get install VNC,sudo apt-get install ...
1
vote
0answers
600 views

Unable to get Pi to boot with Kali

I'm trying to flash an SD card with Kali Linux to run on my Pi. I've followed the instructions found here: https://docs.kali.org/downloading/kali-linux-live-usb-install and the image I downloaded came ...
2
votes
0answers
1k views

Unable to install Firefox or Thunderbird (Icedove)

I have been trying to install Firefox and Thunderbird on Raspbian Stretch, but I have not been able to. Edit: This issue seems to have been resolved for now. For some reason the sudo apt-get update ...
0
votes
1answer
371 views

NOOBS install menu options greyed out

I am trying to install Arch Linux using NOOBS. I have put it onto a 16GB SD card and applied power to the Pi (Pi 2, model B) and it started with no problems. However, all the menu options (Edit config,...
2
votes
1answer
225 views

Unable to install and open cryptocurrency wallet

Hi I am trying to very simply install and use the exodus wallet on my raspberry pi. I have the default OS installed, and downloaded the .zip from here. I extracted the files, but when double-...
0
votes
2answers
422 views

Why do I constantly have missing package dependencies?

Many tries. Many half-fails. All of the package managers that I'm using (apt-get, synaptic) always cannot really finish installations or removals. Just minutes ago I was trying to purge the code::...
1
vote
0answers
85 views

Installing mysql in Rasbian installs mariadb [duplicate]

I'm trying to install mysql server on my Raspberry pi 3 Model B. I've updated the packages and I've upgraded the packages using: sudo apt-get update && sudo apt-get upgrade When I install ...
1
vote
0answers
209 views

HOW TO FIX: “The valid stable is invalid for APT::Default-Release as such a release is not available in the sources”

So as I'm working on a project I type in "sudo apt-get install feh" but after I pressed enter it gave me a "The valid stable isinvalid for APT::Default-Release as such a release is not available in ...
1
vote
1answer
1k views

How can I connect to my Raspberry Pi 3 over SSH in this scenario?

I have a new Raspberry Pi 3 B 1.2 and I am trying to SSH into it. I don't have a monitor or an HDMI cable. I have already etched the img file with Raspberry Stretch onto a 64 GB SD card using Etcher....
4
votes
4answers
8k views

Install Postgre SQL in Raspbian Stretch

Anoyone try to install postgresql in Raspbian Stretch? I follow the instructions to the postgresql'site, but when in type sudo apt-get update, returns the follow error: N: Skipping acquire of ...
7
votes
5answers
27k views

Firefox 57 on a raspberry pi

I have just heard about the new firefox "Quantum". It says it uses 30% less RAM. Since the pi only has 1gb of ram, this sound good. Also, it would be nice to have a newer version of firefox. So, can ...
4
votes
3answers
3k views

Does Firefox 57 work on the RPi?

The title pretty much says it all. I am using Ubuntu Mate, so Firefox is available from the main repository. Firefox has not worked on the Raspberry Pi since Firefox 55. I hoped that Firefox 56 would ...
3
votes
3answers
5k views

Is “gedit” a command or text editor?

My question here has to do with "gedit." First of all, is it a Linux command or a text editor? From what I have been surfing up recently, gedit is, from my results, a GNOME text editor. And, at the ...
0
votes
1answer
170 views

Error installing wpasupplicant

I received the following error whilst installing wpasupplicant $ sudo apt-get install wpasupplicant Reading package lists... Done Building dependency tree Reading state information... Done The ...
-1
votes
1answer
99 views

Troubles with installation

What I need to do is to install ROS on a Raspberry Pi 3 (Model B) with Raspbian (I cannot use Ubuntu Mate). First, I tried to do it using Windows 10, with qemu, and following these instructions but I ...
0
votes
1answer
566 views

Unable to run PHP on Raspbian Jessie

I have installed Apache on my Raspberry Pi without incident. However, I cannot install PHP correctly after having tried various methods. It appears to have installed but I cannot get PHP to output. I ...
-3
votes
1answer
359 views

Can't mount raspberry after I've burn raspbian [closed]

Given: So, I have an 8 GB sd card. TODO: Get raspbian Solution: First I delete the partition: Command (m for help): d Selected partition 1 Partition 1 has been deleted. After i've created a new ...
0
votes
1answer
274 views

something similar as jira for rpi

I have rpi model b 2. I wan't to install some kind of management solution tool (like jira). Problem is I don't know what should I choose, because rpi have too small resources. For an example, jira ...
0
votes
3answers
7k views

Error installing RPI.gpio

I'm a new enthusiast trying to learn with raspberry pi so I apologize if I don't use the correct programming terms... The problem that i'm having at the moment is that when I try pip install rpi-gpio ...
0
votes
1answer
54 views

Did dumb thing and removed GTK3.0 folder

So I removed the folder. OK...dumb move Now, when I try to install again.... sudo apt-get install libgtk-3-dev It responds: "libgtk-3-dev is already newest version" So how can I re-install ...
2
votes
1answer
198 views

Cannot install matrix-creator-init for AlexaPi

I'm trying to follow the instructions from Instructables to build an AlexaPi. When following step 3, I get the error: matrix-creator-init : Depends: matrix-creator-openocd but it is not going to be ...
0
votes
3answers
90 views

Is there a way to do a “factory rest” on RPi?

I have recently installed Jessie on my HDMIPi, and the first thing I have tried to do is to install simplecv, but every attempt so far has failed. Now there is most likely a load of rubbish in there ...
1
vote
2answers
2k views

Formatting SDXC Card - Format Size Adjustment option doesn't exist?

So I'm trying to format my 64 GB SD card, using the instructions on the Raspberry Pi website (for Windows). They say to run the SD Formatter with Format Size Adjustment set to ON. But in the SD ...
0
votes
2answers
98 views

Cannot start my Raspberry Pi

I'm trying to install my very first Raspberry Pi, but when I copy the NOOBS files to a 16 GB class 10 SD card, the lights (the red and the green) turn on but nothing shows on the screen. I already ...
1
vote
0answers
289 views

phpmyadmin installation issue

I am having trouble installing phpmyadmin on the raspberry pi zero. The raspberry pi is connected to a Windows 10 laptop with SSH using putty and the internet connection is bridge from my laptop. At ...
2
votes
1answer
246 views

Can Etcher be used to customize the base Raspbian image?

I was wondering if anyone in this community has used Etcher to burn OS images to a Raspberry Pi. I have a Rapberry Pi 1 Model A and would like to use Etcher to burn Raspbian Stretch Lite to it with ...
1
vote
0answers
499 views

Unable to install the driver for “AVerTV Volar HD Nano - A867R” (a DVB-T dongle)

I downloaded the driver (for linux) from the AVerMedia site, unpacked it into an xyz directory, and from that directory I gave the command make. I got the following output Missing files that required ...
0
votes
2answers
3k views

Installing/using PyVISA-py on Raspberry Pi

I am trying to install PyVISA-py on my Raspberry Pi 3 Model B without internet connection, because I understand that the normal PyVISA needs the NI backend that is not supported on the Pi. However, I ...
0
votes
0answers
1k views

Using Pitivi Video Editor on Raspberry pi 3

On Raspbian, I tried to run Pitivi on Raspberry pi 3 to edit a short clip. Although OpenShot and Kdenlive later worked for me, I hope I can still get Pitivi to work. I got this error, Is it fixable?
1
vote
1answer
1k views

Can't Install Miniconda 3

Following these steps: wget http://repo.continuum.io/miniconda/Miniconda3-latest-Linux-armv7l.sh chmod +x Miniconda3-latest-Linux-armv7l.sh ./Miniconda3-latest-Linux-armv7l.sh I get to License ...
0
votes
1answer
54 views

OS installation through VNC

The only way I have to display my RPi is VNC. If the VNC is installed, it's ok. But How can I make the installation? Is there any OS with VNC installed by default? Or is it possible to make the OS ...
1
vote
0answers
506 views

Replacing `jessie` with `stable` in raspbian `sources.list`?

in debian etc/apt/sources.list it is possible to replace the name of the current distribution with the status of a given distribution. For example, if one plans to use always the stable release can ...
0
votes
1answer
596 views

SimpleCV is not downloading!

Whenever I try to install SimpleCV, I always get this error message. Traceback (most recent call last): File "/usr/bin/pip", line 9, in <module> load_entry_point('pip==1.5.6', '...
1
vote
1answer
9k views

PySerial Error on Raspberry 3

So I am trying to setup the code on my Raspberry Pi 3 Model B so make it so it can read and write from a Serial Port. I installed Python 2 and 3 versions of PySerial with: sudo apt-get install ...
5
votes
3answers
3k views

Custom Pi's for Commercial Applications

I am looking to start a small company that sells Pi's predefined to fit my customer's needs. My question is: Is there a site where I can order custom raspberry Pis in bulk with my code already on ...
2
votes
2answers
2k views

How to upgrade from an old Raspbian version on a Pi without a computer?

I have a Raspberry Pi 2 Model B, with Wheezy installed. Running some commands tells me version 7.11.x is installed. I would like to upgrade to Raspbian Jessie, which is on 8.8, if I'm not mistaken. ...
5
votes
3answers
23k views

Unable to install mongodb 3.4 on Pi 3

I have been trying to install the latest version of mongodb on my Pi 3. I currently am running the latest version of node (8.0.0) and am running Raspbian lite - Jessie (8). I have been following this ...
1
vote
1answer
412 views

How do I install a vpn on raspberry pi3 debian?

I have installed the defaults from NOOBS that came with the Canakit, have networking and browser working ... the only instructions I've found for ipvanish vpn setup so far use the outdated media ...

1 2 3
4
5
9