Questions tagged [update]

For questions regarding how to update the Pi's operating systems, programming languages, and applications (both native and external). Consider also tagging with the program or OS that you are updating if appropriate, and use [rpi-update] instead for the tool itself.

Filter by
Sorted by
Tagged with
94
votes
3answers
235k views

How do I update software and firmware?

I understand that the software on the Raspberry Pi is divided into three sections: the closed-source GPU firmware, the patched ARM Linux kernel and the user space software. Is the GPU firmware on the ...
74
votes
7answers
102k views

Upgrade to Raspbian Jessie

How can I perform an upgrade from Raspbian Wheezy to Jessie?
67
votes
6answers
124k views

Do I still need rpi-update if I am using the latest version of Raspbian?

I have a 512MB Pi. I am trying to make sure I am getting the most out of it. I just downloaded the latest version of Raspbian and installed it on the Pi. Do I also need rpi-update? Is rpi-update ...
58
votes
3answers
18k views

Is the Raspberry Pi vulnerable to the Spectre or Meltdown exploit?

There are two new serious security flaws discovered, Spectre and Meltdown. Is the Raspberry Pi vulnerable for Spectre and/or Meltdown?
45
votes
6answers
121k views

How can I keep my Raspbian “Wheezy” up to date?

Is there a sort of update tool for my Raspbian Debian 7 (Wheezy) package? I installed php and lighttpd, and I want to keep those automatically updated for when bugs are found.
36
votes
4answers
58k views

How do I set my Raspberry Pi to automatically update/upgrade?

Currently, to get things up to date on my Raspberry Pi, I have to type in sudo apt-get update and sudo apt-get upgrade. Is there a way to set it up to automatically do this? I am running Raspbian ...
29
votes
1answer
38k views

How do I update OpenSSL on Raspbian

It seems like Raspbian has not been updated yet to deal with the Heartbleed bug. sudo apt-get update then sudo apt-get upgrade doesn't update anything (this is a system which was freshly updated ...
19
votes
4answers
70k views

How do I update Java 8 in Raspbian

My Raspberry Pi 3 came with Java version 1.8.0_65 installed. I could not update it to a later version using apt-get - I assume there's no Debian repo for it. I do not know how to update it, and ...
18
votes
2answers
41k views

How do I upgrade Raspbian?

I have my Raspberry Pi setup how I want, but I have an older version than what is currently available (2012-10-28-wheezy-raspbian.zip). How do I upgrade the kernel, firmware, etc.? I have upgraded ...
15
votes
2answers
13k views

apt-get update and upgrade says “packages have been kept back”

I ran an update and an upgrade (apt-get update and apt-get upgrade) and I get the following message: The following packages have been kept back: alsa-base scratch What do I do to get these ...
15
votes
4answers
10k views

Is the Raspberry Pi vulnerable to the KRACKs on WPA2 networks?

I have an updated RPI Zero W running Stretch. The research is stating that wpa_supplicant is vulnerable on all Linux machines. According to Debian patches are rolled out: For the oldstable ...
13
votes
3answers
42k views

Installing Python 3.4 on Raspberry Pi

Is it possible to run python 3.4 on a Raspberry Pi? Currently I have python 3.2, but the odd thing is that running sudo apt-get update sudo apt-get install python3 results in my Raspberry Pi ...
13
votes
1answer
4k views

Automatic updating recommended?

Is it recommended to configure something to automatically keep an RPi updated? And if so, which method (cron-apt or something else)?
13
votes
2answers
33k views

Raspberry Pi apt-get update/upgrade on Raspbian hangs?

Whenever I try to update my pi using sudo apt-get update && sudo apt-get upgrade it will often hang at some point during the installation. It's been different ones each time, but the last was ...
11
votes
1answer
2k views

What is the difference between rpi-update and sudo-apt upgrade?

I'm wondering what the difference is between running the git-hub obtained program rpi-update and using sudo apt-get update followed by sudo apt-get upgrade. I've checked around and cannot find the ...
10
votes
1answer
8k views

Configuring `unattended-upgrades` on Raspbian Stretch

I recently upgraded from Jessie to Stretch and received a new version of the configuration file for unattended-upgrades. Oddly, this new version references Debian instead of Raspbian. pi@kegerator:/...
10
votes
1answer
11k views

How can I access Raspbian Jessie packages from Wheezy?

I need a package that's in jessie, the newer version of Raspbian, but not in wheezy, the one I have installed. Can I use it somehow? Can/should I just upgrade to jessie?
7
votes
4answers
8k views

Pi 3 Raspbian “stretch” (testing) disables wifi

I have a raspberry pi 3 (which has internal WiFi), running raspbian. I decided to run it as "testing", by changing the apt list. Now, I can't use WiFi. Whenever I use wpa_supplicant, it complains ...
7
votes
2answers
14k views

Enable SSH in NOOBS before install

In the last release (2.1) of NOOBS the developers have "disabled by default" SSH, so it's not possible anymore to connect to a Raspbian via SSH, which is installed via NOOBS, without enabling SSH ...
7
votes
5answers
5k views

How to update multiple Pis at once?

Is there a way to update multiple Raspberry Pi machines at the same time? Would it be possible to update them from a single copy of the image on the central Ubuntu PC server so that the download takes ...
7
votes
2answers
606 views

Kernel not updating on Raspbian under QEMU

I'm trying to update my kernel to the latest version. apt is updated and upgraded, and rpi-update finishes without error. However when I reboot, I'm still running the old kernel. Any ideas? $ uname -...
6
votes
1answer
7k views

Getting a deb repository error for collabora

I'm brave enough to try out the upgrade from wheezy to jessie on my pi according to this: Upgrade to Raspbian Jessie So far it runs pretty smooth, except that I get an error when updating the ...
6
votes
3answers
1k views

Does the firmware update corrupt the filesystem?

I regularly make ISO images of my SD cards (for many reasons), and I have noticed that whenever I issue the rpi-update command, I can no longer make these images, instead getting this error: sudo dd ...
5
votes
3answers
5k views

OTA Update of Multiple Raspberry Pi's

I have 4 Raspberry Pi compute modules, running at different locations and I would like to run a script from the server that would connect and update the pi's with the latest version of the file found ...
5
votes
2answers
18k views

Installing Qt on Raspberry Pi 3

I'm trying to install Qt Creator to my Raspberry Pi 3 for a GUI project. However when I use the command sudo apt-get install qt5-default it gives an error saying that: E:Unable to fetch some ...
5
votes
1answer
2k views

Cannot update nor install package on Arch, getting “empty reply from server” error

:: Synchronizing package databases... error: failed retrieving file 'core.db' from va.us.mirror.archlinuxarm.org : Empty reply from server error: failed to update core (download library error) extra ...
5
votes
1answer
365 views

Updating a configured RPi - effects on configurations and settings etc

Suppose I've spent a bit of time configuring an RPi just the way I want, but then I need to make updates, both to the distro and to the installed software. In this question, how to update is covered: ...
5
votes
4answers
7k views

Raspberry Pi 3 Ubuntu 16.04 Server upgrade error

So last week I bought the Raspberry Pi 3 model B with the complete Canakit. I installed Ubuntu 16.04 server standard image on the micro sd card with my Windows computer. I used SF Formatter to ...
5
votes
1answer
4k views

Sub-process /usr/bin/dpkg returned an error code (1) on apt-get upgrade

I'm using Raspberry Pi 1 model B without GUI and when I try to upgrade software using sudo apt-get upgrade I get the following error: Segmentation fault dpkg: warning: subprocess old pre-removal ...
4
votes
3answers
4k views

Is it possible to flash the Pi's firmware live?

I already have few Raspberry Pi devices running Raspbian + my custom scripts. These device is internet connected and mounted at area which is hard to access, (e.g on top of a building) Over the ...
4
votes
1answer
9k views

Why I can't update kernel version?

I have perform the following command into ssh shell: sudo apt-get upgrade sudo apt-get update sudo reboot But I still have an old kernel version, infact: pi@raspberrypi ~ $ uname -a Linux ...
4
votes
3answers
6k views

Command apt-get upgrade crashes Raspbian

The image file I am using is quite old. How old exactly I am not sure, because this image I have inherited from previous developer. I have learnt that running: sudo apt-get update sudo apt-get ...
4
votes
1answer
2k views

After upgrade to Jessie, crashes when external USB drive is connected

I have a Raspberry Pi 2 which was running successfully with Wheezy. I decided to upgrade to Jessie. When I plug in the external USB drive (LaCie Rugged THB USB 3.0), it crashes. I did an ssh and ...
4
votes
1answer
9k views

sudo apt-get update continually errors, despite reboots

I'm trying to host an apache2 server on my RasPi, but I can't seem to even complete the first step of updating all the software. Here's the error message: Err http://archive.raspberrypi.org jessie ...
3
votes
2answers
2k views

How can you update “Incredible PBX” for the Raspberry Pi without using the non-free, $20/year updater?

I have been a fan of Asterisk, and in particular the project The Incredible PBX. However, they charge $20 per year to update (for the raspberry pi). This updater installs security updates, among ...
3
votes
3answers
703 views

Is it worth it to upgrade to Jessie on a headless Pi2?

I'm running Raspbian (Wheezy) on a headless Raspberry Pi 2 at home to manage a number of services for my own amusement (*listed below) and to play around in general (** below). It's pretty much only ...
3
votes
4answers
7k views

How to solve “Encountered a section with no Package: header” error?

I am running a bunch of class Raspberry Pi computers behind a school proxy. I'm using Raspbian off a very recent NOOBS image. The internet connection is supplied through the school WiFi and after ...
3
votes
2answers
237 views

Problems getting df to update on my raspberry pi

I am a relative newbie to this however I have a couple of raspberry pi's (with the standard out of the box configuration) and was writing a PHP that linked to a df shell command. However I found that ...
3
votes
1answer
465 views

How to fix glibc vulnerability CVE-2015-7547

https://www.debian.org/security/2016/dsa-3481 Do we need to wait for a RASPBIAN upgrade to be available here? https://www.raspberrypi.org/downloads/raspbian/ I ran: sudo apt-get update && ...
3
votes
3answers
3k views

Updating kernel/firmware to specific version

I've updated my rPi to the latest kernel/firmware using rpi-update and my Bluetooth dongle stopped working. I found this to be a known bug in 3.10.* branch of the kernel. Through tinkering and ...
3
votes
3answers
5k views

Can I plug my SD card from Pi 3 into a Pi 4?

If I upgrade the OS to buster on an OS disk (SD card or USB stick) on my pi 3, will it work if I boot a pi 4 off that?
3
votes
2answers
10k views

How to upgrade Mosquitto MQTT to the latest version?

Right now I have 1.3.4 Mosquitto Version installed from the repository on my PI. Current version is 1.4.15. So, how do I go about upgrading my Mosquitto MQTT to the latest version on my PI? I looked ...
3
votes
3answers
5k views

What does rpi-update do?

I am thinking about upgrading the firmware on the Raspbery Pi 512 using rpi-update. However, I can't figure out what updating the firmware does. Does it make the Pi more stable? Or faster? I can't ...
3
votes
1answer
897 views

Unmet dependencies when installing expect and libiw-dev

Every time I run the command sudo apt-get upgrade this is what I get. What should I do? Reading package lists... Done Building dependency tree Reading state information... Done You might want ...
3
votes
1answer
2k views

How to upgrade GNU nano to newer version?

So far nano seems my favorite terminal editor, but I noticed I have pretty old GNU nano 2.2.6 While latest is GNU nano 2.8.6. I tried: sudo apt-get install nano but it said I already using newest ...
3
votes
3answers
1k views

Taskbar flashes grey

After an update a few months ago, the taskbar on the desktop disappeared and was replaced with a flashing grey bar. I am running Jessie and am getting the following errors when running an update: ...
3
votes
2answers
4k views

apt-get upgrade fails because of some dependency loop

If I update my Raspberry PI with: sudo apt-get upgrade I run into follwoing dependency errors: lighttpd (1.4.31-4+deb7u3) wird eingerichtet ... insserv: warning: script 'mathkernel' missing LSB ...
3
votes
2answers
678 views

Can I safely hook up my Raspbian device to the Internet?

I recently bought a Raspberry Pi, and I would like to attach it to my local network and (via port forwarding) let it be reachable from 'the outside world'. My plan is to run Apache with PHP on it, ...
3
votes
1answer
140 views

sudo apt-get update does not connect to 10.10.5.18

I am having this prob since morning only and before that everything was normal. I can connect to my Pi through ssh using putty on my windows 7. The problem is when I run sudo apt-get update, it gets ...
3
votes
1answer
188 views

apt-get not working on raspberry pi zero w [Internal error: Oops: 17 [#1] ARM]

I bought a new raspberry pi zero w. I flashed the raspbian lite image on a sd-card, the pi booted normally. But when I try to update it with sudo apt-get update sudo apt-get upgrade I get the ...

1 2 3 4 5