We’re rewarding the question askers & reputations are being recalculated! Read more.

Questions tagged [upstart]

an event-based replacement for the traditional init daemon to perform tasks when the computer is started.

Filter by
Sorted by
Tagged with
0
votes
1answer
1k views

auto start using /etc/rc.local or /etc/init.d not working

-My problem: I can't get autostart to work (/etc/rc.local or /etc/init.d) /etc/rc.local screen never boots and kills the pi, which then needs to be re-flashed to work again. /etc/init.d no auto ...
0
votes
1answer
145 views

Pi won't boot after i installed upstart

So, here is my problem: I installed upstart on my raspbian (jessie) yesterday. After i tried to reboot the system, the boot loader didn't load any further. The problem is, that the sd card is in my ...
1
vote
1answer
8k views

Getting to display images with feh at startup

I can't get my raspberry pi to display images using feh at startup. I have tried placing my simple feh command wrapped in a shell in cron jobs, /etc/rc0-9.d, and init.d but nothing is working. I ...
0
votes
1answer
62 views

upstart prevent pi from booting properly

I followed this guide to use my pi as a MIDI synthesizer. http://andrewdotni.ch/blog/2015/02/28/midi-synth-with-raspberry-p/ Everything worked well until I installed uptsart. Since, my boot screen ...
3
votes
1answer
256 views

Why raspbian has /usr/sbin/service?

I know that Raspbian, being a Debian derived distribution, uses systemd as its init system, but the question is, why is there the binary /usr/sbin/service from the upstart init system? Is there to ...
2
votes
1answer
5k views

How to install upstart on raspberry pi 3

Getting some unmet dependencies issue trying to install upstart. Should I install upstart some other way ? pi@raspberrypi:~ $ sudo apt-get install upstart Reading package lists... Done Building ...
2
votes
0answers
472 views

Why can't I set my app to run on startup with Windows IoT?

I have an app that I would like to have run automatically when my Raspberry Pi 2 starts up. The Raspberry Pi 2 is running Windows 10 IoT. I am able to deploy my app and run it with the Visual ...
0
votes
1answer
190 views

How to run a java serial data command with arguments on start-up

I am using Raspberry Pi 2 to a telosB base station to collect data from other sensors. I receive (on the terminal) hex data and redirect these incoming data into a python script which will clean and ...
0
votes
1answer
1k views

Cannot Install Upstart on Raspbian Jessie

I am trying to install Upstart, this is what I do sudo apt-get install upstart Reading package lists... Done Building dependency tree Reading state information... Done The following extra packages ...
0
votes
0answers
327 views

Raspberry pi boot stuck at udevd

Currently my raspberry pi, running Raspbian, won't fully boot up because its getting stuck 5 seconds into boot at udevd[107] starting version 175 Everything was running smoothly until I installed ...
0
votes
1answer
162 views

Where is the default error log for upstart in Raspberrian?

I created a file in /etc/init/wiki.conf to start up my wiki from a shell script on my Raspberry PI Model B: # tw5nginx.conf description "Nginx Tiddlywiki5 Wiki" author "Me" start on started ...
10
votes
3answers
22k views

How to build custom OS for Raspberry pi from scratch?

I am new to kernel and embedded Linux. I have recently bought a Raspberry Pi and booted it using the Raspbian. I was fascinated by the Pi, to learn more on Embedded I have decided to make an home ...