Skip to main content

Questions tagged [wayland]

Wayland is a computer display server protocol

Filter by
Sorted by
Tagged with
-1 votes
1 answer
26 views

How to use WayVNC in virtual mode instead of service/console mode on a headful Pi?

I set up a new Pi5 at a remote location and plugged it into an old DVI monitor + kbd + mouse in case anyone needs watch the boot process. Setup is default Wayland + WayVNC. Now that I'm away, RealVNC ...
MJA's user avatar
  • 99
0 votes
1 answer
105 views

How to change cursor theme?

How can one change the mouse cursor used in Raspberry Pi OS Bookworm? (Wayfire) I have tried a number of things: setting a cursor theme through lxappearance, manually editing configs for GTKs 2 and 3, ...
Miles B Huff's user avatar
0 votes
0 answers
51 views

Is it possible to split my screen in half and mirror the image on a raspberry pi 5?

I'm trying to do homemade VR using a raspberry pi 5 and I was wondering if there's a way to split the screen in half and on each side mirror the same image. So far I tried some xrandr instructions I ...
chyxo's user avatar
  • 1
0 votes
0 answers
284 views

Ras Pi OS Black screen after switching to X11

I have a new install of the current Pi OS (bookworm) and am having an issue getting my touchscreen to rotate. I think I identified Wayland as the problem and switched to X11 as detailed in this post: ...
ManaBanana's user avatar
1 vote
1 answer
2k views

Raspberry Pi OS Bookworm, Wayland desktop + headless Pi, cannot get past first boot wizard

I probably did something wrong during initial setup, but I've hit a rather strange problem trying to set up a graphical headless RPi 4B with Raspberry Pi OS Bookworm. To set up my Pi, I downloaded ...
ArrayBolt3's user avatar
0 votes
2 answers
4k views

Forcing HDMI output on Bookworm

I want to force both Raspberry 4 HDMI output's to 1920x1080@60Hz in desktop mode where either one output doesn't necessarily have a HDMI connected but usually will but often not at the same time. When ...
kleurbleur's user avatar
0 votes
0 answers
783 views

VC4 — GL setup not working

I am trying to run chromium as weston-client using ArchArm on a RPI 3+ b, but I am unable to make it use GL. Setup: Basic »AArch64« installation as described here Package Installation: wayland ...
philipp's user avatar
  • 191
1 vote
0 answers
606 views

Wayland: Install a GNOME 3 Desktop (pilfs)

I have built PiLFS on my Raspberry Pi 2. I have also build Wayland/Weston on it. But, I want to install a GNOME 3.20.x desktop on it. How would I do so?
Greg Kid's user avatar
0 votes
0 answers
579 views

GTK+ with Broadway

I am trying to use GDK Broadway backend on Raspbian jessie. sudo broadwayd -a 192.168.0.3 -p 80 :5 & Runs and server and I can access from browser http://192.168.0.3/ but most of the ...
Gadelkareem's user avatar
2 votes
1 answer
5k views

Error when running X apps with XWayland: "cannot open display: :0"

I'm trying to run a simple X app under Weston using XWayland, but I get an error. I launch Weston as follows: $ weston-launch --modules=xwayland.so With the command-line argument as suggested here (...
einnocent's user avatar
  • 494
1 vote
3 answers
1k views

Wayland/Weston freezes

I have freshly installed last Raspbian and updated it. When computer boots up to console, I log in and start command weston-launch. The output of command is something about initializing Raspberry Pi's ...
user1257255's user avatar
3 votes
1 answer
4k views

Weston examples on Raspberry Pi

I've just successfully compiled and installed Wayland and Weston on my raspberry box (running Raspbian) following these instructions http://wayland.freedesktop.org/raspberrypi.html However, when I run ...
random.cpp's user avatar