Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [wpa]

WiFi Protected Access (WPA) is a wireless encryption standard.

0
votes
0answers
17 views

Some Raspberry Pis not connecting to Internet

I have a set of 24 Raspberry-Pi Zero W that I need to connect to a router (Netgear NightHawk AC2400) with SSID:NETGEAR30. I want all of them to connect on system start to the router. I have programmed ...
0
votes
1answer
31 views

connect a headless raspberry pi zero to a WPA2 Mixed WiFi network

I'm trying to connect my rpi zero in a headless mode into a WIFI network configured in a WPA mixed mode. More specifically I can get the following info from the router. Security-Mode: WPA2-Mixed ...
5
votes
0answers
106 views

connmanctl having problem with complex passphrase

The built in WiFi module seems to work fine, as it can connect to both of my open networks I created for testing, i.e. the 2.4GHz, and the 5.0GHz ones. If I set a simple passphrase (i.e. contains ...
0
votes
1answer
52 views

WPA Enterprise problem connect

The only way I've found to connect to an Enterprise AP is to modify the wpa_supplicant.conf file, adding this: ctrl_interface=/var/run/wpa_supplicant update_config=1 country=IT ap_scan=2 fast_reauth=...
2
votes
1answer
51 views

What's wrong with this wpa_suppplicant.conf file?

I have an original wpa_supplicant.conf file which I tried to add a new network. Both have same owner (root) and same permissions 644. I just added one more network at the end (just for testing). ...
1
vote
3answers
30 views

/boot/wpa_config being copied with wrong permission

I plug the micro SD into my MacBook. I then save a correct /Volumes/boot/wpa_supplicant.conf with file permissions with 777 (default when creating files into the FAT partition). Then, when I move back ...
1
vote
0answers
1k views

wlan0: link is not ready

I have had my pi3 for a while now all of a sudden I start to get IPv6: ADDRCONF (NETDEV_UP): wlan0: link is not ready IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready and stalls there ...
0
votes
0answers
17 views

Wpa2 enterprise university campus raspberry pi [duplicate]

I tried following other guides on the stack but all of them did not work for me. I am trying to connect to a wpa2 enterprise encrypted wifi from a raspberry pi 3 B+ running Debian stretch raspbian ...
0
votes
1answer
243 views

Wpa_supplicant with openwrt router ‘could not read SSID from driver’

Arch Linux ARM was installed successfully on a Raspberry Pi3 which will be added to a small network. The first attempt at setting up wifi on the Pi3 failed, showing alarm wpa_supplicant[323]: wlan0: ...
0
votes
1answer
48 views

wpa_supplicant.conf entries?

Every resource I have seen / used always say how to COPY or paste entries into wpa_supplicant.conf. The question is Is there a document actually explaining , in "5 W's" style, purpose these entries?...
1
vote
2answers
367 views

On a Raspberry Pi 3 running Stretch, how do I configure dhcpcd to call wpa_supplicant automatically and/or persist the connection through a reboot?

My /etc/dhcpcd.conf file is configured so that if I manually run this wpa_supplicant command from the terminal: wpa_supplicant -B -D nl80211 -P /var/run/wpaSupplicantPid.pid -i wlan0 -c /etc/...
0
votes
0answers
328 views

How do I fix this error with wpa_cli? (strace included)

I had an unfortunate pulling of the power plug on my pi and now wpa_cli isn't starting correctly. user@raspberrypi:~ $ wpa_cli wpa_cli v2.3 Copyright (c) 2004-2014, Jouni Malinen <j@w1.fi> and ...
0
votes
2answers
535 views

ssh and wpa_supplicant.conf files not getting deleted on boot?

I am following this guide for the raspberry pi zero w: https://core-electronics.com.au/tutorials/raspberry-pi-zerow-headless-wifi-setup.html I've flashed the latest raspbian stretch lite to the SD ...
1
vote
2answers
642 views

wpa_supplicant connects to wifi but gets no ip

we are facing a weird issue. Basically, wpa_supplicant tries to connect to wifi network, and apparently succeeds, but it can get no IP address. We are using a Raspberry Pi Zero W to generate an ...
0
votes
0answers
813 views

iPhone Connects to my 5GHz WiFi Access Point but not Raspberry Pi 3 B+

I just received my Raspberry Pi 3 B+ with onboard dual band WiFi. I have a 5GHz Access point that my iPhone ( and MacBook ) connects to just fine. I am using wpa_supplicant on the Pi to manually ...
1
vote
2answers
7k views

Raspbian: static IP for eth0 and dhcp for wlan0

I run a Raspberry Pi at our university (Raspbian Stretch). I use it for a project where it has to rely on WiFi. I configured the connection using wpa_supplicant and it worked perfectly well. Now there'...
0
votes
0answers
21 views

wpa_supplicant daemon failed then worked again

When I tried booting my Pi up the last time, it wouldn't boot. The console said that the wpa_supplicant daemon failed to load. But when I tried again, it worked and booted up fine. What was wrong?
0
votes
1answer
165 views

Enabling WPS in wpa_supplicant on Debian (Raspbian Jessie) wpa_supplicant fails

I have a wireless network router setup under debian (jessie on a Raspberry Pi) with a fixed IP address, DHCP serving - and it all works fine. Now I want to enable the router (raspberry) to allow ...
3
votes
4answers
3k views

Cannot get WiFi to work on PI 3 running stretch

I have 2 identical rpi 3 devices. Both are running the same version of OS, namely "stretch" version 9 (from the same source). They have slightly diverged via upgrades and updates. On one I can use ...
1
vote
1answer
26 views

Cycling through configured Wifi networks if AP connected BUT no internet

I am running a couple RPi powering infoscreens in a building where everyone and their cat made their own undocumented "improvements" to the network configuration (and I am undertooled, undermotivated ...
0
votes
0answers
67 views

No wifi interfaces found after logging in as different user

I just configured my Pi ZeroW to connect to a WPA2 Enterprise network. All good. When I log out of the pi account and log back in as another user, the wifi icon is an up/down arrows and when I click ...
0
votes
1answer
239 views

Inconsistent ifup

I'm working with a raspberry pi 3 running a fresh install Raspbian Stretch Lite. Basically my problem is that the pi inconsistently connects to our network. I've been running sudo ifdown wlan0; sudo ...
1
vote
0answers
598 views

How to connect raspberry to WEP encrypted and dhcp enabled Ad-Hoc network

I have Three Rasbperry Pi3 and I have configured 2 of them as dhcp enabled ad-hoc network server they are working fine and I can connect to them using Windows PC and Linux PC as well as from Mobile. ...
6
votes
4answers
12k views

Cannot set up WiFi on Raspberry Pi Zero W running Stretch

I have been trying to connect to my wireless network for several days now with my Raspberry Pi Zero W running Stretch (2017-08-16 release). I have read many threads on how to setup wifi, including the ...
2
votes
1answer
52 views

Configuring the Raspberry Pi to use various protected WiFi spots

The use case is this: the Pi will periodically ping my server. If it gets the go-ahead, it will perform some action using a relay. Otherwise it'll remain dormant. I need to install multiple RP3s at ...
0
votes
1answer
680 views

Can't connect to company WiFi (WAP2 Enterprise)

First time setting up a a Pi and running into this... When I browse the wifi connections, I can see the wifi I want but it's greyed out. How do I connect to it? I found this but after following ...
0
votes
1answer
144 views

wpa_supplicant runs only once after the raspberry boots

I have a raspberry Pi 3 Model B. I have installed fullpageos on the rasp. I run the wpa_supplicant command to connect to the wifi. I use the following command - wpa_supplicant -Dnl80211 -iwlan0 -...
0
votes
0answers
3k views

run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1

I am facing an issue with my WIFI dongle. When i am running sudo ifup --force wlan0 wpa_supplicant: wpa_action is managing ifup/ifdown state of wlan0 wpa_supplicant: execute `ifdown --...
6
votes
1answer
30k views

Why is wpa_cli producing error “Could not connect to wpa_supplicant: wlan0 - re-trying”?

I am running 4.9.13-4-ARCH #1 SMP Sat Mar 11 14:16:01 MST 2017 armv7l GNU/Linux and I am using systemd-networkd for the network in conjunction with wpa_supplicant, obviously. Running wpa_cli -i wlan0:...
0
votes
0answers
85 views

raspberrypi 3 (minibian): wlan0 doesn't work without eth0 being plugged in to router

I'm customizing my minibian distro and now having hard time to set up two network interfaces: wireless (wlan0) and wired (eth0). I want eth0 to have a static IP (in case I need to connect it to the ...
0
votes
1answer
3k views

wifi issue with pi 3

I've had some problems setting up wifi using wpa_supplicant but would prefer to use it so I set up the pi to auto associated with networks i will likely be around. Initially I used the GUI to connect,...
1
vote
0answers
197 views

What's this icon on raspberry pi 3?

I'm working on a project for my college, but the university wifi is making it a huge hassle to connect to it. I'm trying to connect to a WPA EAP, but the connection is greyed out and there's this icon....
5
votes
1answer
26k views

How to reset the WiFi configuration in Raspbian

The WiFi-related configurations are stored in /etc/wpa_supplicant/wpa_supplicant.conf file. For example, if WPS (WiFi protected setup) is succeeded by using wpa_cli command, the configuration ...
8
votes
4answers
8k views

Pi 3 Raspbian “stretch” (testing) disables wifi

I have a raspberry pi 3 (which has internal WiFi), running raspbian. I decided to run it as "testing", by changing the apt list. Now, I can't use WiFi. Whenever I use wpa_supplicant, it complains ...
3
votes
2answers
1k views

Setting up ad-hoc wireless

I have pi 'A' setup to be an adhoc network and using dhcp3-server. /etc/network/interfaces auto lo iface lo inet loopback iface eth0 inet dhcp auto wlan0 iface wlan0 inet static address 10.10.1.1 ...
2
votes
2answers
2k views

Eduroam, wpa2-enterprise, wifi connection - Configuration options for the wpa_supplicant.conf file

In attemting to get wifi configured for Model B, I'm editing the /etc/wpa_supplicant/wpa_supplicant.conffile in line with this and this. The network to which I'm connecting is asking me to set the ...
3
votes
3answers
762 views

Connecting to enterprise network wpa_supplicant

I am currently trying to connect to an enterprise network through wpa_supplicant, I am using the file: /etc/wpa_supplicant/wpa_supplicant.conf The network is PEAP MSCHAPV2 I am using this code I ...
3
votes
6answers
9k views

Raspbian wpa_supplicant problem

My old wpa_supplicant and interfaces config not work! /etc/wpa_supplicant/wpa_supplicant.conf ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 network={ ssid="MySSID" ...
2
votes
1answer
2k views

Problem with DHCP on wlan

I can't get my raspberry pi to work properly with the wlan. The behaviour I'd like to obtain is: At boot tries to connect to a wlan if there is one available get a ip through DHCP and it's fine, ...
0
votes
2answers
7k views

Wi-Fi Setup Raspberry Pi 3 with WPS (Wi-Fi Protected Setup) not working

I'm using wpa_supplicant with wpa_cli and manually entering SSID and passphrase to connect to network works without problems. When using wpa_cli with command wps_pbc it sees the WPS enabled access ...
0
votes
0answers
346 views

Connecting Pi2 to hidden wi-fi network

I'm trying to connect to a hidden wi-fi network by following this guide. However, I'm getting an error log of: Successfully initialized wpa_supplicant wlan0: Unsupported driver 'wexit' Failed to ...
5
votes
2answers
26k views

Connecting to universities WPA2-Enterprise Wifi Network

As the title suggests, this question is very closely related to this question. And following the instructions by Lucas Goossen, I'm able to get a inet addr on my wlan0 (confirmed by ifconfig wlan0), ...
1
vote
1answer
40 views

Roaming Timing Optimization

Is there a way to improve reconnection timing between two RPis that communicate wirelessly through an access point? Right now, if a connection drops on a RPi side, The roaming process takes 9 seconds ...
1
vote
2answers
214 views

Pi can't find Wifi Dongle Upon Turning On/ Rebooting/Ifup

I'm having lots of trouble getting my Raspberry Pi wlan*'s to work. I already have several Raspberry Pi 2's that work perfectly with the exact arrangement I'm about to describe, but this one I just ...
0
votes
2answers
177 views

Two Wi-Fi networks. One preferred. Connect when it comes in range

I need to set up the pi so, that when one network comes in range it would disconnect from existing one and connect to that one more preferred. Here is my interfaces file: auto lo iface lo inet ...
7
votes
4answers
8k views

How do I configure wpa_supplicant with default iPhone SSID?

Newer iPhones will broadcast an SSID in hotspot mode as such: My Name\342\\\200\\\231\\s iPhone I observed this SSID in the GUI. When I grab the SSID via the command line: $ sudo iwlist wlan0 scan ...
6
votes
1answer
264 views

Issue connecting to internet after proper wifi configuration

I recently purchased a USB wifi dongle for my raspberry pi 2 B and attempted to connect through the Wifi Networks Panel Item in Raspbain Jessie. After entering the key, nothing happened, so I decided ...
1
vote
3answers
220 views

Raspberry Pi Wifi not scannning

I am using the Official Raspberry Pi adapter for my Pi but I can not scan for networks in the wpa_gui window like I should be able to. Under the tab "Current Status" in the "Status" field, it states ...
7
votes
2answers
2k views

Raspberry pi frequently disconnecting and reconnecting from wifi network

My raspberry pi 2 (running Ubuntu 14.04) with SIIG wireless mini adapter is unable to maintain a connection with the access point. It does not seem to be signal strength related, as it behaves well ...
2
votes
1answer
333 views

hostapd configured with wpa but running with wep

I have configured my accesspoint as WPA but it shows up as WEP secured on my laptop. My configuration is: interface=wlan0 driver=rtl871xdrv ssid=AnotherTest hw_mode=g channel=6 macaddr_acl=0 ...