We’re rewarding the question askers & reputations are being recalculated! Read more.

Questions tagged [xorg]

For questions pertaining to running, configuring, installing or troubleshooting the Xorg Server on the Raspberry Pi.

29 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
6
votes
1answer
1k views

How to start Xorg while showing splashscreen?

I'm creating a simple device with a Raspberry Pi and a touchscreen display connected to it. On boot, I want to show a loading image (a simple gif or jpg) while X is starting. Then a chromium-browser ...
3
votes
0answers
131 views

Raspberry Pi 4: Console on first HDMI screen, X11 on second HDMI screen

The new Pi 4 has two HDMI Ports. After booting Raspbian, the first screen (HDMI-0) should display the console and the second screen (HDMI-1) should display the X11 desktop. My first thought was ...
2
votes
0answers
46 views

Touchscreen calibration: touchscreen does not cover full display

I have purchased an industrial touchscreen monitor that supports Linux through PenMount drivers. The VGA video output (via HDMI adapter) works perfectly, and the USB touchscreen is perfectly ...
2
votes
0answers
262 views

How to disable sub-pixel aliasing for fonts

On running desktop environment pixel is hard readable all small texts, because default font sub-pixel aliasing don't correspond with my screen. So, how to disable font sub-pixel aliasing for all ...
2
votes
0answers
883 views

Change PiTFT 2.8" screen resolution

I have a Raspberry Pi 3 running Raspbian Jessie with a PiTFT 2.8" resistive screen. Everything is working great, except that the resolution is not optimal; icons and text are too big for the screen to ...
2
votes
0answers
552 views

running x on read-only raspbian

I am trying to run xserver on a read-only raspbian. I get the following errors. root@ClientX:/var/log# startx xauth: error in locking authority file /root/.Xauthority xauth: error in locking ...
1
vote
0answers
136 views

Touchscreen xinput calibration not working

I want to calibrate a touchscreen named "eGalax Inc. USB TouchController" on my Raspberry Pi. I think X and Y axes of the touchscreen are inverted. I used xinput_calibrator for this purpose. When I ...
1
vote
1answer
340 views

How to start xorg on a physically connected display via SSH?

The pi is configured to start into text mode so that no xorg libraries are loaded during normal operation. Yet I would like to be able to occasionally run a xorg desktop session when connected to an ...
1
vote
0answers
53 views

Do I need to start fresh? I think I messed up X-window

Long story short I can't get my pi 3 B+ to display kodi running on osmc because I jacked up the X-windows possibly? I'm wondering if there is a way for me to reinstall what is creating my GUI going ...
1
vote
0answers
353 views

Loading an ICC profile on Raspberry Pi doesn't work

I am using a Raspberry Pi 3 Model B (non-plus) together with the official 7 inch touchscreen connected to the DSI connector. The latest Raspbian 2018-03-13 is installed. This works fine, but the ...
1
vote
1answer
480 views

How to setup video/graphics correctly on the Raspberry Pi 3?

My question is similar to this. However I need to clarify some details. I can't find anything about this statement "I also read that the vc4 driver does not use the gpu_mem parameter, confusing ...
1
vote
1answer
731 views

PiTFT Touchscreen calibration is ignored by Pi Zero W

I'm using an Adafruit 2.4" Resistive PiTFT on my shiny new Raspberry Pi Zero W and I've finally managed to get the display configured but the touchscreen is proving a problem... (Please note that ...
1
vote
0answers
571 views

With the new openGL driver, can I make a resolution change permanent?

I am using the new openGL driver to run a WebGL app. It runs a lot smoother if I change resolution to 720p, which I can do with xrandr -s 1280x720 This works perfect, but resets after reboot. I ...
1
vote
0answers
226 views

XBMC on HDMI while Xorg on Official DSI Raspberry display

I have an RPi running Xorg Desktop environment on the official DSI display. Is it possible to have XBMC/Kodi or other software working on the HDMI output simultaneously?
1
vote
0answers
69 views

My USB2VGA is working - How do I configure X to use that screen?

I have a green screen on my USB2VGA connection (DisplayLink). How do I configure X to use the screen /dev/fb1 which exists? I do not find an xorg.conf.
1
vote
2answers
1k views

How to make startx open new X Session in tty7?

Before, when I launched x from the tty1 console, it would start the x session in tty7, allowing me to terminate it easily from tty1. Now (I do not know what changed it), startx from tty1 will open X ...
1
vote
2answers
6k views

Xlib: extension “RANDR” missing on display “:1.0”

I'm trying to run openvibe-designer on my raspberry pie over vnc. Currently I am using Xvnc version TightVNC-1.3.9. All other applications that I've launched over vnc have worked. I only get this ...
1
vote
0answers
1k views

No Screens Found Error

I am trying to get my AOC e1649Fwu USB monitor to work on my Raspberry Pi. I was following this tutorial, and got through all of the steps except building raspberry kernel image. It was discussed ...
1
vote
0answers
835 views

Raspberry Pi X-session fails to load over SSH

Am connecting from my Linux (Mint) desktop to the Fedora (rpfr18) Raspberry Pi using SSH X tunneling. When the Pi comes up, I connect to it from the desktop xterminal using: SSH -X root@192.168.x.y ...
0
votes
0answers
56 views

Raspberry Pi 4B no video - xorg fail

I have Rapsberry pi 4B with 2GB of RAM. After some time I powered up Pi but not video output was shown. So I connected via ssh but there is no :0: 16:02:32 up 13 min, 2 users, load average: 0.00, ...
0
votes
0answers
1k views

Xdotool Can't open display: (null)

I am using Raspian Jessie. I create a c++ program that it is execute as service at startup. It open a xserver session with chromium in kiosk mode and use xdotool to change the browser tab. The xserver ...
0
votes
0answers
572 views

Raspbian Lite: xinit at boot as soon as possible

Yes, another question on 'How to start the x server at boot' . I am new to linux admin things so I don't know how to do it correctly. I am using Raspbian Lite which does not include any graphical ...
0
votes
1answer
652 views

Pi 3 Xorg.cond.d missing and need to swap the axis for the eGalax USB touchscreen

I have a problem: xinput_calibrator doesn't work properly. After I touch 4 points my touchscreen's X and Y axis stay swapped. And I can not apply changes manually in the Xorg.conf.d directory because ...
0
votes
0answers
394 views

boot luakit (or midori) on bare X11 desktop (kiosk app, PI3, jessie)

I'm developing a kiosk app using PI3 and the PI Touchscreen. The app is served on localhost. I'm looking for the bare minimum wm that will allow the browser (either luakit or midori) to run and ...
0
votes
1answer
297 views

wpa_gui - X11 connection rejected because of wrong authentication

I am trying to use wpa_gui on my Pi2 from a windows machine using ssh inside MobaXTerm. When I do ssh -X pi@ I get X11 connection rejected because of wrong authentication. wpa_gui: cannot ...
0
votes
1answer
236 views

XDM display manager builds but does not run

I'm trying to modify the X display manager (xdm) source code in order to use it for a special purpose. However when I build and install it, it does not run and I end up getting the non-X login prompt. ...
0
votes
0answers
117 views

Is Raspbian Xorg server built in static form?

I have noticed that in Raspbian no default /etc/X11/xorg.conf is distributed and even if I create a file and modify it's contents it does not seem to take effect sometimes. This is where I studied the ...
0
votes
0answers
300 views

startx command fails after deleting /tmp folder

Okay, I have done something strange which prevents my RPi from entering a graphical environment. I was messing around with my Gertboard and was in the process of configuring the ATMEGA 328P ...
0
votes
0answers
2k views

Minimal Raspbian with X GUI

I installed a minimal build of raspbian, and installed xorg on it. However, when I run Xorg -configure, it tells me that no devices were found. Starting X server via xinit & and sshing into the ...