A message from our CEO about the future of Stack Overflow and Stack Exchange. Read now.

New answers tagged

1

I have tested the setup with a Huawai smartphone Android version 4.0.3 and a FAIRPHONE Android version 9. Both phones connected without any problems so it is difficult for me to debug an error that isn't present. Here are some ideas: From your tests the problem seems to be WiFi asoziation, the step before getting an ip address. So you should focus on ...


1

As far as I understand you want to have an access point that is connected with a WiFi client connection as uplink to your internet. All tutorials and automated scripts I know that work with the RasPi are made to use a wired uplink to the internet router router but not a wireless one. This is because it isn't an easy task to have a wireless access point and a ...


1

Turns out I can simply access my webserver through the wlan0 interface with a little configuration on the access point. I don't quite remember what it was exactly as I tried multiple things, but I believe the solution was to remove denyinterfaces wlan from /etc/dhcpcd.conf. Then you use ifconfig to find out what ip address wlan0 uses, and you use it to ...


2

OpenWrt is the best choice for you. It makes Raspberry Pi to a wireless router device and you don't need to run a lot of commands. Easy to use with an interactive web user interface named LuCi like picture below: I believe it going to help you better than in other ways. The thing you should concern is that you should don't attend this page. As this ...


1

Follow the instructions: sudo apt install git libmicrohttpd-dev git clone https://github.com/nodogsplash/nodogsplash.git cd nodogsplash make sudo make install sudo nano /etc/nodogsplash/nodogsplash.conf Change the configuration to: GatewayInterface wlan0 GatewayAddress 192.168.5.1 MaxClients 250 AuthIdleTimeout 480 Add nodogsplash command to rc....


0

One way would be to set a pseudo interface. If your eth0 IP address was 192.168.0.1 set up eth0:0 with IP address 192.168.0.2 (or whatever works for your address scheme and DHCP scope), then you should be able to use the 192.168.0.2 IP address for the web service. For syntax you could refer to https://www.tecmint.com/ifconfig-command-examples/.


1

Option 1: Using iptables The Network Authentication Type didn't work for me. But redirecting using iptables did the trick. These commands found here iptables -t nat -A PREROUTING -p tcp --dport 443 -j DNAT --to-destination localhost:80 iptables -t nat -A PREROUTING -p tcp --dport 80 -j DNAT --to-destination localhost:80 This redirects all requests ...


Top 50 recent answers are included