Hot answers tagged

175

"rpikernelhack" is a fake package name and a directory name used as part of a hack (in the sense of a dirty but expedient solution to a problem) to work around the fact that the Raspberry Pi foundation decided to make /boot a fat32 partition and dpkg does not get on well with fat32. I was the one who initially came up with the idea, though it was refined ...


49

It's just the directory name given by the developers who have created a Raspberry Pi specific set of patches to the Linux kernel. It is a fix by the Raspbian developers to fix a FAT file-system corruption issue present in the 2016 kernel, this updates to the 2017 kernel and is nothing to worry about. To make this kernel update you need to use sudo apt ...


23

This Answer is obsolete. The operation of mirrordirector has changed. Using terminal or your favorite text editor you can define a specific mirror to use in /etc/apt/sources.list Just comment out the line deb http://mirrordirector.raspbian.org/raspbian wheezy main firmware So it looks like this #deb http://mirrordirector.raspbian.org/raspbian ...


19

It looks like you are having problems resolving the various URLs that apt-get is fetching from. I would try the following: 1.) Check you have an active Internet connection, try google.com with a second machine for example. 2.) If your Raspberry Pi is attached to your home router, check it has an IP# assigned 3.) Try pinging google.com from the command line:...


16

I've adapted the instructions here to our case. First, create the following files in /etc/apt/preferences.d: jessie.pref: Package: * Pin: release a=jessie Pin-Priority: 900 stretch.pref: Package: * Pin: release a=stretch Pin-Priority: 750 Now, creating a matching set for /etc/apt/sources.list.d: jessie.list: deb http://mirrordirector.raspbian.org/...


15

First, install two packages on your Ubuntu system: qemu-user, and proot. After you mount the Raspbian SD card, you can do the equivalent of a 'chroot' with: sudo proot -q qemu-arm -S /mnt/path/to/raspbian/ From there, you can use apt-get commands as though you are actually on the Raspberry Pi. (Use the exit command to exit.)


15

There are two ways: Go to the PPA's web page, click on "Technical details about this PPA" and copy paste those lines into your /etc/apt/sources.list or create a new file at e.g. /etc/apt/sources.list.d/pj-assis-ppa.list with these lines as contents. Figuring out which Ubuntu version (for replacing YOUR_UBUNTU_VERSION_HERE) fits best to your Raspbian can be ...


14

Both Raspbian and Debian pride themselves in suppporting the "armhf" architecture. Of course, they mean two different things ! Raspbian "armhf": ARMv6 + VFPv2 Debian "armhf": ARMv7 Your scenario is impossible without mixing debian.org and raspbian.org/raspberrypi.org packages. You must have mixed those repositories in the past or are still using mixed up ...


11

if you are sure that subnet set in dhpcd config belongs to already configured interface (I'm guessing, wlan0). Compare IP subnets in /etc/network/interfaces and /etc/dhcp/dhcpd.conf . Also, on Debian (and thus Raspbian), check /etc/default/isc-dhcp-server, as it should contain name of your interface, like this: # Defaults for dhcp initscript # sourced by /...


11

I actually fixed this error going step by step, apt seems to have a bug in the way it handles ca-certificates-java and openjdk-8-jre-headless on raspbian. So I did : sudo apt-get remove openjdk-8-jre-headless openjdk-8-jre sudo apt-get install ca-certificates-java sudo apt-get install openjdk-8-jre-headless sudo apt-get install openjdk-8-jre # Optional, ...


10

apt-get is part of the Advanced Packaging Tool, the user interface for package management for Debian (and Raspbian, since it is a fork of Debian). In Debian (and its forks), there is this concept of a "package", a specific piece of software that can be installed and uninstalled. These packages consist of precompiled code, configuration files, and meta-...


10

It seems Python 3.4 is still in beta, and there is no package prepared for it yet. If youstill want python 3.4, you should download it and build it from source. You can find it here: https://www.python.org/downloads/release/python-340/ Download the source tar ball. The build instructions should be in there.


10

These are the steps you can follow. Grab latest source from this site. (http://php.net/downloads.php) Choose your nearest mirror. For example, I did "wget http://in1.php.net/distributions/php-5.6.10.tar.bz2" Unpack it: tar -xvjf php-5.6.10.tar.bz2 cd php-5.6.10 ./configure make -j4 (if you're compiling it on Rpi 2) else just make sudo make install Test it ...


10

Dirty Fix: Add a line of 'rpi': 10, to the end of list component_priorities in /usr/share/command-not-found/CommandNotFound/db/creator.py. Result should like this: component_priorities = { 'main': 120, 'universe': 100, 'contrib': 80, 'restricted': 60, 'non-free': 40, 'multiverse': 20, 'rpi': 10, }


9

Delete the file /var/lib/dpkg/info/libc.list (or the closest to that name), and then run sudo apt-get install libc --reinstall


9

As far as I am aware collabora is still using wheezy based software, it has not been upgraded to jessie. If you want to use that repository change its entry back to wheezy from jessie.


8

I suffered similar issue, and use this way to sovle it. First, comment out this in /etc/apt/sources.list: #deb http://mirrordirector.raspbian.org/raspbian jessie main contrib non-free deb http://apt.osmc.tv jessie main then do sudo apt-get update and sudo apt-get upgrade. Then recover the sources.list deb http://mirrordirector.raspbian.org/raspbian wheezy ...


8

For some reason, I couldn't resolve the default mirror's repositories. I added the University of Oxford's mirror (list of all Raspbian mirrors) to my /etc/apt/sources.list. For the folks who may follow, my sources.list file now looks as follows: # Original mirror #deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi # Oxford ...


8

The jessie-backports contain a precompiled armhf binary of the latest nginx mainline (1.9.10). ### add jessie-backports to sources.list echo "deb [check-valid-until=no] http://archive.debian.org/debian jessie-backports main" >> /etc/apt/sources.list.d/jessie-backports.list ### optionally add sources, as well ... it's GNU after all :) echo "deb-src [...


7

Try sudo apt-get --purge remove apache2 and then sudo apt-get autoremove. I had that same thing with emacs due to it installing other dependencies. emacs would still be there after --purge remove. Autoremove helped removing the dependencies which were installed with emacs.


7

I assume you are using Raspbian. It could be that your installation lists are broken. I suggest to reinitialize them by editing sources.list and raspi.list. By default they look like this: rpi ~$ cat /etc/apt/sources.list deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi # Uncomment line below then 'apt-get update' to enable '...


7

In my case this problem was solved by rebooting after installing updates, and before trying to install Docker. This will likely occur if you suddenly bring an older version of Raspbian up-to-date, and then straight away try to install Docker, as it appears some of the core binaries (or maybe even the kernel itself!) has been updated, the docker installer is ...


6

Follow the step-by-step guide provided by yours truly :-) First install XFCE4 (consider also installing the xfce4-goodies package for extra visual candy) sudo apt-get install xfce4 Then list all installed LXDE-related apps sudo dpkg --get-selections | grep "^lx" ...and remove them sudo apt-get remove lxappearance lxde lxde-* lxinput lxmenu-data lxpanel ...


6

Please note this answer is out-of-date and the current version of Raspbian is jessie, not wheezy. Make sure of which one you are using before you do anything. Your raspbi could not find a valid mirror so you need to find a working mirror. For valid and working mirrors please check http://www.raspbian.org/RaspbianRepository After getting valid mirror ...


6

Turns out I needed to expand the file system to make space for the updates..


6

sudo apt-get install libjpeg-progs


6

Looks like it's trying to use IPv6. I bet your connection doesn't have IPv6 (yet). Make a config file that disables IPv6. Run the command sudoedit /etc/apt/apt.conf.d/99force-ipv4, put Acquire::ForceIPv4 "true"; in it then save it. If you want a temporary solution, run apt-get -o Acquire::ForceIPv4=true update instead of just apt-get update to make it use ...


6

There is DNS related issues with mirorrdirector. See answer here : cannot connect to mirrordirector.raspbian You can remove deb http://mirrordirector.raspbian.org/raspbian wheezy main firmware from /etc/apt/sources.list then add another mirror found here to this file. Or, you can change /etc/resolv.conf to something like : nameserver 8.8.8.8 ...


6

You can try sudo apt-get install raspberrypi-kernel-headers if you're running raspbian. As suggested here https://www.raspberrypi.org/forums/viewtopic.php?f=91&t=154749


Only top voted, non community-wiki answers of a minimum length are eligible