New answers tagged

1

Alsa may be attempting to access the config file for the user (usually www-data) at ~/.asound. Make sure that the user has a home directory, and that it's accessible. As root: # mkdir ~www-data # chown www-data.www-data ~www-data Of course there are probably good reasons not to solve the problem this way specifically ... Usually it's a better idea to ...


1

Are you sure you are still using ALSA only? The Pi OS has recently switched to PulseAudio, so if you're using an up-to-date system you may want to poke around Pulse settings. Checking the kernel log (sudo dmesg) and the list of loaded modules (lsmod) might also help. Personally I would start by unloading the driver sudo rmmod <driver-name>, loading it ...


0

I also had this problem. Here is some background info I found. The audio message is a recently added feature to help visually impaired users to install a screen reader. It is part of piwiz which is used to configure the system on the very first boot. The idea is that you only hear the message on a brand new system and it disappears when you move past the ...


2

You should use the Raspberry Pi OS 2021-01-11. As stated in the Release notes there are some important bug fixes belonging to audio.


0

I got a similar problem. I checked the times of call_backs per second. It is about rate/chunks/2. I still do not know why it is half of rate/chunk. Have you figured out why? I think I have found the reason. The chunk is too small which results in too frequent callbacks. Maybe due to the limited CPU power of Raspberry Pi. It will lose some chunks. You can ...


3

No its a 4 channel i2s dumb board whilst the pi has a single i2s channel for a single l/r pair. Also there is a myth that an array on its own is somehow good but without the DSP simple summing creates some pretty bad high pass filters. https://invensense.tdk.com/wp-content/uploads/2015/02/Microphone-Array-Beamforming.pdf adafruit have a tutorial on how you ...


1

Powering everything with a single power supply and connecting all grounds to its ground terminal will eliminate the noise source in most cases but isn't always convenient. Replacing poor cables with better ones (with smaller resistance to ground) is not as drastic but often reduces the noise significantly. If eliminating the noise is not possible, you'll ...


0

Take 5V to your multiple USB sound cards from an USB splitter connected to your RPI. It probably need the same point of ground. I guess it can work. I moved the USB connector from adapter to RPI USB port. The humming 50Hz sound disappeared totally. This works for 5V powered audio. Some countries use 60Hz power supply.


0

I moved the USB connector from adapter to RPI USB port. The humming sound disappeared totally. This works for 5V powered audio.


0

I moved the USB connector from my 5V audio supply adapter to RPI USB port. That eliminated the buzz totally. The problem may be same for you, if you take the power from two separate 12V to 5V power supplies.


0

Take the common ground directly from audio jack or RPI USB


0

I moved the USB connector from adapter to RPI USB port. The 50Hz sound disappeared. This works for 5V powered audio. Some countries use 60Hz power supply.


0

There is a guy on YouTube named John Darko I believe that a addressed this in an episode. I bought a Schitt DAC per his recommendation but he does mention one that you can attach as a HAT because the power is noisy. He rigged it to run with batteries and it was much cleaner.


1

See if you can set the default audio sink device in Pulse Audio Volume Control settings, as described in this answer. Pulse settings are user-specific, so this has to be done for every user you create.


1

If you're using raspbian you could try this: In the top right, there is a volume icon, if you right click that you should probably see the HDMI option, make sure there's a green check mark next to it.


0

Try to setup audio output device like described in https://www.raspberrypi.org/documentation/configuration/audio-config.md I had the same issue, after update of rpi there was no sound anymore (HDMI in my case) - so nothing from aplay, chromium, etc running as pi user, but it works fine as root (or under sudo). User pi was initially (and still is) in audio ...


0

I have the same issue. If I connect the Pi (4B, latest update-version) via HDMI-Cable to my TV, the audio-output is normal and I can switch it to Analog (3.5) and HDMI. But if I only connect my active-speaker, restart the Pi without connect via HDMI, it shows "no audio device found". Is it possible to install an older Version of Raspbian, to be ...


Top 50 recent answers are included