New answers tagged

0

As @Ingo said, "We have seen many problems here on this site using it(/etc/rc.local)." The solution is to use systemmd or crontab


0

You need root permission to edit system files. This can be done with sudo nano but it is much better to use sudoedit sudoedit /boot/config.txt


1

When issuing your command, if permissions are denied, the easiest way to fix that is to run the command with root privileges. Like this: sudo nano /boot/config.txt sudo basically let's the command after it do whatever it wants (like in your case, let nano write to /boot/config.txt), so be careful.


0

Thanks to @Jaromanda X. Using user in fstab implies noexec, so add exec after user: /dev/sda1 /mnt/hd auto defaults,user,exec 0 1 However if you do not want to mount with exec flag you can run: $ sh start.sh (or another script interpreter). As the script is just a text file and the interpreter is on another partition (exec-able), it will run. One ...


2

You could also use tool called pinout


1

Raspbian comes with the systemd init system since version Jessie. I assume your system has this also running. systemd heavily uses dbus for interprocess communication and it seems that it is missing. Try to install it and reboot: rpi ~$ sudo apt install dbus


Top 50 recent answers are included