Hot answers tagged

14

Proxy arp is a way to build a pseudo bridge that is working on OSI layer 3 but it behaves like a real layer 2 bridge. So it is a good way to workaround the lack of WDS support on Raspberry Pi. Here is a way to set it up. In general I followed the tutorial (2). Have a look at it for the background. Example Setup ┌─proxy arp─┐ UPLINK ...


6

The problem was that there was no ground between the L298N and the Raspberry Pi. By wiring the Ground (-'ve) terminal on the L298N to a ground pin on the Raspberry (as well as the batteries) it then worked.


5

I don't know something about AWS VPC. But because it seems to be only a routing problem I will use openVPN for reference. For routing it should not be make a big difference. I will try to be as generic as possible. An issue is that it isn't possible to add a tun interface to a linux bridge. That's exactly what the error message tells you. On openVPN there ...


5

It is a bit unclear how do you want to connect the Laptop to the Raspberry Pi. I will assume that there is no other wifi router as access point running for example to connect to the internet so you want to connect to the RasPi direct by wifi. You tagged a bridge so it is possible to bridge the wired interface eth0 to wifi interface wlan0. If you setup the ...


5

In addition to the answer from @Milliways you have to enable 4addr support on the wlan interfaces with sudo iw dev wlanX set 4addr on. But if you try to add such an interface to the bridge you will get the error message Operation not permitted. Raspberry Pi does not support OSI layer 2 bridging for client connections on wifi (an access point can be bridged). ...


4

I strongly suggest to test this on Raspbian Jessie, but not on Stretch, as Stretch is difficult to configure from my experience, with many things breaking in totally unexpected ways. One really annoying breakage is that MAC48-based so-called "stable" but unfortunately unpredictable network interface names are now enforced. This makes any configuration unique ...


3

Try this tutorial: Start with a clean install of the latest release of Raspbian (currently Buster). Raspbian Buster Lite is recommended. Update Raspbian, including the kernel and firmware, followed by a reboot: sudo apt-get update sudo apt-get dist-upgrade sudo reboot Set the WiFi country in raspi-config’s Localisation Options: sudo raspi-config If you ...


3

You have many questions and as you see there are many answers. Btw. you cannot bridge a WiFi client connection. It is not supported by the on board WiFi chip. For further information about this issue you can look at Raspberry Pi WiFi to Ethernet Bridge for a server?. If you like to look at handmade solutions for Raspberry Pi you can look for Access Point ...


2

For the DHCP you can use "isc-dhcp-server" sudo apt-get install isc-dhcp-server For Made access point with an USBStick: wget https://github.com/jenssegers/RTL8188-hostapd/archive/v1.1.tar.gz tar -zxvf v1.1.tar.gz cd RTL8188-hostapd-1.1/hostapd sudo make sudo make install Complete tutorial


2

After some years there have been found a solution to this specific problem with Raspberry Pi. You very clearly described that you want to have a bridge on the RasPi but this cannot be done with a WiFi client connection to the router. For this it must supported by the WiFi chip but it doesn't. For further information about this look at Raspberry Pi WiFi to ...


2

Brdging an access point together with a wired ethernet interface is possible but connect to a local network with internet access together with using a vpn tunnel is a routing problem. So you can only use routing instead of bridging but that requires different subnets e.g. for your wifi, the vpn tunnel and for your local network. A working solution of this ...


2

So it occured to me that telling /etc/network/interfaces to "manually" add the network interface eth0 to my br0 bridge may answer my question: yes, indeed, this works. So my /etc/network/interfaces contains this: auto eth0 allow-hotplug eth0 ... up brctl addif br0 eth0 After quite some testing by pulling eth0 and later hot-plugging it back again I could ...


2

Example for this setup: bridge ┌──────────┐ bridge ┌───────┐ vpn-tunnel │ │ ┌───────┐ 192.168.179.1 │ (tap0)│════════════════════════╗ ╔═══════╪══════════╪═══════╗ ╔═════════════════│(tap0) │╱...


2

Try following this tutorial. I have something like this in my house to extend the WiFi coverage. I don't recall if I followed this exact tutorial, but these are the basic steps that I followed. I will paste the major steps from the tutorial here: Step 1: Install and update Raspbian Step 2: Install hostapd and dnsmasq Step 3: Configure a static IP for the ...


2

You are using an experimental kernel and presumably firmware, probably from running rpi-update. There are outstanding issues with the 4.19 kernel. "In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". ...


2

From debian.org i have tested ProxyArp and DHCP relay with parprouted, dhcp-helper and avahi-daemon packages and it's work for me on Raspbian. My other computer (ethernet connected device) get his dhcp IP addr successfully trought the RPi with full IP connectivity. Detail: I use bcm wlan0 RPi interface for internet wireless gateway (W.A.P on fire) ...


2

As you mentioned, it's easy to do it on Windows OS, however, it's a bit different on Raspberry Pi and Linux. I have looked up guides but they all seem to mention using the pi as a DHCP server, not too sure what I want/need this. In your situation, the phone is a device that has an internet connection. Obviously, the devices/clients must connect to ...


1

To answer your first question: to connect to your web server from outside the internet it is easier to have a static public ip address, e.g. from your provider. Then you can simply connect to this address or by its dns name. The other way your router gets a mostly dynamic public ip address from your provider. The problem is to get this always changing ip ...


1

First of all: you cannot bridge the interface from the built-in wifi device on any Raspberry Pi including RPi 4B if you use it for a client connection (uplink) to a hotspot. This is due to a hardware limitation with WDS and 4addr. For further information look at Raspberry Pi WiFi to Ethernet Bridge for a server?. Fortunately there is a workaround with ...


1

You haven't specified concurrent calls and if you are doing transcoding in Asterisk, but the short answer is YES a raspberry Pi 3 can do both if you don't have a lot of transcoding and playing a lot of voice prompts.


1

Please don't use the official guide. They are horribly mixing up things, setups and helper programs without understanding what they are doing. Beside other things they use configuration of interfaces with files in /etc/systemd/network. To use these files you have to enable systemd-networkd which is managing these files. For further information you may have a ...


1

A bridge does not work with ip addresses. It only uses mac addresses. That is the reason why you do not see an ip address on member interfaces of a bridge like wlan0 and eth0 if you show it with ip addr. It doesn`t help if you give these interfaces ip addresses. They will loose them as soon as you add them to the bridge. So you cannot use eth0 for ...


1

Ahh.. At last I connected to my LAN device from internet or from anywhere without router or by using pi and dongle only. steps are as followed :- Configure the USB modem. remember to use :- pi# sudo wvdial instead of pi# wvdial otherwise it will give a error & also change APN to given by network operator. after all this your pi should have internet ...


1

First you have to setup the 4G dongle to connect to your provider and this way you can get into the internet. You should be able to ping google.com from the RasPi. We cannot help you much with setting up the dongle because it is a specific device and not belonging to Raspberry Pi. If you have done it then you must have an interface representing the internet ...


1

The problem is that the Raspberry Pi Foundation does not show in its example Setting up a Raspberry Pi as an access point in a standalone network (NAT) how to configure a static ip address to the bridge. You can use Setting up a Raspberry Pi as an access point - the easy way if you like. Just go direct to the section Setting up an access point with a bridge ...


1

I have managed to get a working connection from wifi through to ethernet. I changed the network manager used on Raspbian to Network-manager-gnome and deviated from stretch-lite to stretch fully updated Install Network Manager Gnome sudo apt install network-manager network-manager-gnome Remove the unneeded package. (vital step else network-manager-gnome ...


1

You do not need a second wireless adapter. The Raspberry Pi is able to work as a wireless hotspot and simultanous connect to another hotspot as client. But the wifi device on the RasPi has a general limitation. The client connection cannot be bridged because lack of WDS (wireless distribution system) that is needed for bridging on wireless. But as you say ...


1

The above answer is great and helped me to save a lot of time with my setup, but I chose to make a few changes I thought I'll share. The setup is this: I have a Denon amplituner that has an Ethernet jack, but no wifi; it also doesn't have Spotify. Since it accepts HDMI input, I chose to use Volumio on a Raspberry Pi 1B - audio via HDMI, Raspberry gets WiFi ...


1

You must connect GND pin of your raspi to ground of bridge (- of battery) Then you can use these code for test : import RPi.GPIO as gpio gpio.setmode(gpio.BCM) #setpinout as BCM #Motor1 gpio.setup(m1in1, gpio.OUT) #m1in1 = motor 1 input 1 gpio.setup(m1in2, gpio.OUT) #m2in2 = motor 1 input 2 gpio.output(m1in1,True) #Set first pin High gpio.output(m1in2,...


1

You are missing ground / common connection between Pi and the driver board


Only top voted, non community-wiki answers of a minimum length are eligible