146

You can't install Google Chrome, but you can install Chromium. As other people have posted, Chromium is the code base out of which Google Chrome is compiled. Chromium is an open-source version of this browser. Simply type the following. Debian $ sudo apt-get install chromium-browser If you receive any errors running this command, try running $ sudo ...


44

I have a Raspberry Pi 2 running Raspbian Jessie with Chromium 45 installed. I found that you need to copy the existing autostart file to your local: mkdir -p /home/pi/.config/lxsession/LXDE-pi/ cp /etc/xdg/lxsession/LXDE-pi/autostart /home/pi/.config/lxsession/LXDE-pi/autostart So edit this local version: nano /home/pi/.config/lxsession/LXDE-pi/autostart ...


39

You can enter the following three xset commands xset s off # don't activate screensaver xset -dpms # disable DPMS (Energy Star) features. xset s noblank # don't blank the video device into the /etc/X11/xinit/xinitrc file (You should insert these after the first line).


29

It appears there is now a different autostart file to use located in /etc/xdg/lxsession/LXDE-pi/autostart To get Chromium to autostart follow these instructions Type sudo nano /etc/xdg/lxsession/LXDE-pi/autostart" Add the following line: /usr/bin/chromium --kiosk --ignore-certificate-errors --disable-restore-session-state "http://www.domain.com" Press ...


28

It's in the raspberrypi.org repository for Raspbian now. sudo apt-get install chromium-browser


27

I had the same issue. At raspberry pi forum I found this: You need to edit your script that's starting X. In the default build with lightdm the file to edit is /etc/lightdm/lightdm.conf in the SeatDefaults section it gives the command for starting the X server which I modified to get it to turn off the screen saver as well as dpms [SeatDefaults] ...


27

For Raspbian (Jessie), this solution worked for me: Create a new .desktop file in ~/.config/autostart/, e.g. sudo nano ~/.config/autostart/autoChromium.desktop Then add the following: [Desktop Entry] Type=Application Exec=/usr/bin/chromium-browser --noerrdialogs --disable-session-crashed-bubble --disable-infobars --kiosk http://www.website.com Hidden=...


22

This answer is outdated and should no more be followed. See https://raspberrypi.stackexchange.com/a/56231/42933 for—since October 2016—the most appropriate answer. As already shown in the previous answer, the general idea is to use Chromium builds from Ubuntu. Using their staging repository for Chromium security updates is probably not the only way, but not ...


18

I fixed this problem by installing xscreensaver via $ sudo apt-get install xscreensaver and disabling it from within the screensaver settings. Not the most elegant of solutions but it worked for me.


18

Edit this file sudo nano /home/pi/.config/lxsession/LXDE-pi/autostart And add this: @xset s off @xset -dpms @xset s noblank @chromium-browser --kiosk http://google.com/ # load chromium after boot and open the website in full screen mode Then reboot. Chromium should automatically launch in fullscreen mode after the desktop has loaded.


17

I've got it! Use --app=your.url For example: chromium-browser --kiosk --app=http://your.url.here


13

You can apply hildred's suggestion permanently by creating a ~/.xinitrc file: #!/bin/sh exec chromium --kiosk This will then be applied if you are using a graphical login, so that you do not have to boot to console. To test it from the console, try startx with no arguments.


12

As far as I know Google does not (yet) distribute Chrome binaries for Linux/ARM. (The only ARM binaries are for Android and these will not be compatible.) You might be able to cross-compile Chromium for Linux/armel (I have not tried but I am willing to bet that the RasPi itself is not powerful enough to compile it.) Also keep in mind that if you were able ...


12

Note that apt-get gives you a very old version of Chromium (v6). Hexxeh has a much newer build (v22): http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=11800 http://hexxeh.net/?p=328117859


12

Try sudo apt-get install chromium-browser


11

startx chromium --kiosk -- startx is a wrapper for xinit which starts an xserver and one client program. It should do exactly what you want.


10

Doable, but if chromium is minimised, you will still see a window manager/background. I would recommend using a lightweight window manager, like openbox with an empty menu file ~/.openbox/config/menu.xml, so a user cannot active any programs. Steps Install a window manager Configure window manager settings (blank config so no other programs can be ...


9

Edit /etc/xdg/lxsession/LXDE-pi/autostart and add these three lines @xset s off @xset -dpms @xset s noblank Log out, log in, verify it's working with xset -q


7

Use these commands to install chromium-browser on Jessie (not Wheezy): wget https://dl.dropboxusercontent.com/u/87113035/chromium-browser-l10n_45.0.2454.85-0ubuntu0.15.04.1.1181_all.deb wget https://dl.dropboxusercontent.com/u/87113035/chromium-browser_45.0.2454.85-0ubuntu0.15.04.1.1181_armhf.deb wget https://dl.dropboxusercontent.com/u/87113035/chromium-...


7

Okay so I found a solution here: https://www.raspberrypi.org/forums/viewtopic.php?t=191087 use raspi-config to enable OpenGL (Full KMS) remove "--disable-gpu-compositing'' from /etc/chromium-browser/customizations/00-rpi-var is all you need to do to get the https://get.webgl.org cube spinning. Works for me!


6

After finding out that Chromium is stuck at version 22 (current version is 31) I decided to switch to Firefox ie Iceweasel browser on Raspbian because it is kept updated.


6

Short answer There is currently no easy way to get a recent Chromium build on the rpib+. Options If you just want chromecast you could try some projects that don't use Chromium because the rpib+ is RAM limited (limiting Chromium functionality) and has a less popular CPU architecture (limiting your install options). If you really want a recent version of ...


6

OpenELEC appears to be an intentionally confined, minimal operating system. I assume it is simple to use, partially because you cannot do much with it beyond Kodi. Part of this is that it does not have much of a "package management" system. You cannot install a vast range of software the way you could on Raspbian; you are limited to the various "add-ons". ...


6

Raspbian Jessie Chromium boot to fullscreen: *Loaded Chromium-browser for Raspbian Jessie based on this site: -https://www.raspberrypi.org/forums/viewtopic.php?t=121195&p=818455 *And got the Chromium "boot to fullscreen" from this guidance: site: http://www.0atman.com/auto-start-full-screen-web-page-on-raspbian-jessie-startup.html Create a file called ...


6

Axel Beckert is correct in his answer, however any version of Chromium after 48 wont run on armhf (which is what Raspberry Pi 2 & 3 use) because of this bug: https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1563184 To correct this I modified DolbyOver's answer as follows: wget https://launchpad.net/~canonical-chromium-builds/+archive/...


6

I/O failure is a common cause of this; processes suffering from such are stuck in an uninterruptible sleep. If this is widespread and includes critical processes, the entire system will stutter and stall -- although from a GUI perspective this may be exaggerated in that it is mostly the GUI that is stalling. Such processes can be identified with diagnostic ...


5

By default the Pi the auto-logon X environment is done with credentials of the pi user. The config setting's of the Xserver environment of this user is in /home/pi/.config/lxsession/LXDE-pi/autostart, NOT in /etc/xdg/lxsession/LXDE-pi/autostart (this is the environment for the root user).


5

1) I dunno why --disable-infobars didn't work for you. This works well for me: chromium-browser --kiosk --disable-infobars \ http://URL1 \ http://URL2 \ http://URL3 2) A better way to refresh the browser (contents) would be to sent it Control-R? e.g. in your browser startup script, do: (while sleep 200; do xdotool key ctrl+R; done) & (I also send ...


4

Chromium is working fine and get reasonable performance on my Raspberry Pi. Better than Midori. sudo apt-get install chromium


Only top voted, non community-wiki answers of a minimum length are eligible