New answers tagged

0

Problem SOLVED! At least with the static Wi-Fi. After swapping a myriad of parameters, I finally completely deleted the /etc/network/interfaces, instead relying ONLY on the dhcpcd.conf. The latter's layout is now interface wlan0 static ip_address=192.168.200.100/24 static routers=192.168.200.1 static domain_name_servers=192.168.200.98 1.1.1.1 8.8.8....


1

Is there any reason you ignored the warning in /etc/network/interfaces? # Please note that this file is written to be used with dhcpcd # For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf' If you really must use static IP do it properly see How to set up Static IP Address


0

Based on the detail you added in Comments (which should be edited into your Question) I want to connect this standalone network to a laptop or mobile phone intermittently to capture data the system gathers over time (the system takes photos) You would be better to set up an Access Point The default setup for an Access Point includes a DHCP server and ...


0

I set up the ad hoc settings in the other Pi with a static IP address and was able to able to connect to the network


1

Although this question is a year old, it popped up in my Google search results, after I acquired a Raspberry Pi 4. I don't believe the other answers addressed the question, even though their results provide a similar behavior. Here is how I disabled dhcpcd and set a static IP on my Raspberry Pi 4 on Raspbian Buster Lite (should be the same on any version of ...


Top 50 recent answers are included