Hot answers tagged

21

How To Geek has a good article that covers this issue. In a nutshell .local domains are self-reported by each host (via Multicast DNS), and other machines on the network have to listen for them. Windows comes with such a service (LLMNR) however it's non-standard and therefore doesn't work terribly well. Instead you should install Apple's Bonjour service (...


9

I had the problem that my raspberry 3 couldn't connect to inet, but it had connection (no ping to google.com but it had ping to the ip address). So I figured it was a DNS problem. After a search I found this solution. Sorry, but I don't remember where, so I can't post the link. It's true that /etc/resolv.conf is created at every reboot, so you lose the ...


8

Edit /etc/network/interfaces file and add the following to the end: dns-nameservers 8.8.8.8 Don't edit /etc/resolv.conf since that file is generated automatically.


7

It appears that the /etc/init.d/dnsmasq script will automatically add the local machine as a resolver unless the lo adapter is explicitly disabled... start_resolvconf() { # If interface "lo" is explicitly disabled in /etc/default/dnsmasq # Then dnsmasq won't be providing local DNS, so don't add it to # the resolvconf server set. for interface in $...


7

In case someone else stumbles upon this, this might be useful: you could try avahi-resolve to see if it's a problem with the NSS integration or the actual hostname resolution try a tcpdump -i wlan0 port 5353 or igmp -w /tmp/mdns.pcap (IGMP) and wireshark /tmp/mdns.pcap (should work from both the pi and your laptop) to inspect what's sent over the wire and ...


5

I would try to change the domain to .lan. This is possibly an issue with mDNS (Avahi, Bonjour, etc) that use the .local domain. It could be that Windows tries to resolve the .local domain using mDNS. The other possibility is that the responses are rejected due to lack of DNSSec. Try to use nslookup router.local and nslookup router.local 192.168.2.10 on ...


4

Depending on how your router resolves names It might be helpful to install samba and winbind (even if you're not going to use it). It provides a couple more services that your router might be requiring for device resolution. sudo apt-get install samba winbind reboot and check.


4

There are 3 steps necessary to accomplish what you're describing: Create the bridge device. Assign an IP address to the bridge device. Configure dnsmasq to listen on the bridge interface IP address. Creating the bridge device is simple: sudo apt-get install bridge-utils sudo brctl addbr br0 sudo brctl addif br0 eth0 eth1 If you want it created ...


4

The short answer is that this depends on your home router. Most home routers now provide a domain name service in addition to the standard routing. They can vary in how they implement this and how configurable they are in providing the service. The router that I currently have at home does not append anything to the device name. In contrast, I've worked ...


4

On your local network you won't necessarily need to use DNS to access the Pi via a different host name. The .local domain, has been officially reserved as a Special-Use Domain Name (SUDN) specifically for the purpose of internal network usage. This way your custom local names don't conflict with existing external addresses. This will require a service ...


4

If you want a more robust setup, you can try pi-hole. It is an open source software package made to block ads network wide, specifically for a Raspberry Pi. Although it can also run on other platforms. It comes with a management interface and easy updating of the used lists.


4

There are several considerations here. The straightforward way is to log what the DNS forwarding (you've probably enabled) in your pi does. Typically, this will be a service such as dnsmasq, depending on how you set up the hotspot functionality of the pi. However, that will only tell you which URLs your children where browsing, and could include a lot of ...


3

I understand this question is quite old, and perhaps resolved in some way other than posted. However, I've posted an answer to a similar question on the Unix and Linux StackExchange. The short answer is that the GNU/Linux host Pc's Ethernet port needs to be setup with a network bridge through Network Manager's commandline tool nmcli. And then the Pi's OTG ...


3

Add 192.168.1.125 myrpi.dynalias.net to your hostfile. In windows it is normaly located at: c:\Windows\System32\Drivers\etc\hosts Linux: /etc/hosts


3

While there's nothing wrong with using .local internally in your home, you probably do not want to use it for anything other than mdns as used by avahi/bonjour because of the conflict. Bonjour uses .local and it is absolutely appropriate to use it in a home setting (i.e. from clients to refer to a device). I would not suggest using such a "well known" ...


3

You haven't actually specified a range. You should choose your own range end, but 50 could be a good start, e.g. dhcp-range=192.168.1.5,192.168.1.50,48h See https://wiki.debian.org/HowTo/dnsmasq Regards, Geoff


3

I've found a solution and created a script to share it. This script will download a list of known domains and block them by using dnsmasq. Those lists will be updated daily. Run ./adblocker.sh --install|--start|--stop to install, start or stop it. The script: #!/bin/bash installAB () { if [[ "$(crontab -l | grep adblocker.sh)" =~ adblocker.sh ]]; then ...


3

To understand what's going on here is to know something about link-local addresses and how avahi handles it. If there is a mostly small home network without a DHCP server then avahi configures a link-local ip address from the reserved address block 169.254.0.0/16 to the interface. It also maps this ip address to the name hostname.local. The DNS domain .local ...


3

I have tested it with a fresh flashed Raspbian Buster Light on a RPi 4B: $ sudo apt-get install bind9 bind9utils dnsutils Reading package lists... Done Building dependency tree Reading state information... Done The following additional packages will be installed: dns-root-data libirs161 python3-ply Suggested packages: bind9-doc ufw rblcheck python-ply-...


3

Relative to where you started, here are some issues that I think were part of your problem (and have been written into your updated question now): The router was providing multiple DNS servers. Although your internal server was listed first, this is not a binding order of search on the router. See, e.g., https://superuser.com/questions/1177175/change-dns-...


2

The fact that you have an IP does not mean that this is your public IP that actually can be accessed from "internet" side. Your global IP might be only a router IP. You have to contact your ISP to find your if your IP is public or behind NAT


2

Problem solved. I was connected on the same local network and my pc/smartphone was using local dns to resolve hostname instead of external dns, so using only 3g network, I tried to connect using No-Ip hostname and it worked fine.


2

what does ip addr show eth0 give as output on the rPi? This is useful to determine where the problem lies: Does your Pi have 2 IPs? (likely not based on what you showed from /etc/network/interfaces but worth checking) Is your network router caching a DNS entry for your raspberrypi.fritz.box name? You can check this from the admin settings on the router ...


2

I just had this issue, I was able to fix it by running sudo raspi-config, then going to Advanced, then Change Hostname, then Reboot. Give it a try.


2

Question has been answered in the comments itself OP had added ip=169.254.55.21 to boot/cmdline.txt, removing this fixed the problem


2

It looks like I found the issue. /bin/dhcpcd was still running despite no interfaces being configured via DHCP. The culprit is dhcpcd5. Removing the package helped (and, surprise, something called openresolv was included) root@rpi2:~# aptitude purge dhcpcd5 The following packages will be REMOVED: dhcpcd5{p} openresolv{u} /etc/resolv.conf is not ...


2

In order to set up routes, you'll need to set up dhcpd, which will assign local IP addresses, as well as push routes. In order to resolve hostnames, you need a DNS server, which BIND9 does a great job handling. The following uses domain.tld as the domain being used, and 10.1.0.1 as the GATEWAY/ROUTER's IP. Also, somename is used to represent a client to ...


2

The reason for your problem is due, most likely, the way your network interface is connected. Usually the default 'dns server' is your own router; in this case, the router will take care to resolve public and local names. Local names are captured by your router during the DHCP IP address assignment (or similar protocol). Routers, acting as DHCP Servers, ...


2

Did you enable IP forwarding? Try this: sudo tee << EOF /proc/sys/net/ipv4/ip_forward > /dev/null 1 EOF If it works, edit /etc/sysctl.conf to include this line, then reboot: net.ipv4.ip_forward=1


2

First you need to configure dnsmasq correctly, add the A records private class IPv4 only, I denoted three methods for resolving hosts (without using upstream servers for sure), example : NOTE: Assume 192.168.1.1 is the dnsmasq IPv4 listen address for the DNS server You must find associated parameters for choose a method how to serve the dns response What ...


Only top voted, non community-wiki answers of a minimum length are eligible