Hot answers tagged

8

The jessie-backports contain a precompiled armhf binary of the latest nginx mainline (1.9.10). ### add jessie-backports to sources.list echo "deb [check-valid-until=no] http://archive.debian.org/debian jessie-backports main" >> /etc/apt/sources.list.d/jessie-backports.list ### optionally add sources, as well ... it's GNU after all :) echo "deb-src [...


5

apt-cache search only searches for packages by name and description, not what they contain. For your intended use case you probably should use apt-file: $ sudo apt install -y apt-file ... $ sudo apt-file update ... $ apt-file search autoreconf autoconf: /usr/bin/autoreconf autoconf: /usr/share/man/man1/autoreconf.1.gz autoconf-dickey: /usr/bin/autoreconf-...


3

I had a similar problem on Raspbian: dpkg: unrecoverable fatal error, aborting: files list file for package 'init-system-helpers' is missing final newline E: Sub-process /usr/bin/dpkg returned an error code (2) This solved the problem for me: sudo mv /var/lib/dpkg/info/init-system-helpers.* /tmp sudo dpkg --configure -a sudo apt-get install --reinstall ...


3

Actually, there is some weird (but working!) way to avoid RaspBMC reinstallation in this case. Firstly, you should prepare the following script: #!/bin/bash echo "Start insserv clearing" cd /etc rm rc?.d/S* rc?.d/K* typeset -l l= while [[ $l != n ]]; do for x in init.d/*; do [[ -s $x ]] || continue x=${x##*/} ...


3

Remove all the files inside /var/lib/dpkg/updates directory with the following commands: cd /var/lib/dpkg/updates sudo rm * And then run this command to get the newer ones: sudo apt-get update


2

Mount the orginal image file sudo mount ./2016-09-23-raspbian-jessie-lite.img ../rasp/root -o offset=$((137216*512)) Copy /var/lib/dpkg again to the sdcard of the pi and everything worked.


2

I've finally got it working again. I downloaded the fail2ban package from the debian package repository using wget http://ftp.us.debian.org/debian/pool/main/f/fail2ban/fail2ban_0.8.13-1_all.deb. Once the package was downloaded, I used sudo dpkg -i fail2ban_0.8.13-1_all.deb. Then following that command, I used sudo apt-get -f install. And finally, I used ...


1

Either you don't have the armhf architecture set up in DPKG, or you don't have http://archive.raspbian.org/raspbian/dists/buster/main/binary-armhf/ in your APT sources. Or maybe you just didn't update your system for a long time. The former should be fixed by running dpkg --add-architecture armhf. The latter requires you to add APT sources as described here....


1

After continuing to search on the issue, I think I have solved it. I ran the following: sudo apt-get autoclean dpkg –-remove samba dpkg –-purge samba apt-get clean && apt-get autoremove (not 100% certain about the order) Then, I ran again sudo dpkg --configure -a sudo apt-get upgrade. For some reason, the issue seems resolved. Thank you all for ...


1

The error message indicates that there is a problem with the files list. The files list is updated with: rpi ~$ sudo apt update so this is the first you should do. And afterwards it is always a good idea to upgrade your installed software with: rpi ~$ sudo apt full-upgrade If this does not help you can try to completely reinitialize the files list.


1

You should better use the more up to date installation manager apt. It is just a wrapper for the underlying tools apt-get, apt-search and others but with additional functions. You will find with: rpi ~$ apt search autoreconf Sorting... Done Full Text Search... Done dh-autoreconf/stable 19 all debhelper add-on to call autoreconf and clean up after the ...


1

You should make sure, if there is any doubt, that the system is not actually rebooting due to brown-out as implied by other commentators (check uptime if you are unsure). I always use tmux when initiating updates. In a nutshell, this is a tool that allows you to (amongst other things) start a command, send it to the background, then check in on it later ...


1

You can download deb files on your laptop and move them to your Raspberry on a USB stick. Or connect your RPi to your laptop (with a cat5 cable) and use "internet connection sharing" on Windows to get the Raspberry online. Unless you are located somewhere where you're off the grid.


1

With the first attempt you try to install openSSL from the deb packages. This is very painful because openssl depends on libssl1.1 and this depends on debconf and ... (assuming Raspbian Stretch). You have to find all needed packages, dowload them on another computer and copy them to the RPi0. With the second attempt you use apt but that needs an internet ...


1

As @Jarmanda X commented, I had installed the https, unnecessarily. Then, from a different comment, I realized I had installed the debian packages, not the raspbian packages. To fix, I installed the libapt-pkg4.12_1.0.9.8.5_armhf.deb package first (dependency), and then the libapt-pkg4.12_1.0.9.8.5_armhf.deb package from here. A quick test of apt update ...


1

Seems you have really mixed up your packet manager. I suggest to reset its installation lists by editing sources.list and raspi.list. By default it looks like this: rpi ~$ cat /etc/apt/sources.list deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi # Uncomment line below then 'apt-get update' to enable 'apt-get source' #deb-src ...


1

Based on this Ask Ubuntu answer, you could: mkdir ~/dpkg-info sudo mv /var/lib/dpkg/info/libcap2:armf.* ~/dpkg-info This keeps a copy of the corrupted file(s) in ~/dpkg-info for whatever reason; if you don't want to bother with that use rm /var/lib/dpkg/info/libcap2:armf.* instead. Then: sudo dpkg --configure -a sudo apt update sudo apt upgrade ...


1

I don't know what version you are using. This answer is for Raspbian stretch. You should first upgrade: pi ~$ sudo apt update pi ~$ sudo apt full-upgrade Then install packets separate. No need to install python-pil. This will be install automatically with python-imaging. python-imaging-tk is only a virtual packet and will install python-pil.imagetk. So do ...


1

Originally, brcmfmac43430-sdio.bin was provided by linux-firmware-raspi2 package from ppa. But recent linux-firmware package from ubuntu also provides the same file. dpkg-divert solution is works for me. https://bugs.launchpad.net/ubuntu/+source/linux-firmware-raspi2/+bug/1691729/comments/4 sudo dpkg-divert --divert /lib/firmware/brcm/brcmfmac43430-sdio-...


1

The result you got is a symptom of a larger problem: systemd is designed to be a core part of an operating system, not something that is easily installed after the fact. Your time is likely better spent upgrading Debian to a newer version with a much newer systemd than trying to get a much newer version of systemd running on an older version of Debian. ...


1

Please check your raspberry pi configuration uname -a Follow the below steps copy the status file for future sudo cp /var/lib/dpkg/status /var/lib/dpkg/status-old empty the status file sudo echo "" >/var/lib/dpkg/status populate the status file sudo apt-get update Upgrade using the below command sudo apt-get upgrade Update the firmware sudo rpi-...


1

there seems to be no package, that installed it If it was a Raspbian package that installed it, either it was created post-installation or it comes from a repo which is not indexed properly. > sudo apt install apt-file [...] > apt-file update If the last command is new to you it is necessary to use "update" the first time (and occasionally ...


1

[SOLVED] the user @Milliways say it was a memory access violation. so i tried using a different sd card (i was using an 8gb class 6 and now i'm using an 16gb class 10) and everything went perfect now i can upgrade and install anything


1

It looks like you will have to upgrade your dependencies as well. Try sudo apt-get update && sudo apt-get install libssl1.0.0 libgd3 libpcre3 As you can see, you need libssl1.0.0 (>= 1.0.2~beta3), libgd3 (>= 2.1.0~alpha~), libpcre3 (>= 1:8.35) and then try installing it again by dpkg. If it doesn't install latest packages you need, you ...


1

See this question about the particular "can't locate *.pm" errors. It seems to me you have some issue related to your perl installation. If the above question does not resolve your issue, have you tried the following?: Running sudo apt-get update, prior to attempting the upgrade sudo apt-get remove perl, followed by sudo apt-get install perl (or sudo apt-...


1

it's a well known problem, the installation process hangs during "Setting up rsyslog" phase, and rerunning dpkg won't fix it. raspbmc actually advises against running apt-get update. you may just ignore it and keep watching your movies (xbmc should work just fine), or reinstall raspbmc from scratch, optionally backing up and restoring your settings with tar ...


Only top voted, non community-wiki answers of a minimum length are eligible