New answers tagged

3

I have an Rpi4 8GB with a WD Elements 2TB USB3 external HDD (USB3 powered from the Pi) and a Seagate Backup Plus USB 3TB (with its own power supply), both shared by the Pi using Samba and I can get 100 Mbyte/sec each way from either on my LAN, maxing out the Gigabit Ethernet. SFTP is slow because of encryption/decryption. Also, if the drives are formatted ...


0

After a while of scratching my head at wireshark and systemctl status dhcpcd.service, I decided to try a fresh install of Rpi-OS Lite. Still can't get static eth0 + dynamic wlan0.. But it did somehow fix hostname resolution, so I can ssh with <hostname>.local now. In retrospect this was probably the problem I should have pursued anyway, as it's much ...


2

You can Use systemd-networkd for general networking to solve your problem. Use section ♦ Create interface file for a wired connection and section ♦ Create interface file for a WiFi connection. For the WiFi connection you can use the example as given. It uses DHCP by default. For the wired connection comment option block: using a DHCP server and multicast DNS ...


0

I did something similar a few days ago. Do you wan to route between ethernet and wifi interface? On the static I think you are doing the right thing: /etc/dhcpcd.conf interface eth0 static ip_address=192.168.0.4/24 static routers=192.168.0.254 By adding a static IP (witch can also be done from the GUI) you should be able to connect to the r-pi from your ...


0

Andyroo gave a robust answer regarding ethernet hardware, but I don't think the issue lies there. I've used a variety of ethernet cables of different cats, many being over 10 years old as well, and never ran into any issues with them. Especially because you mention that it connects just fine to your laptop via that cable. It does not appear to be an issue ...


1

Gigabit Ethernet is supported on the Pi 4 (though the max throughput speed CANNOT be reached on the Pi)as as such it needs a cable with all eight pins connected: I think you will have a cat-5 or cat-5e cable that will not have the correct lines for the Pi. You maybe able to get this to work by setting the switch port to force a lower speed but this may not ...


1

Only the Pi4 can do 1 Gbit over the built in ethernet.


0

As @leanne said in the comments, you can use this command to keep network-manager (needed for some features) but disable MAC Address Randomization: printf "[connection]\nwifi.mac-address-randomization=1\n\n[device]\nwifi.scan-rand-mac-address=no\n" | sudo tee /etc/NetworkManager/conf.d/100-disable-wifi-mac-randomization.conf


1

Problem solved! The issue was my ethernet cable: even though all LEDs were on, and even though it worked on other computers, changing it made it work. I have no real ideas on why the Raspberry Pi didn't accept it, but still didn't complain about it...


0

When making the image from scratch, don't forget to enable ssh by creating a file named ssh on the SD before you put it in the pi. While you are at it, add a line to cmdline.txt that says ip=192.168.1.12 or similar. ( IP must be within the proper subnet.) When in a similar situation with other devices that don't have static ip capabilities, sometimes I ...


1

There are a number of problems that can cause your Pi to be not-recognized. I will dispense with the hardware connectivity; I assume you that works. If you do not know the Pi's address, and you have a DHCP server (often as part of you (A)DSL router or cable modem), you can check what new address is being handed-out. Pi's are normally B8:27:EB, DC:A6:32 or E4:...


5

You already reduced the setup to a minimum to locate the error. That's what I would suggest. But there is still your network environment involved. You can try to use a wired direct device to device connection. A fresh flashed raspios_lite_armhf will work out of the box with a wired connection. It either request an ip address from a DHCP server, or if not ...


3

The built-in WiFi device on a Raspberry Pi is limited to create only one access point. To have a second access point for a guest network you need an additional USB/WiFi dongle. All other access issues are then only routing settings. To have a wired connection to the additional guest network you also need a second USB dongle with an ethernet RJ45 port of ...


0

The Ethernet ports on the Pi (and indeed almost ANY computer) are galvanically isolated so normally have to direct electrical connection to the Pi. Ethernet DOES NOT provide any power. Normally USB to Ethernet adapters require power FROM the USB port. You can power the Raspberry Pi Zero over the USB-data port as it does not have any of the protection methods ...


Top 50 recent answers are included